Reply
Contributor
danholle
Posts: 26
Registered: ‎16-11-2009
Founder

Port forwarding does not work...?

Hello ---

 

I am trying to enable an inbound connection to a web server running on my home PC (Apache Tomcat).  This was working before;  something has changed.  After reading some things on the forum, it seemed likely that the router firmware (DSL2640R) might be the problem... I raised this issue with Support and they sent me a DSL3680.

 

With the new router, when I try to add port forwarding for port 80 to the local address of this PC (192.168.1.20), I get

     ERROR: FAIL TO UPDATE DUE TO... DUPLICATE PORT NUMBER !

 

This did not occur with the 2640R.  So I tried bringing up a web server on port 8080, and port-forward to this.  That worked locally;  i.e. I was able to access the website on this PC at http://127.0.0.1:8080 and I could access it from other machines on the network at http://192.168.1.20:8080, so I am thinking I don't have a firewall problem.  But coming in externally,

  • When I specify the address with :8080, the request times out.
  • When I skip the port and just try to hit the IP address directly, I now get a 403 Forbidden, saying I don't have access to /UI on the server (remote management redirect?).

Any ideas?

 

--- Dan

Super Contributor
Chrisbish92
Posts: 395
Registered: ‎04-06-2012
Founder

Re: Port forwarding does not work...?

Have you confirmed the port is open correctly?

http://canyouseeme.org/

Will be able to tell you.
Microsoft Certified IT Professional
Comp TIA A+, N+ | ZyXEL Certified Network Engineer.
View my Broadband Stats...
Community Star
Fred_Sheehan
Posts: 11,847
Registered: ‎22-03-2010
Founder

Re: Port forwarding does not work...?

Om most of the newer talk talk routers you have to set up a seperate VLAN (virtual LAN, sometimes called a virtual server in some routers) for the web server for it to be reachable from the internet at all.

 

This also solves the problem that port 80 is used internally by the router for its own config pages by default, hence your error message.

Contributor
ypango
Posts: 24
Registered: ‎02-11-2013

Re: Port forwarding does not work...?

I'm tryin to port forward other ports on the Talktalk DSL-3680 but also getting the following error message:

 

ERROR: FAIL TO UPDATE DUE TO... DUPLICATE PORT NUMBER !

 

Setting inputted into the portforwarding menu are: 

 

  • IP address: selected one in the active dropdown list
  • Protocol type: All
  • Public start port: 8621
  • Public end port: 8621
  • Connection: PVC0 (only choice)

 I've tried various other combinations of ports: 

30000-30000

30000-31000

8600-8700

8000-9000

 

All come back with the same error... 

 

What am I doing wrong?

Community Star
Fred_Sheehan
Posts: 11,847
Registered: ‎22-03-2010
Founder

Re: Port forwarding does not work...?

[ Edited ]