Reply
Contributor
trileymill
Posts: 45
Registered: ‎24-02-2012
Founder

Using TalkTalk SMTP from outside TalkTalk Network

Hiyah,

 My in-laws have an Kindle Fire which I set up for IMAP/SMTP email using the intructions on this site, it sends emails happily from both my network and theirs, but not from anywhere else (we're both on TalkTalk). It would appear that smpt.talktalk.net only allows connections from within the talktalk network, meaning on all other networks you can only receive emails (from imap.talktalk.net) and not send them. Also for some reason the TalkTalk webmail interface isn't compatible with the Kindle Fire so the whole situation is baffling for none techie OAPs.

 

I saw other suggestions of using open relays / smtp servers on your *current* network (ie. any number of ISPs etc) to send email rather than the correct talktalk smtp server.

 

Has anyone else experienced this, I don't use talktalk email myself so I can't easily diagnose this.


Dan

OCE_Karl
Posts: 6,211
Topics: 2
Kudos: 974
Solutions: 459
Registered: ‎04-11-2013

Re: Using TalkTalk SMTP from outside TalkTalk Network

Hi Trileymill,

 

They can change the settings of the outgoing server to use SSL (Authentication) with their email address and password, and set the outgoing port to 587.

 

Details can be found : http://help2.talktalk.co.uk/email-security?subcat=11479

 

Thanks

 

Karl.

 

 

Contributor
trileymill
Posts: 45
Registered: ‎24-02-2012
Founder

Re: Using TalkTalk SMTP from outside TalkTalk Network

Thanks Karl, I don't have their kindle or phone to hand to confirm, so I'll check these as soon as I can (I took the setting from this site so I'd hope they are right).

 

To confirm, you're saying that on the TalkTalk network you can access SMTP.talktalk.net *without* SSL, but from outside of the network SSL is required? Their issue is that the kindle correctly sends email when on either my TalkTalk wifi, or their own TalkTalk wifi, but when connected via any other ISP they can only receive and not send emails.

 

Thanks!

Dan

 

OCE_Karl
Posts: 6,211
Topics: 2
Kudos: 974
Solutions: 459
Registered: ‎04-11-2013

Re: Using TalkTalk SMTP from outside TalkTalk Network

Hi Dan,

 

Thats correct. If you set the smtp server to use authentication, and set it to use SSL on port 587, they should be able to send both on and off the TalkTalk network.

 

Thanks

 

Karl.

Contributor
trileymill
Posts: 45
Registered: ‎24-02-2012
Founder

Re: Using TalkTalk SMTP from outside TalkTalk Network

Brilliant, thanks will check this ASAP.

Dan

 

Contributor
trileymill
Posts: 45
Registered: ‎24-02-2012
Founder

Re: Using TalkTalk SMTP from outside TalkTalk Network

I can't seem to get SSL setting to work on either a Kindle Fire HD nor a TalkTalk Huawei Ascend Y210. When I try to select SSL/TLS on the kindle on outgoing smtp.talktalk.net the port changes from 587 to 465, so I change it back to 587 and it fails with 'Unable to finish account setup: Unable to connect to server safely'. On the Huawei I get a more detailed error message, 'Cannot safely connect to server. (SSL handshake aborted: ssl=0x2eb280: Failure in SSL library, usually a protocol error error:140770FC:smileyfrustrated:SL routines SSL23_GET_SERVER_HELLO: Unknown protocol. etc etc.

 

Is this a certificate issue with Android?

 

Removing SSL and taking the default ports then allows them to connect again, but obviously leads to the issue not being able to send mail outside TalkTalk.

 

the settings I'm trying to copy are from: http://help2.talktalk.co.uk/set-and-manage-your-email/what-are-talktalks-email-settings

Dan

 

New Contributor
Greg888
Posts: 2
Registered: ‎13-11-2013

Re: Using TalkTalk SMTP from outside TalkTalk Network

I'm having exactly the same problem. I'm in Australia. My mother is visiting and bought a Nexus 7. We're trying to set up her TalkTalk email using IMAP, but it will only receive, not send.

 

We've tried the same settings you - but no success.

 

Greg.

OCE_Karl
Posts: 6,211
Topics: 2
Kudos: 974
Solutions: 459
Registered: ‎04-11-2013

Re: Using TalkTalk SMTP from outside TalkTalk Network

Hi,

 

a few people are having issues with smtp auth off network.

 

We have verified that android devices require you to set the auth method to TLS on port 587 to send.

 

Can you verify these settings are correct on your device.

 

Thanks

 

Karl.

 

 

Contributor
trileymill
Posts: 45
Registered: ‎24-02-2012
Founder

Re: Using TalkTalk SMTP from outside TalkTalk Network

I wasn't able to connect using SSL/TLS on the Kindle Fire it defaults to port 465 so needed to be updated to 587 and still didn't connect. I was able to get it to connecting using security setting of "STARTTLS" which defaults to port 587, hopefully this will work off network too. I'll update here when I get a chance to test.

 

Dan

p.s.

Kindle Fire HD has the following options for Security:

  • None
  • SSL/TLS
  • SSL/TLS (accept all certificates)
  • STARTTLS
  • STARTTLS (accept all certificates)
Contributor
trileymill
Posts: 45
Registered: ‎24-02-2012
Founder

Re: Using TalkTalk SMTP from outside TalkTalk Network

I tested the kindle with the new settings this lunchtime and although it connects fine on my TalkTalk connection, out at the coffee shop on BT Fon it wouldn't connect to the outgoing mail server despite having the secure TLS settings above.

 

OCE_Karl
Posts: 6,211
Topics: 2
Kudos: 974
Solutions: 459
Registered: ‎04-11-2013

Re: Using TalkTalk SMTP from outside TalkTalk Network

Hi,

 

a few people have reported issues with off network access from different devices.

 

Our support groups are investigating presently to see if we can find a solution.

 

Thanks

 

Karl.

New Contributor
Greg888
Posts: 2
Registered: ‎13-11-2013

Re: Using TalkTalk SMTP from outside TalkTalk Network

Hi Karl,

 

Yes those settings are correct when I try to connect.

 

I start with:

Security Type: SSL/TLS    - Android only gives the option of "SSL/TLS", there's no option of "TLS" only. I don't know if this makes any difference.

Port: 587

 

I get an error:

Can't safely connect to server. (SSL handshake aborted: SSL=0x76ea2350: I/O error during system call, Connection reset by peer.)

 

Then the Port number is automatically changed to 465.

 

Greg.

OCE_Karl
Posts: 6,211
Topics: 2
Kudos: 974
Solutions: 459
Registered: ‎04-11-2013

Re: Using TalkTalk SMTP from outside TalkTalk Network

Hi Greg,

 

Thanks for the feedback on this one. There are a number of issues now reported with mail access off network on certain devices.

 

We will feed this back to the relevant support groups for investigation.

 

Thanks.

 

Karl.

Occasional Contributor
skynite
Posts: 7
Registered: ‎05-03-2014

Re: Using TalkTalk SMTP from outside TalkTalk Network

I am having the same issue as Greg888. Please can you advise how to resolve this issue.

OCE_Karl
Posts: 6,211
Topics: 2
Kudos: 974
Solutions: 459
Registered: ‎04-11-2013

Re: Using TalkTalk SMTP from outside TalkTalk Network

Hi skynite,

 

what device are you using?

 

Have you set the outgoing server port to 587.

 

Is your email address @talktalk or @tiscali etc.

 

Thanks
 
Karl

Occasional Contributor
skynite
Posts: 7
Registered: ‎05-03-2014

Re: Using TalkTalk SMTP from outside TalkTalk Network

I am using a android and yes I have changed the port number but get the error above
Occasional Contributor
skynite
Posts: 7
Registered: ‎05-03-2014

Re: Using TalkTalk SMTP from outside TalkTalk Network

My address is a talktalk.net
OCE_Karl
Posts: 6,211
Topics: 2
Kudos: 974
Solutions: 459
Registered: ‎04-11-2013

Re: Using TalkTalk SMTP from outside TalkTalk Network

Hi, 

 

What version of android - KitKat or Jellybean...

 

Thanks
 
Karl

Occasional Contributor
skynite
Posts: 7
Registered: ‎05-03-2014

Re: Using TalkTalk SMTP from outside TalkTalk Network

Jellybean (4.1.2)
OCE_Karl
Posts: 6,211
Topics: 2
Kudos: 974
Solutions: 459
Registered: ‎04-11-2013

Re: Using TalkTalk SMTP from outside TalkTalk Network

Hi, 

 

ok, and I'm assuming it's your main email address affected.

 

I've setup the account on my samsung here, running Jellybean also.

 

Imap works for incoming, but will not accept SSL for outgoing and will not allow me to send either.

 

Tried all combinations of SSL / TLS etc and no joy.

 

I'll raise a ticket to our network teams for this. - Can you update your forum profile with your Home Phone Number.

 

Thanks
 
Karl