Reply
Contributor
welshpilot
Posts: 28
Registered: ‎02-08-2013

Devices are slow connecting to router

[ Edited ]

Good evening,

 

I wondered if anyone is having the same issue as me at all.  I have had the router and broadband with TalkTalk for one week exactly but have noticed over the past four days that device (iPad, iPhone, Laptop, iMac etc) are taking a long time to connect to the router.

 

Router is:  DSL-3680 (DLINK)

 

I have looked in the advanced area of the router settings but cannot see anything that sticks out as being an issue to the setup of the router.  Its almost as if the device is taking an age to grab an IP address through DHCP.

 

As I have no idea, any help would be greatly appreciated as I have never come across this before.

 

Thanks in advance

Aled
Contributor
liubeliu
Posts: 53
Registered: ‎08-07-2013

Re: Devices are slow connecting to router

There is well known problem with Apple devices particularly Macs working on the N wireless standard. I had his on my Macbook and found solution was to change of wireless mode from B/G/N to G only in router settings.

Mine has been fine since I made change two weeks ago

Good luck
Occasional Contributor
Aeroadster
Posts: 11
Registered: ‎03-08-2013

Re: Devices are slow connecting to router

Change your Router settings to make sure it's always switched ON.

 

Go to the Router setup, and login with your admin account.

 

Find the ADSL Setup

 

Goto the PPPoe/PPPoa Internet Connection Setup section, and make sure "Idle Time Out" = 0

 

Reboot your router and check the setting is still set to "0".

 

You'll find that any device connects up much faster including your iPad. 

 

My kids have an iPad each and they appeared to not connect, until I changed this setting.  I also found that my Microsoft and Android devices connected instantly when they were the first device to attempt to connect to the internet for a while.

 

The problem is that the router disconnects from the internet after 30minutes of inactivity by default, so when it's in sleep mode the first device that connects seems to take an age (up to 15minutes) from my experience and any device that has connected previously will take an age to reconnect for the first time in that new internet session.

 

It also doesn't help that this D-link is a really nasty slow router and doesn't compare with the BT or Sky offerings in terms of range coverage and whilst it supports a similar number of concurrent connections, the performance really drops when 5 devices are connected and simultaneously active. 

 

I have a SMART TV, and the response time when accessing iPlayer is horrendously slow whereas with BT/Sky it's much faster, and in all cases the TV is connected directly to the routers Ethernet port using a well made CAT5e cable.

 

I've done a number of benchmarks in the three months as I've switched from BT to Sky and now to Talk Talk.  I might change the router for one of my Drayteks.

 

The router is also configured for WPA2 only now and I'm not seeing any difference in response time or performance and the Internet still appears to drop out frequently. 

 

I live in a block of flats and my work colleagues who have stayed with Sky/BT/Plusnet don't have the problem I have.  If these problems continue, I'll cancel this contract and go back to BT or Sky.

 

I'll try seeing whether upgrading from the 1.03t firmware to a beta or newer version will help.

Contributor
welshpilot
Posts: 28
Registered: ‎02-08-2013

Re: Devices are slow connecting to router

Hi both. Thank you very much for your help. As soon as I got the router I changed the interval timeout to = '0' , however, now I gave changed the router from BGN to G, it seems to running smoothly with a 10 meg downstream so that's great news. Thanks chaps!
Aled
Occasional Contributor
benedictwarner
Posts: 7
Registered: ‎03-08-2013

Re: Devices are slow connecting to router

Thanks for the suggestions, everyone.

 

We've been having the same problems since joining TalkTalk this week: the first device to connect to the WiFi seems to take ages to get through to the internet, and the router doesn't seem to be able to handle all our devices (two laptops and two phones) at once - two seems fine, but if a third device connects, one of the first two tends to get bumped off. God forbid we buy a smart TV!

 

We've also noticed several dropouts in connection already in the few days that we've been connected, all of which is quite a change from our previous provider (Virgin).

 

We've already contacted TalkTalk's tech support, who are working on the issue, so I'm unwilling to play about with the settings as you've suggested until they've had a go at everything, but given the quality of both the router and the connection, and from speaking to other friends and colleagues who have used TalkTalk, we are seriously considering just buying our way out of the contract and finding another provider. It's been a shame, switching to TalkTalk for the first time - they had an opportunity to impress a new customer and keep us for years, but instead they've given us a dud router and a dodgey connection!

 

As an aside, it seems a bit bizarre that there is a 'cooling off' period when you sign a new contract with TalkTalk, but only until your 'go live' date - so the cooling off period ends before you get to try the product/service! It seems to defeat the purpose of a cooling off period, to me, as I don't know how you are meant to assess whether the service is for you until you've had a chance to try it!

~ MacBook (White, 13", 2007), 2Ghz Intel Core 2 Duo, 2GB RAM, 320GB HD, Mac OS X (10.6.8) & Ubuntu 12.04 ~ iPhone 4S 32GB, iOS 6.1.3
Occasional Contributor
Aeroadster
Posts: 11
Registered: ‎03-08-2013

Re: Devices are slow connecting to router

Hmm, the cooling off period remark does concern me.

 

I'd have to check the contract, but a cooling off period should really be sufficient enough for you to try out the service first and for you to reject it, within a reasonable timeframe - usually around 14 - 30days.

OCE_Michelle
Posts: 48,005
Topics: 4
Kudos: 1,018
Solutions: 420
Registered: ‎03-11-2008

Re: Devices are slow connecting to router

Hi 

 

I'm really sorry to hear this. Are you using the 3680 router? Is the connection ok if you connect in a wired state? I've also raised the wireless issue to our Products Team who are investigating at the moment.

 

Be sure to give kudos and accept your solution


Frequent Visitor
DavePesto
Posts: 1
Registered: ‎11-08-2013

Re: Devices are slow connecting to router

[ Edited ]

It sounds like the same Apple product-related issue (although I do experience the same problem with my Advent printer that does not connect to the WAN when 'N' is one of the band-options). Simply go into your router settings (192.168.1.1) click on the 'wireless' tab and change the wireless mode from B/G/N to just B/G. Fixed the problems with slow connection for me.

 

Good luck.

Occasional Contributor
benedictwarner
Posts: 7
Registered: ‎03-08-2013

Re: Devices are slow connecting to router

Hi Michelle,

 

Thanks for the reply, I'm sorry not to have got back to you sooner. We are using the 3680 router; I'm afraid I haven't tried it in a wired state.

 

We went through TalkTalk's tech support, but unfortunately when they sent a text message to ask if the problem had been fixed (after they had done their magic at their end), it came at a time when all our devices seemed to be working, so I replied with 'FIXED'. 30 minutes later we could no longer connect all our devices at once.

 

Our problem is identical to that described by stevec67 in this thread, which I believe you've addressed as well, Michelle. The router appears to be connected to the internet, and our devices appear to connect to the router, but our devices don't always connect to the internet - it usually takes a good 15 - 20 minutes before one of them seems to wake up the router. Even then, it doesn't work for all devices at once.

 

Having gone through TechTech's support without much success, I have just tried changing the Idle Timeout setting to 0 as suggested on this forum. I haven't yet changed the wireless mode from B/G/N to B/G as I am unwilling to downgrade my speed, but I gather this may be necessary for Apple products (all of ours!). 

 

I saw on the thread linked above that you are working on a firmware update that may fix these problems, and offered stevec67 an opportunity to test it. Would it be possible for us to do the same? I have added our phone number to my profile on these forums.

 

Thanks for your help!

 

 

~ MacBook (White, 13", 2007), 2Ghz Intel Core 2 Duo, 2GB RAM, 320GB HD, Mac OS X (10.6.8) & Ubuntu 12.04 ~ iPhone 4S 32GB, iOS 6.1.3
OCE_Debbie
Posts: 40,891
Topics: 1
Kudos: 1,057
Solutions: 485
Registered: ‎03-11-2008

Re: Devices are slow connecting to router

Hi benedictwarner

 

Please can you post on the thread below and we can then test the new firmware

 

http://community.talktalk.co.uk/t5/Unlimited-Broadband/D-Link-3680-Wireless-problems/m-p/926550#U926...

 

Thanks

Be sure to give kudos and accept your solution


Contributor
welshpilot
Posts: 28
Registered: ‎02-08-2013

Re: Devices are slow connecting to router

Now that the original issue has been resolved and I have accepted the correct answer, how do I stop emails coming through to me to tell me someone has posted a new comment? Thanks
Aled
OCE_Michelle
Posts: 48,005
Topics: 4
Kudos: 1,018
Solutions: 420
Registered: ‎03-11-2008

Re: Devices are slow connecting to router

Hi welshpilot,

 

You can unsubscribe from your post, however as you've advised that your original issue has been resolved I will close your thread :smileyhappy:

 

Be sure to give kudos and accept your solution