Your Account

Get tailored support with your TalkTalk account and bills.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't see large area of my on-line bill

MikeBoardman
Participant
Message 10 of 10

When I log in to My Account, I can only see the "standard" parts of the web page: the "TalkTalk for everyone" etc headings, and similarly for the bottom part. The middle section is just white space. I've even tried to copy and paste that area in case it's hidden, but there is nothing there. The top area shows “Log out”, so I assume it has accepted all the log-in details. Everything worked properly until about four weeks ago, and I don’t remember having changed anything recently that might have caused this.

Clicking on the "Bills and Payments" dropdown shows the usual options, most of which work but the "Bill Summary" produces no response. (That may be expected as presumably I'm already on that page. Nonetheless, it shows as a clickable link.) In addition, some of the other pages on this dropdown don't load properly (eg "Make a card payment") - they start to load but have a grey overlay and the text doesn't change from the page I'm already on.

This is the same on various browsers: Edge, Firefox, Opera, Brave. I've turned off extensions, but nothing makes any difference. Oddly, using my smart phone allows me to see the pages browsers don't. (I haven't checked all of the differences - life's too short!)

I've spoken to TalkTalk twice for a long time on each occasion, and they've assured me it will be fixed shortly but nothing's changed. Last time, they gave me a tech helpline number to contact but before I do that, has anyone else experienced this kind of problem and/or have any suggestions as to how to fix it?

Many thanks in advance.

0 Likes
9 REPLIES 9

Message 1 of 10

Hello,

 

I'm sorry for the delay. How are you getting on?

 

Thanks

 

0 Likes

martswain
Philosopher
Message 2 of 10

@MikeBoardman, it's obviously your machine that is the issue, what Anti Virus/Malware are you running ?

0 Likes

Message 3 of 10

Thanks, but I'm afraid I had already tried that with no luck. I've done it again, same outcome.

0 Likes

Message 4 of 10

Thanks, but as I mentioned in my query, I have tried four browsers, all with the same negative result.

0 Likes

AllyM
Insightful One
Message 5 of 10

I installed Brave browser out of interest (Edge/Firefox always worked fine for me), and found that all pages were blank in MyAccount as per your earlier screenshot. I disabled the "Trackers & ads blocking" option in the Brave browser settings and everything appeared.

 

If that doesn't work for you, and you've tried several browsers, then there must be some other ad/pop-up/tracker blocking running on your PC/laptop/whatever device you are using which is causing the issue.

 

martswain
Philosopher
Message 6 of 10

@MikeBoardman  As it's likely to be an issue with your BRAVE browser, time to see what extensions and blockers are incorporated, then disable them one by one.

 

It would seem that it blocks a lot by default.

0 Likes

ferguson
Community Star
Message 7 of 10

Apart from try a different browser? 

0 Likes

MikeBoardman
Participant
Message 8 of 10

OK, thanks for taking the time and trouble to reply.

However, having tried your suggestion, I find it makes no difference (Brave browser - I'm not going to trail through other browsers to see if any of them work, as it seems really unlikely to be successful).

For reference, this is all I'm seeing:2021-09-18 TalkTalk screenshot.jpgAny further ideas?

0 Likes

Arne-TalkTalk
Support Team
Message 9 of 10

Hi @MikeBoardman

 

Disable your pop-up blocker and Ad blocker for the My Account site and this will fix that problem.

 

 

0 Likes