Broadband help

For queries about your TalkTalk broadband service.

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Asus DSL-AC55U Router Setup for VDSL

First Timer
Message 21 of 21

Today I purchased an Asus DSL-AC55U VDSL router to replace my current HG633 for increased wi-fi capability.

I used the Asus quick internet setup and chose Talktalk and auto IP and was unable to connect.

I then ran setup again and chose PPPOE but was unable to complete this as have never had the login and password, which I understand is coded into the HG633 before delivery.


I rang Asus for advice and they said as it was a non standard router I would need to ask Talktalk for the login details.

I then rang Talktalk who assured me it was not required and that the Asus router should just connect automatically. I tried again and it didn't.

I rang Asus again and they said I would DEFINITELY need my PPPOE login details.

I rang Talktalk again and asked for my login info and the advisor had no clue what I was talking about.

She spoke to her 'manager' and returned to say that they have no such login info to give me.

I said that my login ID before VDSL was, where xxxxxxxxxxxxxxxx is my landline number.

She agreed and when I pressed her further she gave me a possible password in the format FTTCXXXXXX.

I tried this together with my phone number based ID and still got no luck.



After wasting a whole day, someone is lying to me.

Do I need a PPOE login and password? Are Talktalk really not able to release the info??

Am I just going to have to return my nice whizzy router and live with the flaky HG633???


Thanks in advance.



Message 1 of 21

TT have just added the basic Fibre settings to their Set up a non-TalkTalk router info.


I got an ASUS DSL-N16 working as a result but still needs some fine tuning.



Message 2 of 21

Assuming you have the option, try configuring the modem for 'no password required'. I had this with my D7000, provide a password means it will refuse to connect. Configure VDSL, no password required - now connected.


Message 3 of 21

I’ve got a ASUS dsl-ac52u router and I’ve spoke to talktalk and they say they cannot give me my password as it automatically athenticates my isp. Also Talktalk said because of my type of line fibre the asus router might not work. I’m going to speak to Asus in the morning and see what they say. Any help would be greatly appreciated Thanks


Message 4 of 21

Yes. I run asus dal ac68u on talk talk and firs you have to call talk talk ask for your login details and pass. I did it and all works fine. good luck


Message 5 of 21

I’m having issues with a similar modem, what settings did you use?

Message 6 of 21

Ive bought this router Weekend just gone and was up and working very quickly didnt have to really set up any passwords apart from the one for the router itself just getting to know the layout and tweaks it improved my upstream to double than with the crappy  hg633 but having awful downstream rate as the old router has kicked in the DLM system before i changed over think its just a waiting game now until the speed starts to increase will report back to let you know how soon things have changed back 

To Give In Is To Accept Defeat

Popular Poster
Message 7 of 21

Ever get this sorted?

Stuart Goodrick

First Timer
Message 8 of 21

Hi there, have you got a TalkTalk account where you can check your bills and stuff? My Account at top of the page, the PPOE login and password is the same as you account login, well it was for me any way..


Hope this helps.


Message 9 of 21

Just purchased a X4S Netgear night hawk.


It wont let me specifiy my username and passworde.g. but it i go through the automactic setup it works fine but selects the option:


DOes you internet connection require a password and the radio button is selected to off.


Its the only way it will work (for me anyway)




Richard B

Message 10 of 21



I too am on fibre. Can't even get it connected to the internet. Has anyone been successful in connecting this on talktalk?


Message 11 of 21



I too am on fibre. Can't even get it connected to the internet. Has anyone been successful in connecting this on talktalk?


Message 12 of 21

Hi everyone I've just got myself this router I have my login details and tried multiple settings. Tried connecting via adsl and Vdsl I have the fibre package on both settings the router is connecting to the internet but it won't let me connect. Keeps asking me to check my settings although I have tried all different settings. 


Any help would be great thanks




Message 13 of 21

Or go back to ASUS, if they say it will support TalkTalk then it is their responsibility to help you set it up.


Message 14 of 21

A long time a go in another life I ran a technical support help desk. We specified the kit the users should use, because we could support it. Sometimes we were asked, "will XYZ work instead?".


Our position always was, "we don't know, please use the kit we specified, we know that will work, and if it doesn't we'll help you". 


Some users still came back and insisted on trying to use their piece of XYZ, and when they couldn't make it work, hoped that we would solve their problem. To which we replied: "please use the kit we specified, we know that will work, and if it doesn't we'll help you."


Maybe the ASUS will work on the TalkTalk network, maybe it won't, but TalkTalk's helpdesk is only ever going to point you back at their suggested (supplied in fact) kit. After 14 years on broadband (ADSL in 2002, VDSL for last 5 years) I have only 3 weeks ago started using a TalkTalk supplied router, the DL-3782, and it is working well. They are on restricted availability at the moment, but maybe you could ask for one.

Now surfing from a Dell Inspiron 3881 running Windows 11 and a Qualcomm QCA9377 Wireless Network Adapter with Sagemcom FAST 5364 router.

Message 15 of 21

Just tried Automatic IP and had no luck.

There is now a section for 'Special Requirements from ISP' which includes a space to input a 'Host name'.

Could this be it? I would need to talk to useless TalkTalk again and prise it out of them perhaps.


Message 16 of 21

Go for Automatic IP.


Message 17 of 21

The other 2 options are:

Automatic IP

Static IP


Message 18 of 21

You have WAN connection type as PPPoE, that is wrong, what other options are there for that setting?


Message 19 of 21

Thanks Ferguson for the quick reply.

I believe I already have but setup insists on a PPP username and password and won't complete otherwise.


My settings are:

Transfer Mode              VDSL WAN (PTM)

Service Unit                   Internet

Enable?                          Yes


IP Version                      IPv4

WAN Connect Type     PPPoE

Enable UPnP?               Yes


802.1Q enable?            Yes

VLAN ID                         101

802.1P                            0


IP Universal Settings 

Default Route               Yes

MTU                               1492


Get WAN IP automatically          Yes

Connect to DNS automatically   Yes

Enable NAT                                    Yes


(asks for PPP username and PWord)


PPP Authentication            Auto

TCP MSS                              0


Have tried changing a few options but with no luck.

Any thoughts welcome.


Community Star
Message 20 of 21

You need DHCP/IPoE authentication. And better support from Asus.