cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Broadband speed 50% of what it used to be...

Reply
9 REPLIES 9
Highlighted
TimWN
First Timer

Hello.  TalkTalk HomeHub is reporting 20Mbps download speed in it's GUI.  Speedtest from devices shows same result. 

 

My minimum guaranteed is 35Mbps (estimated 39-48Mbps) Until recently I used to get around 32Mps

 

Same house, cabling etc, nothing changed.  Done all the usual:

Powered off all devices except hub

Checked for faults - none

Powered off hub for 30mins

Reset router to factory defaults

Firmware seems current


None of the above did anything, still 20Mbps download.

 

Can someone from TalkTalk please check what the issue is?   Thanks in advance.

Highlighted
Community Team

Morning Tim,

 

I've run a test on the line which hasn't detected a fault, however I can see quite a few re-connections on the line which can affect the sync speed. Is your connection also unstable?

 

Does your master socket have a test socket? Is the voice service ok with no noise on the line?

 

Thanks

 

Highlighted
TimWN
First Timer

Hello.  Thanks for reply.

 

I do not see any connection stability problems in normal use, but can run a continuous test to monitor.  Any recent drops might be a result of me trying to diagnose the issue.  As I said before, on my side nothing has changed and until recently all was well.   

 

I don't have a phone handset available to test the phone line until next week, since I have no use for the landline.  

 

The master socket (5C) does not have a test socket fitted.

 

Best regards

 

 

Highlighted
Community Team

Hi TimWN, I've run a line test and there's a minor fault showing, it's more than enough to cause this problem. I've raised the fault ticket for you and hopefully this won't take too long to clear. 

 

Ady

Highlighted
TimWN
First Timer

Thanks Ady.

 

I ran a test for 24 hours, pinging TalkTalk's DNS server and another shorter test of 6 hours to Google DNS for same period.  There does appear to be a drop occurring almost every hour in case it helps.  Attached the screenshots in zip.

Highlighted
Community Team

Hi TimWN,

 

The fault has been passed to Openreach for an external line investigation and we should receive an update within the next 48-72 hrs.

 

Thanks

 

Highlighted
TimWN
First Timer

OpenReach Engineer turned up yesterday (good service!).  He could see that the speed had halved since 28th December and after diagnostics, the fault appears to be something external.  He redid the connections in the cab and ran a remote test from there which then showed 38Mbps.

 

My router is now also showing 38Mpbs but I am not seeing this.  I have exactly the same sub 20Mpbs performance as before, wired or wireless, different devices.

 

What next?  

Highlighted
Community Team

Hi TimWN

 

Please can you power down your router for a full 30 minutes and then run another speed test?

 

Thanks

 

Debbie

Highlighted
TimWN
First Timer

Hi Debbie

I did that today and now I am getting 48Mbps!

thank you very much, case closed.

Highlighted
Community Team

Hi TimWN,

 

Thanks for trying this and I'm glad to hear that the speed has increased 🙂

 

Thanks