Broadband help

For queries about your TalkTalk broadband service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Broadband speed

Anonymous
Not applicable
Message 16 of 16

I am having a problem with inconsistent broadband speeds. As recently as this morning I checked the speed and the first check gave a speed of around 8mbps. I immediately tested again lierally within seconds and the speed showed as 30.6mbps. How can this be? Could it be a router problem as I have had this router for at least 3 and a half years. I have carried out a test with an ethernet cable and it returned 36mbps so could this be the router. Could you advise please. Thanks.

0 Likes
15 REPLIES 15

Message 1 of 16

Hi pilgrim6,

 

How are you getting on?

 

Thanks

 

0 Likes

Message 2 of 16

Hi @Anonymous 

 

Debbie has asked me to help you. Slow speed, intermittent dropouts, breaks in the signal, or no signal on some or all devices, might be caused by Wi-Fi interference from other local networks, which can also lead to a permanent reduction in speed. No ISP can be responsible for your local environment, this is mainly a by-product of the popularity of Wi-Fi.


If you have the HG633, HG635, DSL-3782 or the TalkTalk Wi-Fi hub, they are dual-band routers & offer both the older 2.4GHz & the newer 5GHz Wi-Fi bands. The problem is these are two different networks (SSIDs), but they share the same name, so you can't tell which one you are connected to. Log into the router (http://192.168.1.1) and enter a username of "admin" and if the HG635 a password of "admin" as well, or if the HG633, DSL-3782 or the TalkTalk Wi-Fi hub, use the unique router password (see the label on the rear of the router at the top).

HG633/635 go to:-
"Customise my wireless network"

Append "5G" to the end of the network name of the "Wireless 5 GHz SSID" field. Then click "Save".

DSL-3782 go to:-
Settings > Wireless (Wi-Fi)

Append "5G" to the end of the network name of the 5 GHz "SSID" field. Then click "Save".

TalkTalk Wi-Fi hub

Go to:-
Dashboard > See Wi-Fi Settings > Manage Advanced Settings > Wi-Fi 5Ghz gear icon > Basic

Append "5G" to the end of the network name of the "SSID" field. Then click "Apply".

This will not fix your issues, but it will make it much easier to identify the band you are connected to. This way you will know which band is causing your problems.

Having said that, there is another approach which can be better, which is to use Band Steering. This will automatically move any 5G compatible device connected to the 2.4G band to the 5GHz band. This is available on the HG633 (V2.00), DSL-3782 (V1.10) and the TalkTalk Home Hub. To use this leave both network names identical and on the HG633 enable Band Steering from the initial Wi-Fi menu.

Generally speaking, the 2.4GHz band suffers much more from interference than the 5GHz band, but the 2.4GHz one can sometimes have a better range, but this all depends on your local area.

You may then wonder what was really the point of this if it won't solve the problem? This is because the whole topic is too complex to be dealt with in one post. The next stage involves sending out a guide to you to help you get me some important diagnostic results, so as I can analyse them for you and recommend changes to your router configuration to solve them.

I only send this out to people who request it.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

Message 3 of 16

Hi pilgrim6

 

I'm sorry to hear this.

 

Were any other devices connected and in use at the time of the speed test?

 

@KeithFrench provides really good advice on improving wireless performance. Could you help please Keith?

 

Thanks

 

Debbie

0 Likes

Anonymous
Not applicable
Message 4 of 16

Hello Michelle, How optimistic was I yesterday with mbps over 30. Tested 3 times in 3-4 minutes this morning and it was showing speeds of 9.8, 25.8 than finally 33.8 It's the sheer inconsistency which is bafling and was the basis of my original post. Where do I go from here?

0 Likes

Message 5 of 16

Hi pilgrim6,

 

Thanks for letting me know 🙂 If the wireless speeds do drop again then please let us know and we can look into this further for you.

 

Thanks

 

0 Likes

Anonymous
Not applicable
Message 6 of 16

Hello again, over the last half hour I've done 6  speed tests and they have shown speeds between 31 and 33.6 mbps and I'm very happy with that. It seems odd that this sort of consistency has happened since I tried several channels yesterday but reverted to channel 36 as it was the best. I just hope these speeds continue and I shall continue to monitor. Thanks for your help.

0 Likes

Message 7 of 16

Hi pilgrim6,

 

Thanks for the update. The wireless speeds will always be slightly slower than a wired connection. Have the wireless speeds remained consistent since your last post?

 

Thanks

 

0 Likes

Anonymous
Not applicable
Message 8 of 16

Hello again, finally got into router settings and tried several channels which produced speeds of between less than 10 upto 21-22 mbps. I reverted to channel 36 and enabled and saved auto and speed tested and got 32mbps which is entirely reasonable. However I was always likely to get that sort of speed but only on a random basis which was the problem in the first place and the rest of the time it varied between less than 10 up to 25-26 although less than 10 was not often. The router can achieve 37mbps via ethernet but not that high on wireless. Are you able to tell what the problem is? Sorry to trouble you but could you advise? Thanks.

0 Likes

Message 9 of 16

Hi pilgrim6

 

Are you using the router admin password, this sticker is also on the back of the router (this is different to the wireless password)

 

Thanks

 

Debbie

0 Likes

Anonymous
Not applicable
Message 10 of 16

Hello again. ref changing router channel. I simply cannot access the router. I've entered password as admin but the log in won't accept my password that's shown on the back of the router and have always used for accessing wifi on devices. Could you advise please. Thanks.

0 Likes

Message 11 of 16

Hi pilgrim6

 

This help page provides some further information on changing wireless channels

 

Change your wireless channel

 

Thanks

 

Debbie

0 Likes

Anonymous
Not applicable
Message 12 of 16

hello again , I've just tried another ethernet cable test and all 4 ports produced 37.8 (if that's what you mean by channels) If that isn't what you mean then I'll need help to do what you suggest.

Thanks.

0 Likes

Michelle-TalkTalk
Support Team
Message 13 of 16

Hi pilgrim6,

 

Ok thanks for confirming this. Has the speed also been low when you've been connected wired or do the wired speeds remain consistent? Have you tried a few different wireless channels to see how the speeds compare?

 

Thanks

 

0 Likes

Anonymous
Not applicable
Message 14 of 16

Hello Michelle, I tested this morning using wireless. The router I have is a D-link DSL- 3782. I should have pointed in my post that this problem has been going on for some time. Thanks for your response.

0 Likes

Michelle-TalkTalk
Support Team
Message 15 of 16

Hi pilgrim6,

 

I'm sorry to hear this and I'll take a look now. I've run a test on the line which hasn't detected a fault and the sync speed looks consistent.

 

When you experienced the low speeds this morning did you run the speed test wired or wireless? Which router are you currently using? (make and model)

 

Thanks

 

0 Likes