cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

Broken router

Reply
19 REPLIES 19
Highlighted
Popular Poster

Hi 

 

I had a new router back in May and every time I move it to clean ect it goes off and is getting worse what can i do, can you get a replacement?

Highlighted
Community Star

Hi @Shanej ,

 

If the router or power supply have developed a fault then the staff here will probably be able to send you a replacement, they would send you a new router and all the included cables.

 

The staff won't be around now until Monday, but they should be able to respond to this post early next week to help.

Highlighted
Community Team - TT Staff

Hi Shanej,

 

I'm sorry to hear that you're experiencing problems with your router. Just to confirm, have you made sure that the the power cable is seated securely in the port on the router?

Chris

Highlighted
Popular Poster
Yes its plugged in correctly. I'm having to use one of the feet to keep the wire in a certain place to keep it on and it still goes off every now and then. Its messing the router up too. My devices keep disconnecting.
Highlighted
Community Team - TT Staff

OK thanks. We are trialing a new way of sending router, would you like to take part in the trial, we just ask you to complete a short feedback survey afterwards?


Chris

Highlighted
Popular Poster
Hi

I recieved a new router today but if you want to send me that Hub for free instead of the £30 discount price I was offered when chatting to someone about this problem,
I'll do as many surveys as you want 😁
Highlighted
Community Team - TT Staff

Hi Shanej,

 

How are you getting on with the new router?

Chris

Highlighted
Popular Poster
Great thanks. I've had to relocate my router due to a new sofa so can now see all the flashing green lights which is annoying but at least it works. Thanks.
Highlighted
Community Team - TT Staff

That's great, thanks for letting me know

Chris

Highlighted
Popular Poster

Well I think I spoke too soon here.

 

I've recently bought a new smart tv and smart home products and well let's just say I don't think the internet service/ router can keep up. Now I'm  getting connected but no internet on all devices. 

 

I'm not getting the speeds I should be either. I've been a talk talk customer for over 8 years now move had a problem but it's getting worse. I cant get fibre where I am and i cant afford the HuB router I'm stuck what's the terms and conditions about getting out of my contract because of poor service.? 

 

Highlighted
Community Star

@Shanej, you may be advised to follow these instructions to reach your new devices:

 

https://community.talktalk.co.uk/t5/Articles/Split-your-router-s-SSID-wireless-network-name/ta-p/230..., or the speed issue can be looked at,  as all you were dealing with previously was the router. 

 

You need to give staff time to investigate your more recent issues properly. 

 

Ts&Cs are linked from the bottom of any page on the forum, as is the Complaints Code. 

Gliwmaeden2
Please click "like" if this helped you!
Highlighted
Community Team - TT Staff

Hi Shanej,

 

What sort of speed test results are you getting? Could you also try Gliwmaeden2's advice and let us kow how you get on

 

Thanks
Chris

Highlighted
Popular Poster
Hi

Yeah I've done that as some of the devices require being on the 2.4. Only.

I wasn't aware that TT were looking into anything, so I will wait..
Highlighted
Popular Poster

Well talktalk service check said 8mbps this morning, its every so often things just take ages and then say couldn't connect. But then will work again. Maybe these checks TT are apparently doing may find something. I did a line check it came back ok said it's my home set up. Everything is set up the way it should be so unsure. 

Highlighted
Community Team - TT Staff

Do the lights change on your router when the connection appears to drop?

 

Is your router situated close to other electrical devices that could be causing interference?

Chris

Highlighted
Popular Poster

The lights are going off like a disco constantly. No its away everything. Its below the tv but I need ot close to that for the earthnet. 

 

The wireless and Broadband seem to go off out the most of them.

Highlighted
Community Team - TT Staff

Thanks for the info. So do you lose connection on all devices at the same time? If this happens again can you check if the internet light on the router changes

 

Thanks
Chris

Highlighted
Popular Poster

Yes the tv says not connected and that's connected via Earthnet, my phone will show lite mode on chrome ect and the laptop will change from showing the wifi signal and show a globe and will say needs action on the network I'm connected too. The web page on the laptop will go to talk talk where it says your not getting any internet and takes me through the fix it steps which I'm not doing. I was told not to keep turning the router on and off too much so I just leave it and wait for it to come back on. I've not really seen what light goes off but will check when it happens I think it's the internet or broadband one what goes off. But sometimes they have all been on and my devices are off. They are all pretty new devices as well. 

Highlighted
Popular Poster
Hi it's just happened. All devices have lost connection and the internet light is red. All devices loose lose connection at the same time. I understand there is planned maintenance at the time of writing this but I've checked and I'm not in the affected areas. But my connection say no internet, secured and the option to disconnect.
Highlighted
Community Team - TT Staff

Hi Shanej

 

I'm really sorry to hear this.

 

I've completed a line test which hasn't detected any faults.

 

I have also reset the data port and optimised your connection. Please can you monitor this over the next 24hrs and let us know how the connection compares?

 

Thanks

 

Debbie