Broadband help

For queries about your TalkTalk broadband service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Connectivity broken after automatic router update

MichalP
First Timer
Message 16 of 16

Hi,

 

So this night I've noticed that my router (TalkTalk Wi-Fi Hub now with version SG4K100130) is updating by itself. I've logged in to it and noticed the new, slightly faster, UI.

 

But, unfortunately, it resulted with connectivity problems to UDP / RTC services. I cannot connect to discord channels. I can't do a test on speedtest.net. Also tests on https://test.webrtc.org/ for UDP are failing.

And the worst for working from home, my wife's company's VPN stopped working. Everything was working fine yesterday.

 

Any ideas what can I do? perhaps rollback the update somehow?

 

Thanks.

M

0 Likes
15 REPLIES 15

Message 1 of 16

Hi DanielL1

 

Thank you for your feedback, I have passed this straight over to our Products Team.

 

Debbie

0 Likes

DanielL1
First Timer
Message 2 of 16

Oooo... I've had a breakthrough. It looks like it's the wildcard IP address matching that's changed with the update and causing things not to work.

 

For custom rules, it seems you now need to enter your IP address wildcards in a different way.

 

You need to go through each of your existing "Other" rules that use IP address wildcards and change the local and remote IP addresses to be *blank*. They have to be blank - you can't enter values like the other rules or in the way you did before the update.

 

It's still a bit broken though, because it curiously sets "::/0" for remote IP address (a bug?). When you try and edit the rule, and that weird value gets put in the form, then the form itself takes issue with it and you have to clear it again.

 

Long story short - I've got things working again...but it sounds like you should raise a ticket and have your devs look at it as it will doubtless confuse others too.

 

As for your original question about my configuration:

 

I had portforwarding set up for a web-server and a minecraft server (port 25565). These servers were on different nodes and I had the firewall set up to accept the incoming connections.

I also had several additional disabled firewall rules for blocking outbound connections for some other nodes.

Message 3 of 16

Hi DanielL1

 

Ok please can you confirm the below so I can ask our Products Team to check this.

 

What settings you had set up on the router prior to the fw update?   What are your port forward or firewall settings?  

 

Thanks

0 Likes

DanielL1
First Timer
Message 4 of 16

I can't do a factory reset as this will clear all my config: Port forwarding config, device names, reserved ips, passwords, mac filters etc. There's no way I'm going through all that torture again!!!

 

It seems to me that, since the update, the custom firewall page is just plain broken. Any custom rules that use the "Other" Service Name just get ignored. I can add a "reject from local" rule right on the top of the list...and it has no effect.

 

If you update the rules for the standard services (e.g. HTTPS), then the changes are respected and it works as expected.

0 Likes

Message 5 of 16

Hi DanielL1

 

It will default the router back to factory settings (settings straight from the box)

0 Likes

DanielL1
First Timer
Message 6 of 16

Well I suppose I could, but won't this clear everything? Port forwarding config, passwords, device names etc?

0 Likes

Message 7 of 16

Hi @DanielL1

 

Could you try a factory reset (pin hole reset for ten seconds) 

0 Likes

DanielL1
First Timer
Message 8 of 16

Yes - I turned it off and back on again.

0 Likes

Message 9 of 16

Hi @DanielL1

 

Can I just check, have you rebooted or reset your router?

 

Thanks

0 Likes

DanielL1
First Timer
Message 10 of 16

Hi there, I'm having the same problem. Out of nowhere, devices on the network are blocked from accessing things like minecraft servers (port 25565)....how do I update the custom firewall settings to allow all outbound connections? My router version is SG4K100130 as well. Thanks!

0 Likes

Message 11 of 16

Hi MichalP

 

Thanks for your reply.

 

Please let us know if you do experience any further issues.

 

Debbie

MichalP
First Timer
Message 12 of 16

Hi,

 

Thanks Debbie, I sorted it. it was the new "custom" settings for the router's firewall applied by this update. I've set my own settings and I've regained connectivity.

 

 

Message 13 of 16

Hi MichalP

 

I'm really sorry to hear this.

 

We unable to roll firmware back. Which VPN client are you using?

 

Would you like me to send a Huawei WIFI hub?

 

Thanks

0 Likes

MichalP
First Timer
Message 14 of 16

Thanks, done.

ferguson
Community Star
Message 15 of 16

If you would like the support team to look into this for you it will help if you make sure that your personal details including TalkTalk landline number are complete on your community profile (click here) so that they can link your forum identity with your account and then wait for them to respond.