Broadband help

For queries about your TalkTalk broadband service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Home hub died

gouarfig
Conversation Starter
Message 19 of 19

Hi!

 

I have a Sagem model of the talktalk router and it died overnight. I tried to get into the chat but it seems to be disabled (is it?)

 

So to give more information:

 

- I got up this morning and the router was flashing orange

- I turned it off and on again (like 3 times) and it kept flashing orange

- I tried to log on to it and the page wasn't loading. I tried to ping it with no success either.

- Then I started the procedure to check my line and after a while I got a text saying my line was perfectly fine.

- Then I switched the router off an on again, but still flashing orange.

- I dig up an old router from the loft and plugged it in, and TADA! internet is back.

 

I think it's quite obvious the router is dead, and I'd be happy to discuss it with someone, if only I could get into the chat...

 

Can you guys help me? you have been so helpful with my problems in the past 😍

 

Thank you very much

Our phones fall, we panic
Our friends fall, we laugh!
18 REPLIES 18

KeithFrench
Community Star
Message 1 of 19

You're welcome @gouarfig. When you default the router WPS is enabled by default.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 2 of 19

Hello,

 

Thanks for the update 🙂

 

Thanks

 

0 Likes

Message 3 of 19

Hi,

 

So, following your investigations (I can't thank you enough for it) I did a factory reset again.

 

But this time, I tried in exactly the same order as you did, and ... TADA! it worked!

 

I really don't understand why it didn't work before.

 

One thing I noticed though, there are a few default settings that I change pretty quickly: like disabling WPS. I swear on my previous setup that it was disabled by default, but this time it was enabled by default. Maybe there was some leftover configuration in the NVRAM? pretty unlikely though, but who knows...

 

So I don't know if the order matters, DHCP or DNS or IP change, but anyway it works now and I'm happy with it.

 

Thank you very very much!

 

Our phones fall, we panic
Our friends fall, we laugh!
0 Likes

KeithFrench
Community Star
Message 4 of 19

OK, I have just been doing some extensive tests.

 

  1. Set router to 192.168.11.1 created a port forwarding rule for TCP port 1293. All worked fine.
  2. Deleted the port forwarding rule. Disabled the DHCP server. Recreated the PF rule & all worked OK
  3. Set router to 10.7.201.1 created a port forwarding rule for TCP port 1293. All worked fine.
  4. Deleted the port forwarding rule. Disabled the DHCP server. Recreated the PF rule & all worked OK

The one bit that I definitely agree with you on & I will bring to TalkTalk's attention is the fact that the subnet mask is missing from the Device Info page in the network section.

 

When restoring a backup this will only work if the backup file is the from the same firmware version. In fact, it was not until firmware V130 that backup & restore worked properly anyway.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

Message 5 of 19

I'm passionate about home automation, and I have a few raspberry pis and microcontrollers around the house. It's much easier to manage the DHCP rules in a text file. But I could start using the router DHCP if that would fix the problem to be honest.

 

Which reminds me, I might have a backup of the router configuration (the previous one that died recently) and I guess I could try to restore it on this router.

 

Our phones fall, we panic
Our friends fall, we laugh!
0 Likes

KeithFrench
Community Star
Message 6 of 19

I doubt if it is just the one subnet, I'll have to try myself tomorrow when I get more time. Obviously there is no reason why you shouldn't use your own DHCP server, but what features do you use from it? Perhaps some of the Options?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 7 of 19

Same problem I'm afraid, but at least we can narrow it down:

 

I've removed the 2 DNS (and the 192.168.11.1 was added back automatically) and I reactivated the DHCP in the router.

 

The port forwarding is still saying something is wrong. I also tried the Games & Applications tab which resulted with the same error message.

 

It could be this particular subnet that is causing the issue (that would be my luck!) maybe because of a malformed regex somewhere 🙄

 

Our phones fall, we panic
Our friends fall, we laugh!
0 Likes

KeithFrench
Community Star
Message 8 of 19

Whilst I could change my subnet on this router (no time tonight), I cannot replicate your setup with a separate DND server. To prove a point, what happens if you enable the router's DHCP server instead of your own DHCP server, can you forward the port then?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

gouarfig
Conversation Starter
Message 9 of 19

Hi @KeithFrench,

 

Thanks for looking into it. You will quickly realise that I don't have an usual configuration, it's because I have a development server at home where I need DNS entries, and I also use a pi-hole setup.

 

For that matter, I don't use the DHCP from the router, and I use an internal DNS.

 

But it was all working fine for ... I'd say about 4 years, before the brave Sagemcom router died and I got a replacement.

 

From the status page: there's no local subnet mask? it's either a bug or .. hmmm a bug?

 

Screenshot 2021-09-28 at 17.00.48.png

 This is what the IP & DHCP page looks like: no DHCP, no address reservation.

 

Screenshot 2021-09-28 at 17.11.15.png

And my DNS settings:

 

Screenshot 2021-09-28 at 17.12.40.png

In the port forwarding rules, I managed to add an invalid rule. There's no way the router can access this IP:

 

Screenshot 2021-09-28 at 17.15.27.png

 But now if I try to setup a port forwarding on the right subnet:

Screenshot 2021-09-28 at 17.19.13.png

 I'm getting this error:

 

Screenshot 2021-09-28 at 17.22.33.png

So there's definitely something wrong going on 🤔

Our phones fall, we panic
Our friends fall, we laugh!
0 Likes

KeithFrench
Community Star
Message 10 of 19

Hi @gouarfig, this is my recommended way to change the IP address of the router:-

 

It is a three-stage process & it is best done in this order:-

  1. Remove any DHCP Reserved IP addresses

  2. Change the DNS address handed out by DHCP

  3. Change the router’s IP address & DHCP IPv4 Pool Start & End ranges to match.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

KeithFrench
Community Star
Message 12 of 19

Hi @gouarfig, @Debbie-TalkTalk has asked me to help you. There is nothing wrong with the port forwarding either in this router or specifically with the new firmware V130. Please can you do a factory default of the configuration in the router & try again. If it still causes problems, please can you include a screenshot of what you are doing, so I can see the error? In addition to this, please get me these screenshots as well:-

 

Dashboard > See Wi-Fi Settings > Manage Advanced Settings > TalkTalk Wi-Fi hub > DHCP

 

and

 

Dashboard > See Wi-Fi Settings > Manage Advanced Settings > TalkTalk Wi-Fi Hub > DNS

 

When you include these via the Insert Photos button, please ensure that the Size parameter is set to Large.

 

The last time I tested the router on different subnets it worked absolutely fine where port forwarding is concerned.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

Message 13 of 19

Hi Debbie,

Oh, that's the latest version 😫 It is possible to downgrade? 😬

 

I can give a bit more information about it, as I was investigating yesterday:

 

- I changed the default router IP to let's say 192.168.2.1, this is because of the VPN I'm connecting to for work (I know that's annoying but I can't help it)

- I tried to do a redirection from a port, let's say 220 to the IP 192.168.2.10 which should have worked, but displayed an error "something wrong happened"

- I tried may other things, even opening port via uPnp, which was also refused by the router

- Remembering a few of the other old bugs in the firmware (like the DHCP range) I tried something that cannot work: redirecting the port 220 to 192.168.1.10 <- this is the wrong subnet, but it was accepted by the router interface!

 

So it looks like: no matter the subnet you choose the router to be on, it will only accept port redirection to the default subnet (192.168.1.0/24).

 

Our phones fall, we panic
Our friends fall, we laugh!
0 Likes

Message 14 of 19

Hi gouarfig

 

Thanks for keeping us updated 🙂

 

Your router has version 130 fw and this is the latest version. @KeithFrench have you come across this issue with port forwarding on the new firmware version?

 

Thanks

Message 15 of 19

I Debbie,

 

I have received and setup the router. Now the boardband is all back to normal! thank you very much.

 

I have another problem though, I cannot add any port forwarding rule, I always get a message that "something wrong happened".

The firmware is SG4K100130 and apparently it's a well known defect. Is it possible to upgrade the firmware?

 

(Or should I open a new thread maybe?)

 

Thank you for your help 🙂

 

Our phones fall, we panic
Our friends fall, we laugh!

Message 16 of 19

Hi gouarfig

 

Ahh you are very welcome 🙂

 

Debbie

Message 17 of 19

That is an excellent service 😊

 

Thank you very much Debbie! 😍

Our phones fall, we panic
Our friends fall, we laugh!

Debbie-TalkTalk
Support Team
Message 18 of 19

Hi gouarfig

 

I'm sorry to hear this.

 

I have ordered you a replacement router and a returns bag for your current/faulty router.

 

Please allow 24-48hrs for this to arrive. Let us know how you get on.

 

Thanks

 

Debbie