Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

I can't get my WiFi hub to turn on

First Timer

Hi there,

Sorry if I am being an idiot, but I have just received my new WiFi hub, and I cannot get it to power up.

I have plugged in the power supply and the broadband line, but when I turn the hub on, there is no light on the front of the box and no sign of life at all.

I have tried a different power socket and I have the same result.

Is there something I am missing?

Or is this a faulty hub?


Community Star

Looks like it's DOA. The quickest way to resolve this would be to report it directly to customer services.


Alternatively, if you would like the support team here to help then make sure that your personal details including TalkTalk landline number are complete on your community profile here so that they can link your forum identity with your account and then wait for them to respond.


Community Team - TT Staff

Hi Pinstripe Cowboy,


Can you please update your community profile to include your:

  • Name
  • Telephone number
  • Alternative contact number

We'll then look into this further. Please do not post this information on this thread Once you've updated your profile please post in your topic to confirm it's updated. 




First Timer

Thank you.

I have now updated my details.

Community Team - TT Staff



A replacement is on the way.





Check & Report l Our latest Blog l Set Your Preferences l Service Status l Help with your Service l Community Stars

Working From Home Tips

Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.

STAY HOME      -      PROTECT THE NHS      -      SAVE LIVES