Broadband help

For queries about your TalkTalk broadband service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Internet Explorer

Mervyn2
Participant
Message 2 of 2

I suggest that the TalkTalk Community stops saying 

We no longer support Internet Explorer v10 and older. Upgrade to a newer version or use a different browser

when I am on IE11 with automatic updates, so I always have the latest version.  Infuriating!

0 Likes
1 REPLY 1

hosay299
Philosopher
Message 1 of 2

@Mervyn2  u could try uninstall it then reinstall it directly from the site. Or use Google chrome  

 

I would if ur going to download it 1st then u have the software to reinstall it after 

 

Might need to do a computer restart in between.

Hope that help Regards Joe
If so then give me a Kudos ( Click the Thumb up Button)
0 Likes