Broadband help

For queries about your TalkTalk broadband service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Internet Intermittent for last few days - possible DNS Server problem

DavMuss
Team Player
Message 38 of 38

Good evening,

My internet access has been intermittent for the last few days.  Sometimes I can access websites, other times nothing.   I believe the problem is related to the TalkTalk default DNS settings within my WiFi Hub.   If I manually switch to Google DNS servers, everything is fine.   The WiFi hub is a Sagemcom SG4K10002816t H/W. FAST 5364 3.00.   From what I have read on other posts this is a known problem and a Firmware Update may be required to fix the problem (or a switch to another hub - ? Huawei).   The phone-line tests OK and the white light on the hub remains solid!

Have tried switching off the hub, waiting 30 mins, and rebooting, but this doesn't really help.  It may work for a short period and then fails to access websites.

Currently using the Google DNS settings and seems to be fine.

Any thoughts?

David

0 Likes
37 REPLIES 37

Message 21 of 38
0 Likes

Message 22 of 38

Thanks for your help.

Have a good weekend yourself

David

Skynet_TX
Community Star
Message 24 of 38

@DavMuss

 

One tip, when you switch between two different types of router make sure that you leave over 30 minutes after switching the first router off, before you then turn the new router on. Leaving over 30 minutes of downtime will ensure that the new router connects to a brand new session in the street cabinet. This will help ensure the new router connects with the best possible settings to get the best speeds, if you don't leave over 30 minutes then the new router may connect to the same session that was created by the old router, and as they are different models of router this may mean the new router does not work at its best possible speeds.

Message 25 of 38

Hi David

 

Thank you 🙂

 

Have a good weekend 🙂

 

Debbie

0 Likes

Message 26 of 38

Thanks Debbie - I'll look out for it.

I'm interested in comparing connection speeds, wi-fi range etc. myself!

Will keep you updated on test results.

Many thanks.

David

Message 27 of 38

Hi David

 

The Huawei WIFI hub is on its way, please allow 24-48hrs for this to arrive.

 

Let us know how the connection compares with this router.

 

Thanks

 

Debbie

Message 28 of 38

Thanks for the update, Debbie.  If you could send a Huawei WiFi Hub, that would be great.

I can return it to you once the Sagemcom receives the firmware update.

Regards,

David.

0 Likes

Message 29 of 38

Hi David

 

The firmware roll out has been paused for a short while for the Sagemcom hub.

 

Would you like me to send you a Huawei WIFI hub?

 

Thanks

 

Debbie

0 Likes

Message 30 of 38

Hi Debbie,

All seems to be working fine having applied the suggested workaround, thanks.

I understand the updated firmware is now being rolled-out in batches.

Could I please request an early firmware upgrade to my WiFi Hub if possible.

Many thanks.

David.

0 Likes

Message 31 of 38

Hi David

 

Thanks for your reply.

 

Please let us know if you do experience any further issues.

 

Debbie

0 Likes

Message 32 of 38

Good morning,

Many thanks for your detailed information and instructions - much appreciated.

I have now made the changes to Static DNS Server Configuration within the WiFi Hub, as suggested, and all appears to be working great, no reboots have been necessary.

Will monitor the situation but hopefully this issue has now been resolved.

Once again, thank you for your help.

Regards,

David.

Message 33 of 38

Good morning,

Many thanks for your detailed information and instructions.  Much appreciated.

I have now made the changes to Static DNS Server Configuration within the WiFi Hub, as suggested, and so far all is working great with no reboots required!

Will monitor the situation but hopefully this problem has now been resolved.

Thank you once again.

Regards,  

David

 

Skynet_TX
Community Star
Message 34 of 38

It will depend what screen in the router settings you tried changing the DNS, changing them in one of the screen will help for a little while, but the issue will then come back, changing them in the other screen may well resolve the issue permanently.

 

Basically the firmware bug is that the DNS service in the router stops responding, so if you are allowing your router to be a DNS server then this problem will keep coming back, regardless of the external DNS service you point the router to. The details below explain how to stop your router acting as a DNS server at all, and to just let your devices go directly to the TalkTalk (or other service of your choice) DNS servers.

 

If you are suffering from this known DNS issue then getting a replacement Huawei will fix it, as that router does not have this problem, but if you did want to try changing a setting on the Sagemcom to see if that fixes it then the details are below (I had this same issue with my Sagemcom, and changing this setting has fixed it for me, I've had no recurrences of the issue for many months).

 

Workaround :

 

At present your router will be acting as the DNS server for all of your devices, so when the DNS stops working in your router all of your devices will lose internet access. However you could configure your router so that it just tells all of your devices to use the TalkTalk DNS servers directly, therefore your devices won't use the router as a DNS server, and so shouldn’t be affected if the routers DNS stops working.

 

If you wanted to try this you just need to follow the instructions for the 'Wi-Fi Hub' here (ensure you go to the screen described in this article, as there are two screens in the router where you can modify DNS settings, but you must change the settings on the specific screen described in this article for this potential fix to work). If it won't let you change the settings in this screen it may be because you have set specific DNS servers in the other screen where you can modify the DNS settings, if this is the case then go back and set that other screen back to Auto, that should then allow you to edit the details on this screen.

 

If you have never changed these settings before you will probably find that the primary DNS server is set to 192.168.1.1 (i.e. the router itself). You could change the settings as follows (or use any other DNS service of your choice) :

 

Primary : 79.79.79.79
Secondary : 79.79.79.80

 

These are the current preferred TalkTalk DNS servers (they are mentioned at the bottom of that webpage so you know they really are genuine TalkTalk DNS servers).

 

IMPORTANT : Having changed the settings you would need to make your devices disconnect and reconnect to the router (you could just reboot the devices or the router). When your devices have reconnected they will be configured to use those two addresses above as their DNS servers. So from that point on the devices will use the TalkTalk DNS servers directly rather than going via the routers DNS service.

 

Making this change may well resolve the issues for you, but if you do ever want to 'undo' this change all you need to do is put the old values back into that screen, or you could just factory reset the router by holding in the pinhole reset switch on the back for over 10 seconds, as that will return all settings back to their initial defaults.

Message 35 of 38

Many thanks for your response.  I'm happy to change settings on the router but I've already tried alternative DNS Servers (Google, Cloudflare etc) and the problem returns after a while, so not sure what else I can do!   A replacement router might be a good idea if it's available, otherwise I guess I'll have to wait for the new firmware - but it's a bit annoying having to reboot the unit frequently.   David.

 

0 Likes

Skynet_TX
Community Star
Message 36 of 38

Hi @DavMuss

 

Yep, there is a known issue with that firmware that can cause this behaviour, changing the DNS servers, or rebooting will fix it for a while, but it will come back. There is new firmware being rolled out at the moment that resolves this issue, but the rollout is currently temporarily paused as a further small change is being made to the firmware.

 

The staff here may be able to offer you a replacement router when they pick this post up tomorrow.

 

Alternatively, if you are comfortable with logging into the router and changing a setting then you may well be able to stop the issue from happening, but it is only a good idea to try this if you have a fairly simple home setup (i.e. just devices that need to access the internet), if you have devices that need to talk to each other and rely on your router to provide local DNS for the devices to find each other, then trying this workaround is probably not appropriate, as it may stop those devices from being able to see each other.

 

If you did want to try changing settings on your router then let me know and I'll post the details, you can easily undo the change if necessary.

0 Likes

DavMuss
Team Player
Message 37 of 38

PS. Spoke too soon.  Problem now happening using Google DNS Servers as well!   Have had to reboot the WiFi Hub again to access websites!

0 Likes