cancel
Showing results for 
Search instead for 
Did you mean: 
Need help?

Internet crawling and Playstore not working - are they linked

Reply
12 REPLIES
Highlighted
GBy123
Wizz Kid

I have just seen two threads  about slow internet and also Playstore issues.  My internet has slowed to an absolute crawl (1.75 download) - cannot function like this to be honest.   At the same time I cannot download anything on Playsstore over home wireless network.   I thought Playstore may be because of the slow internet, but I see from another post that others are having problems.

 

I have carried out multiple speed tests and it just gets slower and slower - to almost unusable, especially over wifi (recorded 0.38) when plugged router into master socket!   

 

Is there something someone can do please.   Both for speed and Playstore issues?  

Gondola
Community Star

Hi @GBy123

 

Is your home in the Birmingham / West Midlands area? 

 Gondola - I'm a TVPlus customer *
GBy123
Wizz Kid

Yes I am in  South Birmingham, West Midlands.   Does that have any bearing on the matter?

Gondola
Community Star

Hi @GBy123

 

First try rebooting the router to see if your connection speed recovers.

 

The reason for asking where you live is because I've noted there are reports are being made by a few people of YouTube videos not working on Apple devices. The reports are coincident with Access Network migrations and Edge Router software upgrades at Birmingham Central on 5th and 6th April. It's therefore possible but not conclusive that the Google Playstore issue is related to Google owned YouTube issue.

 

Google are the common factor and the way they interact with devices could be affected by the Edge Router upgrade. That's just my diagnosis of course and it requires confirmation by Networks.

 

I've drawn this topic to the attention of the TalkTalk Community support team and an OCE will respond to you right here to help you.

 

Leave your router powered and connected to the line until you hear from an OCE.  The OCE will be able to check the line performance and the router and will have options to discuss with you including escalation to Networks / Openreach if a fault is present.

 Gondola - I'm a TVPlus customer *
Community Team

Hi GBy123,

 

We believe the playstore issue should now be resolved. Is this now working ok for you? Are you also still experiencing slow speeds at the moment?

 

Thanks

 

GBy123
Wizz Kid

Yes, download problem resolved.    Speed still rubbish - just did test - struggled to 1.75 download!     I cannot do a speed test through TalkTalk for some reason.

Community Team

Hi GBy123,

 

Thanks for confirming. The connection looks stable so I've optimised the connection and the sync speed has increased. Could you let us know how the speed compares over the next 24hrs.

 

Thanks

 

GBy123
Wizz Kid

Well my download speed jumped up just after receiving your reply - to 3.25 download - which is quite satisfactory for me. (maximum I could get is probablty 4 on my wire).   Unfortunately that did not last and a couple of hours later was down to 1.8 again.   I have carried out several  checks but it depends on who I carry out the check with - the various sites give quite different readings - i.e. I just did one on one site and it was  download 1.75, another was 2.5 and another was 3.15.  I cannot carry out a TalkTalk test directly because it just tells me the site cannot be reached.   Frankly I don't know what my speed is at the moment, but I don't  think it is very good!

 

a. why can't I carry out a Talk Talk Speed test

b.  Which is the best site to use

 

At least Playstore works properly and when I check the TalkTalk service I now get a green tick, whereas there was a yellow triangle and 'could do better' comment!

 

I know you will tell me to plug my router directly into the master socket but actually this would cause quite an upheaval.  Thank you for looking into my issue and I look forward to a reply on my query about the sites to use.

 

 

 

 

Community Team

Hi GBy123,

 

Thanks for retesting and I'm sorry to hear that the speed has dropped since my last post.

 

I've run a test on the line which hasn't detected a fault, however I can see that DLM has lowered the sync speed due to an increase in errored seconds on the line.

 

Is the router currently connected to an extension socket? Which router are you currently using? Do you have an alternative router that you can test with?

 

Is the voice service ok? Are you experiencing any noise on the line?

 

In regards to the speed tester, do you receive an error message? Have you tried using a different browser?

 

Thanks

 

GBy123
Wizz Kid

Thank you for looking into this.   speed still slow but hanging in there.   answers to your queries are:

 

Router is on an extension, where it has been for years.  I have checked all cables, connections and so on.  Very difficult to check master socket if required.  .

Router - DLink 2680.   I do not have an alternative.

Voice is OK with no interference, but I did have a 'check line error' two days ago.  No other problems.

 

 

 

 

 

 

 

Community Team

Hi GBy123,

 

Ok thanks for confirming. Would you like us to send a replacement router for testing purposes to rule this out?

 

Thanks

 

GBy123
Wizz Kid

Thanks - That would be great, though I can't guarantee I will know how to set it up - it always terrifies me when I change anything in case it never works properly again!   

 

I wonder what type of router you will send - hopefully one that works nicely with my system.  When the router is received I will set it up and see if things improve and keep you informed of progress..  .

Community Team

Hi GBy123

 

I've ordered a HG633 router for testing, please allow 24-48hrs for this to arrive.

 

The router will set up ready to use, you will just need to connect it up at the socket/power.

 

Please let us know how the connection compares with this router.

 

Thanks

 

Debbie