cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Nat disabled. Gadgets only working after changing DNS

Reply
7 REPLIES 7
Flemozie
First Timer

Hi, I have just joined TalkTalk. My TV connected to Wifi and worked fine. However, PS4 and all mobiles connected but the Wifi was not working. I've called TalkTalk and after 90 minutes on the phone they gave up and said to give it 24 hours. So I've spent some time researching this and managed to find an article that mentioned changing DNS to 8.8.8.8 etc. This worked, but to do this I had to change from DCHP to Static (yes I have no idea what I'm talking about, please bare with me.) I then noticed my NAT was disabled. I've read up about this but it makes no sense.

So finally my question; why did I have to do all this to get our gadgets to work? Has this somehow limited my speed etc and is it ok that my Nat is disabled?

Thanks in advance. 

KeithFrench
Community Star

NAT (Network Address Translation) is the same as Port Forwarding & is only ever required when you have some sort of server in a game, application or device where other people need to establish a connection from the internet to that device etc.

 

Please give me more details on exactly what you mean about NAT in your case & please elaborate on what you changed from DHCP to static (I assume a device's IP address). It is not a problem when you say you do not know what you are doing, but you shouldn't make such changes with consulting someone who does know.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Flemozie
First Timer
Thanks Keith. I'm not sure how to elaborate more. The connection wasn't working so I googled and tried out everything until something worked.
Changing the DNS to 8.8.8.8 and changing something (can't remember what from) but changed to static.
I absolutely agree I probably shouldn't be messing about with it but unfortunately TalkTalk couldn't fix the issue and having broadband that doesn't work; what did I have to lose.
The kids are able to play games using servers now even though setting say the NAT type is disabled.
Thanks again for taking the time to read my post.
Community Team

Hi Flemozie,


Welcome to the Community. So was the PS4 the only device that wasn't working? Did all other devices, wired and wireless, work OK?

Chris

Flemozie
First Timer
Hi Chris,

Thanks for taking an interest. All mobile phones connected to wifi but we were unable to get onto apps like Facebook, Instagram, you-tube or receive mail. This was the same with our laptop and playstation. The only thing that did work was my smart TV. All connections were wireless, I didn't try to wire them directly.
Since I made my rather blind changes with the help of various blogs it seems to be working fine. Very strange as I didn't ever need to do anything like this when I was with BT.
Thanks again
Community Team

Yes you shouldn't need to have made the changes you have. Do you know if HomeSafe was enabled?

Chris

Flemozie
First Timer
No I haven't had a chance to set that up yet. When I googled "wifi connecting but not working" It advised to do the things I did but didn't tell me why I was doing it or what the issue was.
I did originally call Talk Talk customer service but after over an hour with the representatives trying all sorts to no avail I decided to play around myself.
Do you suggest I reset the settings and see if it works?
Community Team

Hi Flemozie,

 

Yes, you could trying changing the DNS setting back to TalkTalk settings to see if this is still happening. I've also included a Help Article below in regards to HomeSafe as it would also be worth checking this.

 

TalkTalk HomeSafe - An Overview

 

Thanks