Broadband help

For queries about your TalkTalk broadband service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

New hub delay in loading pages

David bastin
First Timer
Message 36 of 36

I received my new hub. Set up and speeds very good but loading web pages so slow? Please help

0 Likes
35 REPLIES 35

Message 21 of 36

OK thanks, there's a newer firmware version available but I can't communicate with your router at the moment, is it currently switched on?

Chris

0 Likes

Message 22 of 36

version SG4K10001400t

0 Likes

Message 23 of 36

Hi David,

 

New firmware is just in the process of being rolled out, which firmware version does your wifi hub currently have?

Chris

0 Likes

Message 24 of 36

Hi. Any updates on a firmware upgrade please?

0 Likes

Message 25 of 36

Hi Davidbastin,

 

Once new firmware is available for the wifi hub then the router will be automatically updated.

 

Just to confirm, what devices experienced the slow web pages? Did they all have the latest updates. Did this affect different browsers? If so which browsers did you use? Which sites were affected and which sites seemed to load ok? We're currently trying to collate as much information as we can as we've been unable to replicate this ourselves when we've tested this.

 

Thanks

 

0 Likes

Message 26 of 36

Ok. Thanks. Really disappointed that what seems a fantastic device is a bit rubbish. How will I be informed about the firmware update please?

0 Likes

Message 27 of 36

Hi Davidbastin

 

This doesn't appear to be affecting all routers (Wifi Hub) Our Products Team have been trying to replicate this fault and are still investigating this.

 

Thanks

 

Debbie

0 Likes

Message 28 of 36

Hi Chris. Thank you. Is this fault well known or just a few are suffering from this?

0 Likes

Message 29 of 36

Hi David,

 

I've ordered you another HG633, should be with you within a couple of days but please allow up to 5 working days for delivery


Thanks

Chris

 

 

0 Likes

Message 30 of 36

Ok

0 Likes

Message 31 of 36

Hi David,

 

Apologies for the confusion, we're currently looking into the slow web pages on the wifi hub with our Products Team at the moment. What devices (make and model) are connected when you are experiencing the slow web pages?

 

We can send another HG633 for testing purposes to see how the web pages compare whilst we are looking into this. Would you like us to arrange this?

 

Thanks

 

0 Likes

Message 32 of 36

Hi. I have the Sagemcom FAST 5364.

0 Likes

Message 33 of 36

Hi David,

 

I'm sorry to hear this. Our Products Team are looking into the issue with the slow web pages at the moment. What devices are you currently using? (make and model) Does the page eventually load?

 

Would you like us to send a another HG633 router for testing purposes?

 

Thanks

 

0 Likes

Message 34 of 36

Hi Debbie. I have the new WiFi hub. My old HG633 was overheating so I upgraded. This new hub has a better WiFi range and slightly better speeds but web pages load so slowly on every device using wired or wireless. Please help my kids are moaning at me!!

0 Likes

Debbie-TalkTalk
Support Team
Message 35 of 36

Hi David bastin

 

I'm sorry to hear this.

 

Are wired connections also affected?

 

Which device are you using?

 

Thanks

 

Debbie

0 Likes