Broadband help

For queries about your TalkTalk broadband service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Please stop changing my router's wireless channel!!

Thorin_Oakensheild
Popular Poster
Message 2 of 2

The wireless channel on the TalkTalk WiFi Hub (Sagecom) keeps changing despite the fact it has been manually set to a static channel. It has taken some time discover that it is TalkTalk that are doing this in the name of WiFi optimisation.

 

The channel should only change automatically when set to 'Auto', not when a user has manually selected a static channel. This is a known bug as there are many similar posts about it. This causes multiple devices to lose connectivity at various times throughout the day.

 

Please could TalkTalk kindly change the settings on their end to allow a static wireless channel to be selected on the router?

0 Likes
1 REPLY 1

Debbie-TalkTalk
Support Team
Message 1 of 2

Hi Thorin_Oakensheild

 

Apologies for this.

 

The WIFI optimisation has now been switched off.

 

Thanks

 

Debbie

0 Likes