cancel
Showing results for 
Search instead for 
Did you mean: 
Need help?

Want to know how to get the most out of our community?

Hey, I'm Michelle and I wanted to tell you about our community and how it's packed full of useful information, answers and has a horde of active members waiting to help or just to say hey! We know forums can be a little daunting at times, so here are some of my useful tips to help you get the most out of the community:

Get Searching

Search is the quickest way to locate the information you're after, use the big red box above. If you don't find what you're after you can always post your own question.

Search now

Get stuck in

Prefer to jump straight into the community? Checkout the yellow "browse" tab over on the left hand side, here you'll find the entire community at your fingertips.

Try now

Join the party!

Had a peek around the community already? If so you'll no doubt want to join us, just hit register below and follow the instructions. Don't worry I'll still be here to help once you've registered.

Register now

Port Forwarding Problems

ANSWERED
Reply
4 REPLIES
Highlighted
JH_77
Visitor

Hi,

I've been trying to setup port forwarding on my DSL-3780 router (v1.19t firmware) so that I can access my home CCTV cameras when away from home. When I go into the router setting, virtual server, I can setup the port to be forwarded but it says I need to disable SPI in the firewall settings. When I enter the firewall settings disabling SPI is not an option. The port if therefore not visible from outside my network and I cannot view my CCTV cameras.

Can this be fixed with a firmware update or do I need a new router (as some other posts suggest)?

Thanks, James

 

KeithFrench
Community Star

Send me screenshots of what you have setup in the 3780 & I will advise. How is the 3780 connected, directly to the incoming ADSL line?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

JH_77
Visitor

Hi Keith,

 

Thanks for your help. Yes, I am connected directly to the ADSL line.

 

Please find attched pics of my setup.

 

Thanks, James

 LAN.jpgfirewall.jpgvirtual server.jpg

 

KeithFrench
Community Star
Solution

HI James,

 

You do not need to touch the firewall at all, port forwarding rules automatically punch a hole through the router's firewall. There is nothing obviously wrong with the Virtual Server config either (assuming that you have the port correct).

 

Are you trying to test using the router's WAN IP address from a device connected to your local router's network, if so, this will never work? Traffic going out to the internet from the local device & back into the local network is known as loopback traffic. All TalkTalk routers treat this as a security issue & block it.

 

If you go to a port checker website with a pc connected to your local router, such as:-

 

https://portchecker.co/

 

Does the port report as being open?

 

Can you connect to the DVR locally via the 192.168.1.20 address?

 

 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

JH_77
Visitor

Hi Keith,

 

It works! I tried the port checker which said it was open, and now I can connect to my DVR remotely.

I did a factory reset of the router yesturday, so I can only assume that fixed it.

 

Thanks for all your help.

 

James.