Broadband help

For queries about your TalkTalk broadband service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Port forwarding for smart cat flap

gwatuk
Enlightened One
Message 22 of 22

I'm trying to set up a smart cat flap.

I think that I need to set up port forwarding for this.

I've set up this:

Service: HTTPS
Protocol: TCP
External host: *
Internal host: 192.168.1.240 (I am very confident that this correct)
External Port: 443
Internal Port: 443
 
Are these settings correct?
 
 
0 Likes
21 REPLIES 21

KeithFrench
Community Star
Message 1 of 22

No problem.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

gwatuk
Enlightened One
Message 2 of 22

Thanks for everything so far Keith. 

KeithFrench
Community Star
Message 3 of 22

Oh well, it is down to the application (presumably within this hub thing) that has the responsibility to open the port, so I think you will have to speak to their tech support on Monday then. Let me know what they say & I will try & help further if I can. 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

gwatuk
Enlightened One
Message 4 of 22

Still closed 😒

0 Likes

KeithFrench
Community Star
Message 5 of 22

Does port 443 report as open now in the port checker? Thanks for the URL, I will read up on it now.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

gwatuk
Enlightened One
Message 6 of 22

Yes port forwarding is correct. 

When it works it should be quite impressive:

 

https://www.surepetcare.com/en-gb/pet-doors/microchip-cat-flap-connect

0 Likes

KeithFrench
Community Star
Message 7 of 22

You do not need to change anything in the firewall, that concerns pings coming in from the WAN. Have you changed the IP address of the port forwarding rule to the correct address? If so what does the port checker report now?

 

I must admit to being a bit intrigued as to what this cat flap offers to you. I assume it reads the cat's microchip & unlocks the flap only for it. Please can you give me a link to the website for this cat flap, so as I can read more about it?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

gwatuk
Enlightened One
Message 8 of 22

Pinging 192.168.1.16 with 32 bytes of data:
Reply from 192.168.1.16: bytes=32 time=2527ms TTL=100
Reply from 192.168.1.16: bytes=32 time=4ms TTL=100
Reply from 192.168.1.16: bytes=32 time=3ms TTL=100
Reply from 192.168.1.16: bytes=32 time=462ms TTL=100

Ping statistics for 192.168.1.16:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 3ms, Maximum = 2527ms, Average = 749ms

0 Likes

gwatuk
Enlightened One
Message 9 of 22

Sorry - I am clueless.

Just realised that I entered the wrong address.

It is at 192.168.1.16 !!!

Just pinged that and it is OK.

0 Likes

gwatuk
Enlightened One
Message 10 of 22

Destination unreachable.

 

And just to impress you that I'm not completely clueless I've also just changed the router firewall settings to Respond to ping: On

(Just thought that might be relevant.)

0 Likes

KeithFrench
Community Star
Message 11 of 22

From the command prompt type:-

 

ping 192.168.1.240 followed by the Enter key. wait a few minutes for it to finish & copy it to your reply.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

gwatuk
Enlightened One
Message 12 of 22

doh... how do I do that?

I'm using a pc connected to the router with PLAs.

0 Likes

KeithFrench
Community Star
Message 13 of 22

So from that, I assume that the cat flap hub is not connecting to their server somewhere on the internet? If that is the case, then the port forwarding will have no impact on this as yet.

 

From a pc or whatever connected to the router, can you ping this cat flap?

 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

gwatuk
Enlightened One
Message 14 of 22

Wired connection.

It is appearing in the manage my devices display

 

Green ears
Green ears mean the Hub is working correctly. See below for the details of what each light
sequence means.
Both ears are solid green – Your Hub is turned on, connected and working correctly.
Both ears flash twice – A cat has gone through the Microchip Cat Flap Connect.
Alternating green ears – Your Hub is re-connecting to our servers.

Red ears
Both ears are solid red – Your Hub is doing a Firmware update. Be patient, your Hub
will reboot and continue as normal shortly.
Both ears flashing red – Your Hub has lost connection with your Microchip Cat Flap
Connect and is trying to reconnect.
Alternating red ears – Your Hub is having difficulty connecting to the internet and/or
our servers.

 

It is mostly showing two flashing green ears.

Then after a while it cycles back to it's start up routine.

0 Likes

KeithFrench
Community Star
Message 15 of 22

This is why I am wondering about the actual connection to the router, as per my previous post

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

gwatuk
Enlightened One
Message 16 of 22

port checker.jpg

0 Likes

KeithFrench
Community Star
Message 17 of 22

What does it signify when they are flashing then? Have you got a good connection from the cat flap to the router, is it appearing in the manage my devices display?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 18 of 22

The little round box is called a hub by the cat flap company.

I'm testing this by watching the the ears of the cat flap "hub" - various combinations of red and green.

They should both be green and not flashing.

This isn't happening.

 

But port checker says 443 is closed!

 

0 Likes

KeithFrench
Community Star
Message 19 of 22

The cat flap having its own hub, do you mean another router or what? Hub in IP networking terms do not really exist anymore & is often a term used incorrectly to describe some kind of networking hardware.

 

What happens if you go to a port checking website such as this:-

 

https://portchecker.co/ 

 

If you test TCP port 443 is it reporting as Open or Closed? If closed, I would suspect that this smart device is not opening the port.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 20 of 22

Thanks Keith.

It's a wifi hub Sagemcom version.

The cat flap has it's own little hub. (A round thing with ears that flash 😄)

I've looked at the router settings to establish the address of the wired connection to this hub and used that for the port forwarding setting.

 

I've been convinced that the External Port and Internal Port should not have been the same (I don't know anything about port forwarding), but a TalkTalk chat person has just said that this is OK, and I guess you're saying the same thing.

 

I don't think I can go much further until I can get back to the cat flap support people but that won't be until Monday ☹️

0 Likes