cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Port forwarding on Super Router

ANSWERED
Reply
2 REPLIES 2
Highlighted
ishalyminov
First Timer

Hi! I can't get port forwarding to work on my D-Link Super Router.

 

I made this simple setup: my Raspberry Pi (reserved local IP 192.168.1.2) runs a simple server on port 8000. It responds perfectly from anywhere inside the local network by calling http://192.168.1.2:8000

 

My port forwarding rule for it is as on the screenshot.

port_forwarding.png

 

With this config, I get "connection refused" every time I call http://{router's IP}:8000. Portchecker.co says that the port is open, yet forwarding doesn't work as expected.

 

I tried to make it UDP or Both TCP/UDP, switching between PVC1 and PVC2, setting different internal and external ports, disabling firewall, enabling DMZ for 192.168.1.2 - nothing makes it work.

KeithFrench
Community Star
Solution

You will get this if you try to make the connection from a device locally connected to your router to the internet and back in to the router's WAN IP address or a DDNS domain. This is because this is classed as loopback traffic & is blocked by all TalkTalk router's as they consider this a security risk.

 

Disconnect a phone from the WiFi & then try via 3/4G.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

ishalyminov
First Timer
Thanks a lot, now I get it!:)