Broadband help

For queries about your TalkTalk broadband service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Repeatedly losing connection gaming

TommyLO
Participant
Message 9 of 9

Hi there,

 

Today I have started to have a connection reliability issue with Call of Duty Modern Warfare (PC). I keep losing connection to the servers. Several friends who are on other ISPs are not experiencing this problem and I have tried everything to resolve it that I can think of.

 

My PC is connected to the router (HG633) via ethernet cable. In an attempt to resolve the issues I have added port forwarding so i now I am showing as having an open NAT instead of moderate and configured a static IP address for my PC but this did not really help. It is only happening when connecting to activision servers and I would suspect the problem is related to TalkTalk since I dont seem to have any connection problems for other games/VOIP and my friends on different ISPs are having no issues (Sky/BT) and Activision are reporting a good service on their servers.

 

As an aside I dont know if this could be a physical problem with a momentary loss of quality/packet loss (possibly poor BT wiring) as this only started when the rain started today.

 

 

 

Can anyone advise on anything else I can try

 

Thanks

0 Likes
8 REPLIES 8

Message 1 of 9

Hi TommyLO

 

That's great, thanks for letting us know 🙂

 

In regards to the old router, don't worry about the packaging, you can put the router and cables straight into the returns bag.

 

Thanks

 

Debbie

Message 2 of 9

Hi Debbie,

 

Had the replacement router in for 3 days now, connection issues have disappeared so looks like the router was the problem. Will get the old one in the post shortly although cant find the original packagaing as ive had it about 3 years.

Message 3 of 9

Hi @Matt Lazenby

 

Please can you create a new topic on the Community, we can then look into this further.

 

Thanks

 

Debbie

Message 4 of 9

Hi Michelle,

 

I’m having exactly the same issues as Tommy. Would it be possible to request a firmware update (if necessary), or a replacement hub? I wasn’t having any issues with my previous ISP, and this has happened a few times now with TalkTalk. 

Matt Lazenby
0 Likes

Message 5 of 9

Hi Tommy

 

The replacement router is on its way, please allow 24-48hrs for this to arrive.

 

Let us know how the connection compares with this router.

 

Thanks

 

Debbie 🙂

Message 6 of 9

Hi Michelle.

 

Yes please that would be great 🙂

Michelle-TalkTalk
Support Team
Message 7 of 9

Hi Tommy,

 

I'm sorry for the delay. I've tried to update the router firmware, however this has been unsuccessful. Would you like us to send a replacement router for testing purposes to see how the connection compares?

 

Thanks

 

TommyLO
Participant
Message 8 of 9

Doubtfully related to my current problem but I decided to check service status and my router firmware is out of date. Doest look like it has ever been updated since we got it (v1.21t). I've checked and remote management is enabled but its not being updated. Any suggestions to fix that as well please or can you guys get an update pushed?

0 Likes