Broadband help

For queries about your TalkTalk broadband service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Slow ADSL speeds after engineer visit — DLM reset needed?

matthew_r
First Timer
Message 4 of 4

Hi — we’ve been experiencing slow speeds on our TalkTalk ADSL broadband following some problems with the line. I was wondering if anyone at TalkTalk on here could have a look into this as I’ve not had much luck with customer service on the phone. 

 

We used to get pretty reasonable downstream speeds out of the line (16–18 Mbps) but a few weeks back, this dropped off dramatically (to ~0.5 Mbps). We discovered there was some noise on the line and, following a couple of engineer visits from Openreach, it turned out the problem was a damaged faceplate inside the house, which has since been replaced with a new BT Master Socket 5C. Once the repair was done, the engineer who came in was happy with all the line parameters during his testing and the router reports a good connection quality, but our speeds are still quite low. Since the work last Friday, they’ve crept up to about 3 Mbps now (they seem to go up by around 0.5 Mbps each night) but it’s slow progress and will take quite some time to recover to a useable speed at this rate. I'm sure the line can still handle the speeds we had before as nothing else has changed.

 

I’ve checked the router, microfilters, etc. and I’m reasonably confident the issue is not with any of the internal equipment in the house. I suspect because we had some quite serious noise on the line, we’ve been moved down to a slower band but haven’t been moved back up to where we were before. I was wondering if anyone from TalkTalk might be able to look into this and see if we need a DLM reset or similar to try and get the speeds recovered a bit quicker. 

 

Thanks in advance and please let me know if there’s any further details I can provide to help get this sorted. 

0 Likes
3 REPLIES 3

Message 1 of 4

Hi matthew_r

 

I'm so glad to hear this 🙂

 

Please let us know if you do experience any further issues.

 

Thanks

 

Debbie

0 Likes

matthew_r
First Timer
Message 2 of 4

Hi Debbie — thank you very much for your help, that seems to have had an immediate positive impact on speeds. I haven't tested everything out fully yet but downstream is now back at ~16–17 Mbps over wifi and upstream is also back where it was so that looks like it did the trick! I'll keep an eye on it over the next little while but hopefully that'll remain stable now and there won't be any further issues. Thanks again!

Debbie-TalkTalk
Support Team
Message 3 of 4

Hi matthew_r

 

I'm really sorry to hear this.

 

I've optimised your connection and the line is now in sync at 20mb.

 

Please let us know how the connection/speed compares following this.

 

Thanks

 

Debbie

0 Likes