Broadband help

For queries about your TalkTalk broadband service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Trying to port forward 19132 on my windows 10 pc

Ibrahem_Abbasi
Chatterbox
Message 21 of 21

Hello there

I am trying to host a minecraft bedrock server on my pc . I need the port 19132 to be open and forwarded . I get a static ip address for my pc and I followed all instructions on how to port forward and for some reason I still cant access the server on any device other than my own pc

 

I added some screen shots

Sorry for the way I uploaded the results of ipconflig but I cant send .txt files on the website for some reason

 

results ( ipconflig ).png

static ip address.png

Firewall.png

router port forwarding.png

   

  

0 Likes
20 REPLIES 20

Message 1 of 21

In the server I just change the port number in the settings

Anyway thanks you very much for your time .

0 Likes

KeithFrench
Community Star
Message 2 of 21

If you can't access it just via your LAN, then sorry, but you need to ask Minecraft. I can't tell you how to change to a different port, because I would need to know how to do this on the Minecraft application.

 

My skills are in IP networking, I am not a gamer.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 3 of 21

Sorry for answering too late

I changed it to All and I still cant access . and no I also cant access through LAN for some reason

If I want to change the server port . How to know which port is open and not used by another program ?

 

0 Likes

KeithFrench
Community Star
Message 4 of 21

I only wanted to see the rules that you have added for Minecraft, not everything. I couldn't see the rule called mc server properties, maybe I missed it.

 

Looking at the bedrock one that allows everything - seems a bit dangerous to me, the profile is set to Public. I would think it should be Private, not Public. You could as an experiment set it to all & see what happens?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 5 of 21

Here is everything

I know its a lot 

0 Likes

KeithFrench
Community Star
Message 6 of 21

This is an example of what I want to see:-

 

example rules.png

 

I am not sure what you mean by the properties of bedrock_server ports - is this something to do with Minecraft?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 7 of 21

Yes , my router ip is 10.0.0.138 . about the WAN interface I just saw all other ports forwarding use ppp1.1 so I used it . about the access through LAN sorry I cant check that now but as soon as I can I will send you the results . about the firewall do you mean the whole advanced settings inbound or the properties of bedrock_server ports ?

 

0 Likes

KeithFrench
Community Star
Message 8 of 21

I assume that your router's IP address is 10.0.0.138? The only bit I can't be certain about with the port forwarding in the router is are you specifying the correct WAN interface in the rule?

 

What I meant was can you connect to the Minecraft on your PC from something else locally, by connecting to the PC's 10.0.0.16 IP address?

 

Can you get me the summary screen from the Windows Defender Firewall (with all columns resized as required)?

 

 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 9 of 21

About your question . No I cant access because it also uses the external ip . I don't know if minecraft has a way to join the server through LAN 

 

0 Likes

Message 10 of 21

here it is

 

0 Likes

KeithFrench
Community Star
Message 11 of 21

It is far more meaningful to look at the summary of the firewall rule.

 

Can you get me a fresh copy of ipconfig plus also get me the output from:-

 

netstat -a | find "19132"

 

Can you connect to Minecraft from another device connected locally to your router?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 12 of 21

I disabled the ipv6 and re-checked everything but I still cant access the server

 

Well that is interesting . I found this in the firewall Inbound rules its not the one I made but its with the name of the server and there is four of them two with TCP and two with UDP

bedrock server.png

 

0 Likes

KeithFrench
Community Star
Message 13 of 21

The only problem I can see is that your PC's default gateway in ipconfig is showing up as an IPv6 address, not the IPv4 default gateway. You could try disabling IPv6.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 14 of 21

Firewall.png

router port forwarding.png

results ( ipconflig ).png

static ip address.png

0 Likes

Message 15 of 21

Here is a file with the screenshots 

 

0 Likes

KeithFrench
Community Star
Message 16 of 21

I will wait for the new versions of your screenshots.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 17 of 21

D-Link Dual Band AC DSL-G256DG

for more specific 

 

0 Likes

KeithFrench
Community Star
Message 18 of 21

I can't really help much on a non-TalkTalk router, as I cannot test your rules. If you can re-upload the screenshots using the size option set to large. These are two small & the text gets blurred when I enlarge them. Then I will check them all for you. No port checking website is compatible with UDP ports & will always report as closed.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Ibrahem_Abbasi
Chatterbox
Message 19 of 21

minecraft java edition uses the port 25565 but bedrock and education editions use 19132

Anyway I can change the port from the server settings but don't know how to choose the right ones

My router is D-Link DSL-G256DG . I am not sure if this exactly what you mean 

0 Likes

KeithFrench
Community Star
Message 20 of 21

Are you sure about that port, Minecraft on a Windows PC normally uses TCP port 25565?

 

If you tell me which router you have I will tell you how to configure the port forwarding in there.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes