Showing results for 
Search instead for 
Did you mean: 
Need help?

Unable to turn off google's SafeSearch

Team Player

Hello. Yesterday, I had to reinstall my Windows 10 and today I find that I cannot use Google freely – Google SafeSearch is 'On' and I cannot turn it off. Using the Command Prompt "nslookup www.googledotcom" (the 'dot' is my doing) I see that I'm being redirected to ''.


Who is responsible for the redirection? I have to assume it's TalkTalk because, if I use a VPN, I can go to google's site and change/save my search preferences without a problem.


The only thing that doesn't make sense is that, prior to reinstalling my Operating System, I didn't have this problem. I can't see how the reinstall would cause my ISP to start redirecting my searches to '' but it seems it has...


If anyone can tell me how to fix it so that I can use google without restriction (and not via a VPN) I'd be very grateful. Thank you.

Community Star

Hi @largolady


  1. Open the Chrome browser
  2. Put this in the address bar: chrome://settings/privacy
  3. Switch off (if it's on) the toggle next to "Protect you and your device from dangerous sites."

See if that makes a difference.


TalkTalk KidsSafe in the HomeSafe feature does automatically activate Safe Search. You may find that KidsSafe is switched off in your MyAccount > My Services > View HomeSafe settings but due to a current problem impacting some customers you may find that KidsSafe is activated in the background. Keep an eye on the websites icon in Service Status (Click here) to see when this incident is cleared.  Then re-check.


Alternatively, if you're not taking advantage of the security features of HomeSafe / KidsSafe then test with the workaround of using a different DNS setting in the router.


Here is the advice and router setup needed for using a Third Party DNS (Click here)


Try Quad9 and Google DNS: Primary - and Secondary

 Gondola - I'm a TVPlus customer *  VICELAND it's a TV channel 
Team Player

Hi Gondola and thank you very much indeed for that. I don't have Chrome and don't particularly want it as I'm a Firefox fan. The 'Service Status' page shows a localised issue regarding the web so I'll keep an eye on that out of interest.


Although I didn't mention it in my opening post, I had changed my PC (not my router) to OpenDNS but to no effect. At your suggestion, I've changed my router to and I'm delighted to report that I can now turn google's SafeSearch off and it stays off. For that, you have my sincere thanks.