Broadband help

For queries about your TalkTalk broadband service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unreliable and slow Internet

JamesG
Conversation Starter
Message 15 of 15

Hi, over the last month I have had increasing problems with my broadband.

 

Not only is is running under the guaranteed 35MB/s but it keeps going off intermittently and then returning.  Also the connection must be stuttering sometimes as it causes streaming iplayer/Netflix etc programs to halt and have to be restarted.

 

This morning I again lost my connection, so I immediately ran the line test on the TalkTalk page, twice.  Both times it showed a suspected line fault, but when TalkTalk ran the line test it magically cleared!!   I have now plugged the  router directly in to the test socket on the BT master as requested, but having done this before I am not holding my breath.

 

The other thing that may or may not coincidence is that BT Openreach have recently been working in my close and even had the inspection pit at the end of my home open.  It might be my imagination but things seem to have got worse since then and I am aware, from past professional experience,  the Openreach are more than capable of switching 'pairs' to sort another customers problems??

 

Can you offer and help or suggestions on the lower speed and unreliable connection please?

 

Thanks,

 

Jim

14 REPLIES 14

Message 1 of 15

Hi Jim,

 

Ok thank you for the update and please let us know if you need any assistance 🙂

 

Thanks

 

0 Likes

JamesG
Conversation Starter
Message 2 of 15

Debbie,

 

Since my last message things have been running reliably, I only had one small issue when the speed dropped to below 20Mb/s.  A quick reset of the router resolved this, although I did notice that the DSL speed dropped to 36Mb/s when it had been 40Mb/s, so perhaps that was a 'bridge to far' from an errors perspective.

 

Anyway, in the light of this I will put the old router in the returns post today (Sufferered DNS failures). I am also returning the router I had previous to my contract renewal as I had a lot of problems with it dropping WIFI or the WIFI speed going down to a few Mb/s.

 

Thanks fo your help and support.

 

Jim

 

Message 3 of 15

Hi Jim

 

That's great 🙂 Please let us know how the connection compares.

 

Thanks

 

Debbie

0 Likes

Message 4 of 15

Debbie,

 

The router arrived this morning and I have installed it using the new cables/PSU/filter supplied, to make sure everything is 100%.

The first thing I noticed is that the DSL speed is now showing as 38.5Mb/s which is better that the 29-30 MB/s is was getting.  I will let it run now and see how it performs and keep you posted. If it all performs reliably I will then send you the old router back.

 

Regards,

 

Jim

 

Message 5 of 15

Hi Jim

 

The Huawei WIFI hub is on its way, please allow 24-48hrs for this to arrive.

 

Let us know how the connection compares with this router.

 

Thanks

 

Debbie

Message 6 of 15

Hi Michelle, that's fine thanks.  I will run the test and depending on the results return either the original or new router.

 

Jim

 

Message 7 of 15

Hi Leonie2001,

 

I'm sorry to hear this. Please can you create your own topic and we'd be happy to take a look at this for you.

 

Thanks

 

0 Likes

Message 8 of 15

Internet connection is so slow, I was guaranteed 20mbps at the least and I have ran 3 speed tests which say I’m only getting 1mbps

0 Likes

Message 9 of 15

Hi Jim,

 

Thanks for the update and I'm sorry to hear this. If it's specifically DNS errors that you are seeing then I think we should send a Huawei Wifi Hub for testing purposes to see how this compares. Would this be ok? We would also send a router returns bag so that one of the routers can be returned following testing.

 

Thanks

 

0 Likes

Message 10 of 15

Hi, I let things run with the changes but it hasn't improved things. I have a number of drop outs since, the worst being for several minutes when our Internet went completely offline and only came back when I reset the router. I have now changed the DNS settings back to the default ones.  I can also see that I never get the guaranteed minimum 35Mb/s that I am paying for with my Fast fibre contract, so that need addressing as well.

 

It's a shame because when it is running I am happy with the service, apart from the speed issue and I have always found the service support helpful.

 

So its over to you as to what we do next.?

 

Jim

 

0 Likes

Message 11 of 15

OK Jim, please let us know how you get on

Chris

0 Likes

Message 12 of 15

Michelle,

 

I have an update.  The problem just occurred again!!  I noticed that the WIFI is fine but no Internet access.  I logged on to the router and it was showing the DSL up and running, then I looked at the logs and found that it was caused by a ongoing DNS failure.  I then switched to manual DNS addresses and enter TalkTalk as the first and the Google one (8.8.8.8) as the second and immediately everything started working again.

 

I will leave it like that and see what happens.

 

Jim

 

0 Likes

Message 13 of 15

Thanks Michelle,

 

The phone line sounds OK as far as I can tell.

 

I will try turning the router off for 20mins to see if that helps with the DSL speed which is still below the guaranteed minimum I am paying for.

 

If that doesn't improve things I will try my old router, but I am reluctant to do that as when I was using it I had numerous WIFI problems, although ironically the DSL was good!!  Shame I can't

take the good parts from each one and combine them.

 

Jim

 

0 Likes

Michelle-TalkTalk
Support Team
Message 14 of 15

Hi Jim,

 

Sorry to hear this. I've completed a line test which hasn't detected a fault, however I can see re-connections on the line and the sync speed has been varying. Is your voice service ok with no noise on the line? I can see that you've advised that the router is connected at the test socket. Do you also have an alternative router that you can test with?

 

Thanks

 

0 Likes