Broadband help

For queries about your TalkTalk broadband service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unusable Internet on Mobiles, PCs, Tablets since Friday/Sat AM

RichardLawrence
First Timer
Message 6 of 6

Hi there

 

Since Friday Evening / Saturday AM, we've been unable get internet access on our mobile devices and some issues with PCs aswell.

 

For the past few "years" we have had excellent speeds and the Wifi covers the whole house.

 

This includes iPhones and Android Tablets alike.

On Saturday I spoke to TalkTalk Help and we did a reset and a hard reset of the router (Its a Hauwei HG633) All seemed OK, but we had the "Weak Security" massages on the iOS devices. I though the issue was sorted but it was not. 

 

Our WIFI signal is Good, and our Connection Speed was also good, with no kown faults.

 

And on Sunday I contacted the help again as we still could not get internet access and this time I was asked to change the security settings of the Router by connecting directly to the box and changing the WPA2/WPA settings. The PC connected to the router was working fine, just all our WIFI devices. At first it seemed to have resolved the issue, but alas, ten minutes later we cant access websites, apps etc on Wifi devices.

 

So today I will have to contact Help again to try and find out what has changed, and why we have no Wifi Internet.

RL
0 Likes
5 REPLIES 5

Message 1 of 6

Hi Richard

 

The replacement router is on its way, please allow 24-48hrs for this to arrive.

 

Let us know how the connection compares with this router.

 

Thanks

 

Debbie

0 Likes

Message 2 of 6

I think that is a solution to the issues I now face, thank you

RL

Message 3 of 6

Hi Richard

 

Thanks for updating your Community Profile.

 

I think we should send a replacement router for testing, would you like me to arrange this?

 

Thanks

 

Debbie

0 Likes

Message 4 of 6

Day 3 of bad internet 

 

I just spent another evening making changes to my Router with the help of a TalkTalk chat person.

 

The main change was making the 2.5 GHZ frequency on a non auto channel e.g. Channel 1

 

This made no difference.

 

All devices showing three bars!

 

On a PC connected to the router I get a nice 78mpbs download but on all our mobile and tablet devices it is well below 15mbps with a higher upload speed than the download speed.

 

Something is very wrong.

 

The final conversation was along the lines of having too many devices connected. We have been fine for the past 2 years. I booted off a couple of devices, the XBOX etc which left just three WIFI connected devices - and still the WIFI speed was terrrible.

 

Looks like we are going to have to MOVE PROVIDER.

RL
0 Likes

Debbie-TalkTalk
Support Team
Message 5 of 6

Hi RichardLawrence

 

I'm sorry to hear this.

 

Can you please update your community profile to include your:

  • Name
  • Telephone number
  • Alternative contact number

We'll then look into this further. Please do not post this information on this thread. Once you've updated your profile please post in your topic to confirm it's updated. 

 

Thanks

 

Debbie

 

0 Likes