Broadband help

For queries about your TalkTalk broadband service.

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Why is Tech Support so Poor?

Super Duper Contributor
Message 28 of 28

Since Friday morning, my normally pretty stable wifi has been all over the place with regards to speed and reliability.  I tried to use Chat to see what could be done, but because of my poor connection, I lost the chats twice.  Spoke to an agent (eventually) who remotely changed my wifi channel on my hub, and to monitor the results.  This seemed to do the trick, until Saturday afternoon, when it reverted to wildly variable download speeds.  I tried again on chat on Sunday afternoon...and again failed.  I spoke with another agent, who I could not hear because of the background noise in the call centre (with people shouting).  I asked him if anything could be done about this, and he moved to quiet (-er) locations twice.  After a long exchange it was decided that an engineer visit would probably be useful.  I explained that I would be out of the country working from Tuesday until Saturday night of this week.  He kindly checked that a slot could be booked between 1200 and 1500 today (Monday).  However, his booking system was apparently 'down' so couldn't confirm anything.  He did, though, undertake to call back on all this on 0900 today.  This didn't happen, so I initiated chats again, with two aborted sessions, so spoke again (eventually) with an agent.  I essentially had to start the whole process again. He agreed (after some tests) that an engineer should visit, but of course (because of my absence) that would have to be done next week.  I undertook to follow up next Sunday, but the agent stated that as this was over 7 days after the incident opened, it would probably be closed by then.  I made it clear that would be unacceptable, and not particularly customer-leaning, so I think he is going to try to make sure that I don't need to start from scratch again.  Given my experience here, I am not confident that will be the case.  However, he was trying to be pretty helpful.


I think we all know that the support staff are largely ineffective and by no means forward-leaning or customer-focused.  So here I am, having expended many hours with agents and on aborted chats since Friday, but effectively am no further forward.  They really need sorting out.  Are there any performance improvement programmes in place for these people, or are we stuck with it?  Regards


Message 21 of 28

Hi Muddymedic,


Ok thanks for confirming. @KeithFrench - Would you be able to offer any more advice in regards to the wireless connection?




Message 22 of 28

Hi  Thank you for getting back to me so quickly.  Yes, Tech Support did that remotely for me a couple of weeks ago.  I am currently connected on 2.4, but Properties shows that I am connected on 5!  I am currently upstairs from my hub, connected via extenders.  As expected, Band 5 gives me a very slow and poor connection. However, 2.4 also continually falls in strength and speed, and then I lose connection completely.  Does any of that help?  Regards


Message 23 of 28

Hi Muddymedic,


Could I just confirm, have you tried separating the SSID's?


Split your router's SSID (wireless network name)




Message 24 of 28

Hi @Michelle-TalkTalk .  My wifi signal from my hub has been acting very strangely and into this morning.  My connection to the hub appears fine, with very good and stable speeds.  However, the signal from the hub to my devices (especially those upstairs) is very unstable.  I use extenders to improve that signal, as our walls are very thick, and they typically work well.  Just in case, I reinstalled them yesterday, but with little effect.


Another curious thing is that when I access the hub on 2.4 GHz, the signal tends to be pretty good.  However, the signal frequently drops to a very slow speed, where Upload is much faster than Download.  I then get a 'No Internet, secured' error message across multiple devices ('Failed to obtain IP address' on Android smartphones).  When I check the Properties for 2.4 GHz when these events occur, it shows that I am on Network Band 5GHz!


The hub is set to 'Auto' on both bands. Any ideas as to what might be going on, please?


Many thanks.  Regards


Message 25 of 28

Hi Muddymedic,


Thanks for keeping us updated and please let us know if you need any further assistance.





Message 26 of 28

Hi @Debbie-TalkTalk Many thanks for following this up.  Apologies for not replying earlier, but I have been working abroad and either travelling and working since last Tuesday morning.  My location and circumstances meant that I had little or no access to the internet.


I returned home late Saturday evening, and have been checking my connection ever since.  I am delighted to say that it is now stable and fast, even over wifi, which was the problem I reported to Tech Support in the first place.  


However, I contacted Tech Support today to close the complaint.  Another however:  on contacting the Helpline by phone a little earlier, the recorded message told me that my Engineer visit would take place as I had arranged.  This puzzled me as I hadn't been able to do so before I left (see my previous post).  I spoke to an agent who at first was pretty adamant that one had been booked.  Twenty minutes later, though, it was agreed that the engineer booking had 'failed'.  To be more accurate, it had never been made!  There would appear to be no point in such a visit, as all seems well for the time being.  So, I have closed the complaint and will monitor speed and connectivity at my end in case I have to raise the issue again.  


Again, confusion and mixed messages via Tech Support, which was my observation in the first place.  There really needs to be some service improvement here, and I'm not the first to remark on this on this community.


But again, thanks for your engagement about my Tech problem.  Regards

Support Team
Message 27 of 28

Hi Muddymedic


I'm really sorry to hear this.


Can I just check if wired devices are working ok? Is this only affecting the wireless connection?


I have also completed a line test which hasn't detected any faults and the connection appears to be stable.