cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

Cannot send Mail error from iphone mail app

Reply
11 REPLIES 11
Highlighted
Chatterbox

When I attempt to send an email via my talk talk account from the Iphone (IOS 13.3.1) mail app I get the error message: "Cannot send Mail - The sender address was invalid"

I has been working OK for several months and as far as I can tell nothing has changed.

So far I've tried the following:

Sending emails from the webmail app, works OK.

Receiving emails via webmail and the iphone mail app, works OK

Sending emails via a different mail account from the iphone mail app, works OK.

Closing and reopening the mail app, problem still occurs.

Powering down and powering on the iphone, problem still occurs

Change SMTP settings to include username and password, problem still occurs.

Setting up the email account on a different iphone (same IOS version), same error message despite passing verification checks.

Is anyone having the same issue?

Is there anything else I can try?

Community Star

Hi @Treheveras 

 

If you're not a TalkTalk Consumer (home broadband) customer you may be restricted to webmail access only unless you subscribe to TalkTalk Mail Plus.

 

If you have a mail message from TalkTalk about deletion of your TalkTalk managed mailbox then deletion is after 180 days. After 60 days the mailbox has webmail only access.

 

You say webmail works so that proves the mailbox is ok. But setting up the account on different devices and both saying the email address isn't recognised would indicate the mailbox may be restricted to webmail access only.

 

If you'd like me to check the settings please upload screenshots but image edit first to obscure the first part of your email address. Use the Insert Photos (camera) icon above this Reply area.

 

Email settings - IMAP & POP3 

 

Setting up TalkTalk email on iPhone 

 Gondola - Volunteer 2017-2020

To appreciate my help . . . If I offered a solution Best Answer

Highlighted
Community Team - TT Staff

Hi Treheveras, I can check this for you if you add the affected email address to private notes in you community profile.

 

 

Ady


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


Highlighted
Chatterbox

Hi @Gondola ,

Thanks for the reply.

It is a current Talk Talk home broadband account so I'm sure that isn't the problem.

I'm sure the settings are correct as that hasn't changed and was working for several months.

I know some people reported issues after upgrading to IOS 13 but my phone is on IOS 13.3.1 and has not been updated since it was working.

 

 

 

Cheers

Treheveras

Highlighted
Chatterbox

Hi @OCE_Ady ,

 

Thanks for the reply.  I've updated the private notes section with the affected email address, if you can check that from your end.

 

 

Cheers

 

Treheveras

Highlighted
Community Star

Hi @Treheveras 

 

If you're a TalkTalk Consumer home broadband customer then the mailbox will not be restricted BUT it must be added to your broadband MyAccount.

 

Please check that you have added the email address and it is listed in My Mailboxes.

 

Managing your email in My Account 

 

Manage TalkTalk Mail - Add an existing mailbox.png

 

 

 

 Gondola - Volunteer 2017-2020

To appreciate my help . . . If I offered a solution Best Answer

Highlighted
Community Team - TT Staff

Hi @Treheveras did you get sorted with this?

SimonB
Highlighted
Chatterbox

Hi @simonb,

Due to the lockdown my email use has been very low so I haven't been noticing the problem hence my delay in following up on this.  I haven't got this resolved but from reading other posts with the same issue it appears that Talk Talk have tightened the security on outgoing email to prevent spam by only allow the sender email address to be a valid Talk Talk one.

This change has effectively stopped my email set up that's been working for the last 13 years.

Unless Talk Talk can find a better solution for preventing spam I'm going to have to find an alternative application for my email.

Thanks 

Treheveras

 

Highlighted
Community Star

Hi Treheveras 

 

It's always been the case that to get TalkTalk network authentication you have to send from the same domain name SMTP outgoing server as the TalkTalk managed email address domain.

 

What domain is your sending email address just the bit after the @

 

 Gondola - Volunteer 2017-2020

To appreciate my help . . . If I offered a solution Best Answer

Highlighted
Chatterbox

Hi @Gondola ,

The sending domain is @treheveras.co.uk. It's been that since 2007 and wasn't a problem until a few weeks ago.

 

Cheers

Treheveras

Highlighted
Community Star

Hi Treheveras 

 

It's always been my understanding that TalkTalk didn't authenticate the sending of non-TalkTalk email addresses via the TalkTalk SMTP servers. You'll perhaps have been able to use the gMail servers until their recent tightening of authentication requirements.

 

You can always use the SMTP servers of the mail host that hosts your personal mail domain. That's what most people will do. You just make sure that the mail host servers are approved senders for your personal mail.

 Gondola - Volunteer 2017-2020

To appreciate my help . . . If I offered a solution Best Answer

Highlighted
First Timer

I too was having the same issues,but only on outgoing Mail

This is how I fixed it !

It was how I had my I.Pad set up

Should be the same for I.phones.

** Settings

** Passwords & Accounts

**Pick E.Mail Address you are having problems with

** Select Outgoing Mail Server

** Primary Server

** Look at the menu for Outgoing Mail server

**Host Name,Username/Password if both those say Optional.

Check in Authentication ! I had Password ticked so it was looking for my password before it would send E.Mails.

Either untick Password in Authentication or tick it and put your Username and Paswword in where it says Optional.

Good Luck if you haven’t already sorted it out