cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

Email server certificate is invalid on Android app Outlook using legacy Onetel email after migration

ANSWERED
Reply
Highlighted
Conversation Starter

Hi @Gondola 

I have a Samsung with Android 10. All software and apps are up to date.

Summarising. The Samsung app works but insecurely.            Correct

Gmail will attempt to set up a secure connection. Correct, but doesn't get as far as connecting

Outlook will work only with a secure connection. No, cannot get it to connect whatever security I use/don't use.

I've now tried 'Email - Lightning Fast & Secure Mail' and that comes up with:

 

Login Unsuccessful

[IMAP] A stable connection to the server

could not be established

                                            OK

Highlighted
Community Star

Hi 247cookie 

 

There's a fundamental authentication issue with your phone not being able to connect any apps securely to the talktalk mail server.

 

Just concentrating on the Gmail setup, because that tends to be the most reliable to set up, have you got another mail account (excluding a Gmail account) that you can add as an IMAP personal account to the Gmail app and set up to prove that the phone and Gmail app can connect to an IMAP mail server securely?

 

Ideally a talktalk managed email address like talktalk.net or tiscali.co.uk.

 

Back to the onetel password. Is this now at least 8 multicase letters and number(s), preferably 12-15 multicase letters and numbers and an added symbol?

 Gondola - Halloween ghoul guide

To avoid my red eyes . . . If I spooked a solution Best Answer

Highlighted
Conversation Starter

Firstly, yes I've updated my password to comply with the recommendations - except it's only 11 characters long.

Last night I downloaded 3 other apps to try them out and only the last one half worked!

I only have three email accounts I use:

Onetel

Gmail

Outlook 365 work account

 

The one that is half working on my Samsung Android v.10  SM-G970F is

FairEmail

Set as a Custom account using the imap settings as at the top of this thread with SSL/TLS security.

However the smtp set up couldn't connect to the host and only allowed for a Port number 465

 

I've just tried with a friend's Tiscali account on gmail and that doesn't work either.

 

I'm coming to the same conclusion as you now!

"There's a fundamental authentication issue with your phone not being able to connect any apps securely to the talktalk mail server."

 

Where do I go from here?

Highlighted
Community Star

Hi 247cookie 

 

A password of 11 multicase letters and numbers is ok.

 

Account Type  IMAP (recommended)
Username username@onetel.com
Password Yes
Incoming mail server imap.onetel.com
Incoming Port 993
Incoming Security Type SSL/TLS
Outgoing SMTP server smtp.onetel.com
Outgoing Port 587
Outgoing Security Type STARTTLS
Require sign-in Yes
 Gondola - Halloween ghoul guide

To avoid my red eyes . . . If I spooked a solution Best Answer

Highlighted
Conversation Starter

Using these settings it says 'Couldn't open connection to server' in Gmail with my Onetel email address.

Highlighted
Community Star

And for the tiscali email address?

 

Account Type  IMAP (recommended)
Username username@tiscali.co.uk
Password Yes
Incoming mail server imap.tiscali.co.uk
Incoming Port 993
Incoming Security Type SSL/TLS
Outgoing SMTP server smtp.tiscali.co.uk
Outgoing Port 587
Outgoing Security Type STARTTLS
Require sign-in Yes
 Gondola - Halloween ghoul guide

To avoid my red eyes . . . If I spooked a solution Best Answer

Highlighted
Conversation Starter

The Tiscali account worked perfectly!!

Highlighted
Community Star
Solution

OK, let's try using the tiscali server names but with the onetel.com email address and password.

 

Account Type  IMAP (recommended)
Username username@onetel.com
Password the onetel password
Incoming mail server imap.tiscali.co.uk
Incoming Port 993
Incoming Security Type SSL/TLS
Outgoing SMTP server smtp.tiscali.co.uk
Outgoing Port 587
Outgoing Security Type STARTTLS
Require sign-in Yes
 Gondola - Halloween ghoul guide

To avoid my red eyes . . . If I spooked a solution Best Answer

Highlighted
Conversation Starter

Yippee!

This setup worked first time.

The inbox and sent folder have synced as they should but my drafts folder doesn't. That might be the imap folders settings or how I set it up on my laptop Outlook 2010 and/or via the TalkTalk website login.

 

Puzzling...............................

But great progress!!

 

A test email sent to myself works and shows in both the sent folder and the inbox.

 

Highlighted
Community Star

The Standard folders should all be present.  You can check via the Main Settings menu, Settings menu item, Accounts and then the Edit function of the account in TalkTalk Mail.

 

Selecting Edit will bring up a window and you can scroll down to check Standard folders to see that the standard default folders are all selected.

 

Account - Edit

 

 Gondola - Halloween ghoul guide

To avoid my red eyes . . . If I spooked a solution Best Answer

Highlighted
Conversation Starter

So, with a Onetel account using Gmail on Android 10 I've had to use the Tiscali server rather than the Onetel one.

Does anyone know why that would work and not the Onetel one?

 

 

I've had a look at the settings and linked the folders with the correct names but still my draft folder does not sync on the Gmail app but does on Outlook 2010 on my laptop and also on the webmail via the TalkTalk login - can you suggest anything else please @Gondola ?

Highlighted
Community Star

Hi 247cookie 

 

The Drafts folder doesn't sync with Gmail. It's not designed to.

 

This isn't a great problem because normally the Drafts are automatically saved whilst composing a mail message and the default action should be to delete the draft on sending.

 

Where this can be an issue is when you create a draft to use as a template and then edit a copy for sending. With TalkTalk Mail you can select a copy of the draft template and use that to send out. 

 

The Gmail drafts folder is self contained for each mailbox added to the Gmail app. You can save a draft and pick that up later in the Gmail app and finish composing and send and when sent the saved draft will be deleted. Unlike TalkTalk Mail the Gmail app doesn't have a draft template feature.

 Gondola - Halloween ghoul guide

To avoid my red eyes . . . If I spooked a solution Best Answer

Highlighted
Community Star

...You also asked why the tiscali server host names work but the onetel host names appear not to.

 

In fact the onetel host names do work as people are using them without a problem. Changing the host name does force the app to register a new certificate and I suspect getting the phone to recognise a new certificate is where the root cause lies.

 Gondola - Halloween ghoul guide

To avoid my red eyes . . . If I spooked a solution Best Answer

Highlighted
Conversation Starter

That makes sense.

Perhaps you could share how to delete certificates on mobile phones so that they have a better chance of picking up a new certificate with the correct server?

Highlighted
Community Star

Hi 247cookie 

 

Whilst you can delete certificates in Settings > Security I would rather you let the 'phone manage certificates.

 Gondola - Halloween ghoul guide

To avoid my red eyes . . . If I spooked a solution Best Answer