cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

SSL imap on Android

Reply
8 REPLIES 8
Highlighted
Super Duper Contributor

I can set up my tablet (Nexus7) for talk talk email, but can only connect if I use port 587 with the "None" security setting on the OUTGOING . Connection will not occur on the instructed StartTLS or any other security settings.

 

I could "live" with this but wonder where my problem lies. Any help would be welcomed, as Live Chat cannot help as it is a "3rd party" device.

Highlighted
Community Star

Hi Tony

 

Have you got multiple smtp servers set up on the Nexus7?

I ask because I know that EE have these set up for port 587 but with no security if you happen to be sending via the EE / Orange smtp server.

 

Here's how to add a talktalk email account to your Google Nexus 7 tablet.

  • Start on your Home screen and tap the All applications button
  • Scroll to and select Email
  • Type in your talktalk email address, and tap Enter
  • Enter your email account's password and tap Manual Setup
  • Select Account type IMAP

Incoming server settings:

  • Enter your username
  • Make sure your email password is entered
  • Enter the IMAP server: mail.talktalk.net
  • Enter the security type SSL
  • Enter port number 993
  • Tap Next

Outgoing server settings:

  • Enter the SMTP server: smtp.talktalk.net
  • Enter the security type STARTTLS
  • Enter port number 587
  • Require sign-in - tick this option
  • Username - tap in the username you want to use
  • Password - tap in your email password
  • Tap Next
 Gondola - Volunteer 2017-2020

To appreciate my help . . . If I offered a solution Best Answer

Highlighted
Super Duper Contributor
Thanks.
Yes I also have gmail set up.
I have already used those directions as per the talktalk information instructions. (& rechecked them.) Only by changing StartTLS to none can I get a connection.
Highlighted
Community Star

Hi Tony

 

I know that adding talktalk.net email to the gMail app works just fine.

 

  • Settings
  • Select the talktalk email account
  • Scroll down to Outgoing Settings
  • Require sign-in ON (toggle slider right)
  • Username: Your full talktalk.net email address
  • Password: Your email password
  • SMTP server: smtp.talktalk.net
  • Port: 587
  • Security type: STARTTLS
  • Tap DONE

Does that not verify ok?

 Gondola - Volunteer 2017-2020

To appreciate my help . . . If I offered a solution Best Answer

Highlighted
Super Duper Contributor

No.

It does for the incoming but not for the outgoing unless I change to "none" as security.

Highlighted
Community Star

Hi TonyW2

 

Something not right there.

 

Have you got any security software running and in particular Avast or Kaspersky?

When sending are you sending from the TalkTalk network via wi-fi or another network or a mobile network?

 

To try and isolate the issue to the device. What happens if you set up email on a different device and send email from the talktalk network?

 Gondola - Volunteer 2017-2020

To appreciate my help . . . If I offered a solution Best Answer

Highlighted
Community Star

...just to add that I've done some tests from here using windows Mail and Thunderbird as clients. Sending insecure mail via the authentication of the TalkTalk network does work using port 587 and no security just as readily as using port 587 and STARTTLS security.

 

So, it's just a case of finding out why the device doesn't accept secure sending.

 Gondola - Volunteer 2017-2020

To appreciate my help . . . If I offered a solution Best Answer

Highlighted
Super Duper Contributor

Something not right there. That's true!

 

Have you got any security software running and in particular Avast or Kaspersky? No  (--- until I get this sorted out)

When sending are you sending from the TalkTalk network via wi-fi or another network or a mobile network? Talktalk via wifi router.

 

To try and isolate the issue to the device. What happens if you set up email on a different device and send email from the talktalk network?

Well there's a mystery. I sent a message from another device and it was received. I changed the security again to Starttls and sent a message back. It was received and the settings for outgoing all verify OK.

 

Thanks for your input, but I will leave it alone whilst it's now working.

Highlighted
Community Star

Nice one. If the email is now working it'll stay working. 

 Gondola - Volunteer 2017-2020

To appreciate my help . . . If I offered a solution Best Answer