cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

Unable to send emails from outlook with Vodafone ISP

Reply
11 REPLIES 11
Trolleyman
Team Player

I am unable to send emails using talktalk email account via outlook and the Vodafone network. I have recently subscribed to talktalk mail plus. Are there any different settings that I need to use to access the talktalk smtp server. Incoming emails appear to be OK. I have been trying with smtp.talktalk.net with no luck and various encryption setting. Also the same problem when using mail set upon on IPhone. I have also tried port 25,587,465 with various encryption types still no luck. All seems well using webmail.

Gondola
Community Star

Hi @Trolleyman 

 

The outgoing SMTP server is smtp.talktalk.net

Outgoing port is 587

Connection security is STARTTLS

Tick My outgoing server requires authentication

Do not tick SPA

Tick use same credentials as the incoming server OR enter email address as username and the email password.

 

Are you connected to Vodafone via the CityFibre full fibre network or on standard FTTC part fibre via Openreach?

Gondola - Volunteer 2017-2021

To appreciate my help . . . If I offered a solution Best Answer


Trolleyman
Team Player

Hello

I have tried the settings you suggest but still no joy. Constantly asking for smtp.talktalk.net password and not sending emails. I have just moved from talk talk broadband to Vodafone Gigabyte Broadband 500. I have joined talk talk mail plus.

 

Gondola
Community Star

Hi Trolleyman 

 

So, first thing is that, yes, you are connected to a CityFibre full fibre network via your provider Vodafone.

 

Next thing is to ask is your talktalk.net mailbox added to the MailPlus MyAccount  that you got when you subscribed to MailPlus? And follow up question, if your talktalk email address is listed in My Mailboxes is there a yellow banner message at the bottom of the My Mailboxes area?

 

Similar to this:

 

Manage TalkTalk Mail in MyAccount - Not a broadband or Mail Plus customer.png

Gondola - Volunteer 2017-2021

To appreciate my help . . . If I offered a solution Best Answer


Trolleyman
Team Player

Yes my email address is listed and no yellow box. I have also tried changing my password

I also have a similar problem when I use my iPhone on wifi. But here it repeats smtp.talktalk.net password incorrect but It is correct ?I

 

 

Gondola
Community Star

Hi Trolleyman 

 

I don't know if this will work because they're the wrong settings but change the outgoing port to 465 and with SSL security and still use the password as authentication and for any clients that require it my outgoing server requires authentication.

 

The only reason I'm asking you to try port 465 and SSL is because years ago it was said that Vodafone blocked port 587. No idea why. But give it a try.

 

Let me know the precise error message if any.

Gondola - Volunteer 2017-2021

To appreciate my help . . . If I offered a solution Best Answer


Gondola
Community Star

Hi Trolleyman 

 

Actually, thinking about this I think we should defer testing until the MX server issue with talktalk.net is fixed. You're probably not going to be able to test the setup regardless right now.

 

Leave it a day, perhaps pick up on Tuesday? Does that sound like a plan?

Gondola - Volunteer 2017-2021

To appreciate my help . . . If I offered a solution Best Answer


Trolleyman
Team Player

Hello Again

Yes I will do as you suggest and wait a day or two and then use the settings you suggest. I will let you know the outcome.

Thanks so much for your help so far

 

Trolleyman
Team Player

Hi

I have waited a few days and still have problems. It seems very intermittent with different errors each time 443 is common. This all happens without any changes. Funny thing it works more often if I use a VPN. 

I created a further mailbox and that works OK.

Looks like a problem TalkTalk end with my original mailbox in mail plus.

This was added automatically. 

Just for your info I have used about 6G of my 10G allocation maybe thats to much.

I have not risked deleting my original mailbox because I do not want to loose all my email history. Sorry to say so much but I am doing my best to assist you with problem

Keep Safe

 

Gondola
Community Star

Hi @Trolleyman 

 

443 or too many recipients indicates rate limiting of the connection. Normally associated with mail being sent from networks (usually overseas) or VPN's (possibly non UK hosts) which are considered higher risk of sending out spam and are therefore rate limited as a precaution.

 

I have come across a full fibre UK network being rate limited previously. I cannot recall if it was CityFibre though. Given that TalkTalk have a deal in play with CityFibre I wouldn't have expected them to be rate limiting because that would ultimately impact upon TalkTalk's own customers.   

Gondola - Volunteer 2017-2021

To appreciate my help . . . If I offered a solution Best Answer


Trolleyman
Team Player

Are you looking further into this problem

Gondola
Community Star

Hi Trolleyman 

 

I've not enough information to be able to positively diagnose an issue.

Gondola - Volunteer 2017-2021

To appreciate my help . . . If I offered a solution Best Answer