cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

email sign in not responding

ANSWERED
Reply
10 REPLIES 10
Highlighted
Problem Solver

I have 2 email addresses main one is ok. Second one asked to update settings requiring a password change which i did. when trying to login details just blank over. Need to access this email address

Highlighted
Problem Solver

putting in wrong password. States incorrect. Putting in correct pasword details blanked over and page eventually times out. Weirder still deleting account in Windows 10 mail then re-entering details account delivers emails. Still cannot access via 3 browsers. Sort it out TT. Spoke too soon account details out of date reappeared.Definitely needing sorting out.

Highlighted
Community Star

Hi @kobaltx 

 

You have two mailboxes.  One completely working.  So you know that TalkTalk Mail is working.

 

One mailbox not working.  What email domain is the one that's working and the one that's not working?  Both talktalk.net?

 

Both mailboxes are upgraded to the new TalkTalk Mail platform?

 

When you send a message from the mailbox that's working to the mailbox that's not working do you receive a bounceback error message.  For example, mailbox unavailable?

 Gondola - Volunteer 2017-2020

To appreciate my help . . . If I offered a solution Best Answer

Highlighted
Problem Solver

Hi Gondola No bounceback tried 3 browsers and android pad same result. However mail being delivered via windows mail With settings out of date message still? Tried again and can now access mail via browser. Only thing different restarted laptop with a windows update. Don't think the update had anything to do with it but restart  maybe helped.  Doesn't account for the Pad though. Maybe a lag in TT updating reset? All seems well now. Thanks for your concern and reply.

Highlighted
Community Star

Hi kobaltx 

 

The settings out of date message relates to the use of SSL/TLS encryption and secure ports. It's telling you that you've got no SSL/TLS selected and port 110 or 143 for the incoming server.

 

The recommended settings are Email settings - IMAP or POP3

 Gondola - Volunteer 2017-2020

To appreciate my help . . . If I offered a solution Best Answer

Highlighted
Problem Solver

Hi again Gondola How do i access these settings? Windows mail says Incoming imap.talktalk.net:993:1 and outgoing smtp.talktalk.net:587:0 For both Accounts. No messages on main account. Out of date on the other. Been trying sending mails from various other accounts and now receiving them with no account settings out of date.

Highlighted
Community Star
Solution

Hi kobaltx 

 

Those Windows Mail settings are good and will work just fine.  Below the incoming and outgoing server settings are 4 tickboxes. It's normal to have all 4 ticked.

 

Outgoing server requires authentication

Use the same username and password for sending mail

Require SSL for incoming and outgoing mail

 

If those 4 boxes are ticked already and you have changed the password recently it would be good to make sure the password is cleared and the correct password re-entered and saved.

 Gondola - Volunteer 2017-2020

To appreciate my help . . . If I offered a solution Best Answer

Highlighted
Problem Solver

Hi again Gondola Checked windows mail settings only ssl box unticked. Never had a Problem with outgoing mail. When Windows mail  sets up ssl is left unticked Have ticked it. I'll keep a look out. Thanks again.

Highlighted
Community Star

Hi kobaltx 

 

You've fixed the Windows Mail error message issue by ticking the SSL encryption boxes.  Nice job.

 

Just to explain; when an email client auto-configures itself, as most do, then most will set up a secure connection. However, it may set up an insecure connection with SSL/TLS encryption off and use the insecure port IMAP 143 or POP3 110 and SMTP 25. 

 

If the ports are changed to secure ports IMAP 993 or POP3 995 and SMTP 587 but SSL is left off then incoming mail will fail but outgoing will still work. This is because the outgoing SMTP port 587 will support unencrypted connections but always checks if encryption is available and if it is will upgrade the connection to a secure encrypted connection.

 Gondola - Volunteer 2017-2020

To appreciate my help . . . If I offered a solution Best Answer

Highlighted
Problem Solver

Hi Again Gondola The Messages always arrived some times with settings out of date message but not always. When windows mail is set up the ssl box is always unticked. I am not sure Microsoft actually trusts ssl. The reason i say this is on a previous occasion in Internet Settings ssl was ticked on. This caused Firefox to not load properly.Only by unticking the ssl box in internet settings caused Firefox to load properly. I was advised to use only tls settings. For this reason i no longer use Firefox and i am ambiguous about ssl. SSL remains unticked in my internet settings. However i will monitor the situation. Thanks once more for your input. Always nice to know that someone cares. You Truly are a star

Highlighted
Community Star

Hi kobaltx 

 

The previous advice given to you to use TLS in place of SSL is great advice. That's because TLS (Transport Layer Security) provides stronger encryption than SSL (Secure Sockets Layer). But there's more to add to that advice.

 

Email encryption for connection security has evolved from SSL to TLS. If there's a choice in selection use TLS but generally the strongest available encryption will be automatically selected. It's currently TLS 1.2 that's the default used for TalkTalk Mail.

 

The encryption is often still referred to in email client setups as SSL or SSL/TLS and STARTTLS is used when sending messages to open an insecure connection and then upgrade that to a secure connection. A secure connection is positively recommended so that the password and message cannot be easily seen even if the email is intercepted in between your device and the mail server.

 

Firefox is, in my view a very dependable email client. In Firefox:

  • The incoming server connection on IMAP port 993 requires Connection security set to SSL/TLS and Authentication method set to Normal password
  • The outgoing server (SMTP) connection on port 587 requires Connection security set to STARTTLS and Authentication method set to Normal password

Described differently in Windows Mail:

  • The incoming server connection on IMAP port 993 requires Connection security set to use SSL
  • The outgoing server (SMTP) connection on port 587 requires Connection security set to use SSL
  • Outgoing server authentication is required

It is confusing when different email clients describe the encryption settings in different ways.

 

The important thing to accept is to definitely use connection security (and secure port numbers), rather than no security (and insecure port numbers), to ensure your email password and the message you're sending to the mail server cannot be easily seen.

 Gondola - Volunteer 2017-2020

To appreciate my help . . . If I offered a solution Best Answer