email support

Ask us about your TalkTalk email account and Webmail.

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Emails not secure icon

Dolomite Driver
First Timer
Message 5 of 5

I keep getting the nit secure message in my emails  When I log on mostly it is showing the lock symbol but sometimes says not secure.  I log out if this happens.  At other times all is as it should be but on opening an email it shows it not secure.  Sometimes the lock is there but when I click on the read more button on emails it happens but at other times not.


I have just had an email from TalkTalk and this opened up as not secure.


Are my emails secure?  I'am getting concerned and now considering if moving away from talktalk to get a more secure service is the way forward.  Is this issue common Nd can it be sorted?




Message 1 of 5

Ah, has a somewhat more wholesome approach to action on change and not just to the undergarments that deals with!


But rest assured that TalkTalk Mail is secure and will not short-change you on security.


TalkTalk TalkTalk HomeSafe - An Overview will provide some degree of protection against virus infected websites and the TalkTalk router firewall is protecting you as well.


As discussed, the browser will advise if you're looking at content that's insecure and some browsers will block the entire website. But it's still possible for viruses and malware to be downloaded so anti-virus and anti-malware software for your computer is still strongly recommended.


TalkTalk Online Defence (SuperSafe) Overview 

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

Support Team
Message 2 of 5

Hi Dolomite Driver, thanks for marking Gondola's post as the best answer. Its always great to acknowledge support received from others.




Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.

Message 3 of 5

Thanks for the reply.  Being an OAP and not a wizz on these issues sometimes all this gets confusing. The emails I quoted was actually but I have just had an email from Which and as soon as I opened it the bar at the top goes insecure and as this happens on a lot and sometimes when I first log on it is a concern.  I will look at your suggestion and now feel a little happier.

Thanks Bob


Community Star
Message 4 of 5

Hi @Dolomite Driver 


Given that the website you quote doesn't have a UK presence it's surprising that you're getting their emails if you are a TalkTalk Consumer customer.


Internet browsers will notify the user when there is insecure content (mixed content) even though the webpage is accessed via a secure https connection.


In the case of TalkTalk Mail the connection is fully secure - you'll always see a locked padlock in the browser address bar. However, if some images used in the advertisements or mail messages are located on http websites that will trigger the insecure notification.


Nothing to worry about as regards TalkTalk Mail or Community. It's as well that you know that the browsers are helping you to identify potentially insecure content.


You can if you wish select not to have images downloaded as TalkTalk Mail includes a setting to Allow pre-loading of externally linked image content. So for extra security you may choose to untick that setting. If the setting is unticked and the mail contains such images then the message detail view will have a Show images button and a comment "External images have been blocked to protect you against potential spam."


Main settings icon top right (triple lines) > Settings > Mail (in the side panel) > Untick Allow pre-loading of externally linked images.


When using TalkTalk Mail webmail A genuine message from TalkTalk related to your account will have a yellow padlock icon at the start of the From: line.  That's an additional security check for TalkTalk Consumer customers.

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution