email support

Ask us about your TalkTalk email account and Webmail.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Fix doesn't work for me

PMAPonline
Chat Champion
Message 4 of 4

Sadly, the fix put out by Andy does not work for me.

 

1) I have changed the server address and ports to ...talktalk.net on a phone, and can't get the incoming address to validate.  Nor can I send emails.

 

2) Using webmail, I can't send emails, and haven't received the test email I sent from MS Live Mail.

 

I get error messages saying "Sender Domain not recognised".

 

I think there is a DNS error for tiscali.co.uk

 

0 Likes
3 REPLIES 3

Message 1 of 4

If your mobile email app doesn't have the usual SSL On switch then the outgoing recommendation is STARTTLS. 

 

But don't use None as connection security even though it would work because your sent mail will not be sent to the server securely.

GondolaVolunteer 2017-2022

  Like below to appreciate my help . . . Mark as solved  Accept as Solution

Message 2 of 4

Gondola, thanks for your interest.  Just seen your response.

I have had emails flowing OK since Tuesday afternoon.

Reference my point 1 - a problem setting up my phone to send emails - I have experimented and found that I can use port 587 with security TLS, or security none, but not security SSL as recommended on your support page "Upgrade your legacy mail settings".

So I don't have a problem using my phone for email - but I need to ignore Talktalk's advice!  Very curious!

 

0 Likes

Gondola
Community Star
Message 3 of 4

Let us know if the mails are now flowing in and out.

 

The talktalk.net server host name is the recommended name for all TalkTalk Mail domains. So it should work. Probably does work now so now would be a good time to upgrade the email settings.

 

Select here: TalkTalk Mail Support Hub


Upgrade your legacy mail settings

GondolaVolunteer 2017-2022

  Like below to appreciate my help . . . Mark as solved  Accept as Solution