email support

Ask us about your TalkTalk email account and Webmail.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Mail cant verify the identity of the server "mail.talktalk.net"

dakotadevil
Whizz Kid
Message 56 of 56

Hi all,

I've started getting the Cannot verify server identity for of the server "mail.talktalk.net".

This has only started today and I have checked settings as per the pinned post by the OCE's.

 

Any ideas?

 

Phone 8 on the lastest IOS and im using the standard Apple mail app.

 

Thank you.

 

Regards

Mark

Mark C
0 Likes
55 REPLIES 55

Message 1 of 56

Hi all, there is an incident open for those who can't get this working with a remove and readd. You can track the progress on the service status page. 


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


0 Likes

Message 2 of 56

Didn’t work for me either! I have two TalkTalk emails addresses both now working on iPhone but one doesn’t work on the iPad and one does! Both set up the same as far as I can see.  Issues started on Friday while I was in the US so I thought it was a local issue but now home I can’t resolve.

0 Likes

Message 3 of 56

Obviously the lack of any response from the Community Team must mean they don't know how to fix our problem.

 

Contacting 'Chat' advisors - even technical managers - is pointless.

 

A couple of months back I had a problem with my Homecall email - it took weeks to sort and was only resolved when I had to escalate the issue by a written complaint to the CEO's complaints dept.. Even then it took a lot of hassle until I eventually got a call from a guy who knew what he was talking about and resolved it in minutes!!

 

I then set-up a TalkTalk email address - which I didn't have - it worked fine for a few weeks and now this. Beggars believe...

Keith Mitchell
0 Likes

Message 4 of 56
Turning SSL off and on again has not worked at all for me.
... computer programmer since the 70s.
0 Likes

Message 5 of 56

This did not work for me and, of course, once I'd taken the decision to delete the account that option was not available to try...

Keith Mitchell
0 Likes

Message 6 of 56

I too have found that turning SSL off, hitting done, and then turning SSL on again works - but only for 4 out of five accounts.  The fifth account has a fault recognising the password which I have checked as correct.

 

0 Likes

Keith70
Team Player
Message 7 of 56

I, too, am having this problem. I've tried all suggestions on this topic to solve it and Mail still doesn't recognise my username/password. I also changed my talktalk email password which didn't help. I can, however, still access my emails on my talktalk account.

 

The problem is on all my Mac devices, Imac, Iphone & Ipad.

 

I deleted my talktalk accounts and then tried adding them again - without success.

 

Interestingly, after submitting my talktalk email and password details, both my Iphone & Ipad come up with this message:

 

'THE OUTGOING MAIL SERVER SETTING PROVIDED IS INTENDED FOR O2 CUSTOMERS IN THE UK. O2 CUSTOMERS SHOULD ENTER THEIR O2 EMAIL ADDRESS IN THE PRIMARY OUTGOING MAIL SERVER USERNAME FIELD AND THEIR PASSWORD'

 

Help please!

Keith Mitchell
0 Likes

Message 8 of 56

Hi @watercolour,

 

what worked for me and is key (I don't guarantee the same for you), is the fact that once I turned off SSL, I had to step backwards clicking '<Account' and then 'Done' so that it re-verifies without SSL and ticks appear alongside your TalkTalk credentials.  I then went back in, turned on SLL and then back out the same way clicking 'Done' so that it re-verifies with SSL.

 

If that's what you did and it did not work I hope you can find a solution.  Fortunately, it has worked for some other forum members.

 

Good luck. 

Message 9 of 56
They're not likely to be starting a proper investigation, let alone taking steps to fix it, until they admit they even have a problem; and, at the moment, they appear to be in denial - eg chat agents claiming there are no problems reported, *including* on these community forums(!) and in the service status panel (link at the top of pages here).
... computer programmer since the 70s.
0 Likes

Message 10 of 56

This issue goes a lot deeper.  Not only is the certificate out of date if using an iOS system but on my iMac using either Apple Mail or Thunderbird the TT server is not recognising passwords.  If you get this message and type the correct password in it fails.

 

I am now effectively locked out of email reception except for my gmail account and my Apple account.  This tells me TT is screwed.

 

I have followed the link in another post (by TT) concerning the effect of the new authentication system and have checked all my settings and passwords.  They are all correct.

 

When is talktalk going to fix this?

0 Likes

Message 11 of 56
If the certificate isn't due to *start* until December 2018 then that *does* also count as it being out of date. You can experience the same effect the other way around if the clock is wrong/broken on your own gadget and everything it then encounters on the internet is set for the future as far as it's concerned.
... computer programmer since the 70s.
0 Likes

Message 12 of 56

I have five talk talk email accounts, one gmail and the Apple “me” account.  The last two are working fine.  One or all of the TT account cause the error.  This I have proven by turning off all accounts and then turning each one on separately.

 

this issue only appears on my iPad Air iOS 11.4

 

i have gone through each account changing the SSL setting off/on, re-entering the password and changing the port number. Nothing works. The weird part of this is that I can send emails on all these accounts (if I can get it sent before the error message pops up - every 5 or 6 seconds) and I can as far as I know receive emails.

 

i also notice that the error message states that the certificate is out of date despite the date given being Sometime in December 2018!!

0 Likes

Vamo51
Participant
Message 13 of 56

I deleted the tiscali account on my iPad, switched iPad off and then on again after a minute or two and then added “new” tiscali account. Hey Presto now all works fine!!!

Message 14 of 56
Thank you all, iPhone and MacBook all running ok.
Mark C

Message 15 of 56

Hi @watercolour

 

Look at Stoker's Best Answer on this very thread and the follow up posts and follow the guidance.

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

0 Likes

Message 16 of 56

I am getting this error as well - every five or six seconds.  As soon as you cancel the dialog box it comes up again.  Only happening on an ipad (iOS 11.4) and it makes the device useless because it continually tries to connect, even if Mail is not running.

 

It is not happening on my iMac using Thunderbird.

 

I have checked all the setting on the iPad - this took some time - and the accounts (5 of them are set correctly with correct passwords).

 

Please fix it!!!!!!

0 Likes

Message 17 of 56

Thanks @Chatter58

 

Nice moves.  Thanks for helping out.  Great Community support.

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

0 Likes

Message 18 of 56

Hi. 

 

just in case you didn't fo far enough....when I say 'backed out' of settings I mean:

 

1. Turn SSL off, then click ' < Account' to return one step.

2. Click 'Done', this triggers the verification.  Ticks should appear alongside you connection settings.

3.Go back in and turn SSL on re-do '< Account' and 'Done'  Hopefully ticks again and no more messages.  if you have several accounts like me, you might need to repeat on each account.

 

Hope it works for you but sorry if it doesn't.

 

Cheers.

 

Message 19 of 56

@S_E_F  Your issue isn't this issue. Your mailbox repair has been requested on your own thread.

 

But with the authentication issues of this thread then removing an email account, starting with a fresh setup or indeed changing port numbers or security setup, all to trigger the reauthentication 'magically', are good workarounds as people are finding.

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

0 Likes

Message 20 of 56
Turning SSL off and then on again didn't work here - but that doesn't mean other people shouldn't try it for the vague hope that it will make a difference.
... computer programmer since the 70s.
0 Likes