email support

Ask us about your TalkTalk email account and Webmail.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Mail cant verify the identity of the server "mail.talktalk.net"

dakotadevil
Whizz Kid
Message 56 of 56

Hi all,

I've started getting the Cannot verify server identity for of the server "mail.talktalk.net".

This has only started today and I have checked settings as per the pinned post by the OCE's.

 

Any ideas?

 

Phone 8 on the lastest IOS and im using the standard Apple mail app.

 

Thank you.

 

Regards

Mark

Mark C
0 Likes
55 REPLIES 55

Message 21 of 56

Hi Chatter58

Thank you so much it worked so simple to do perhaps the boffins could tell us why it happened!🙄😀

 

0 Likes

Chatter58
First Timer
Message 22 of 56

This started happening to me yesterday on my iPhone but not iPad.  Just managed to fix it.  I access several accounts from each device.  Only one has SSL enabled.  I toggled SSL off and then backed out of settings and it performed a verification successfully.  I then turned SSL back on and backed out of settings.  Verification performed again successfully.  No more annoying messages and missing emails flooded in.  Hope this works for you 🙂

Message 23 of 56

Hi @Red_Shoes

 

Bit confused about what you're indicating... talktalk.net email problems but you're getting an imap.tiscali.co.uk message?

 

And when you say the issue has happened since notice of talktalk's authentication update... that's 2 months ago.  Is that what you're saying or have I misunderstood something?

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

0 Likes

Message 24 of 56

Hi Gondola

Thanks yes other email is working on both iPhone and iPad and but 

@talktalk.net emails not received  on  iphone but webmail is working

I notice there is another ongoing post re  Certificate not valid which is the same picture that I get when going into details on the message flash imap.tiscali.co.uk not trusted in red I think TalkTalk should look into this matter which has happened since notice of authentication update!!

Its very worrying and I am not confident messing with settings

0 Likes

Message 25 of 56

Hi @Red_Shoes

 

If your 'other' email is working ok is it also working on the iPhone? 

 

And your main email is working on the iPad.  And presumably in webmail.

 

I'm not discounting the fact that there do seem to be issues as one of my talktalk mail accounts didn't receive mail for a while.

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

0 Likes

Message 26 of 56
I only deleted one of my POP3 email accounts & now my iPhone doesn't appear to give me the option to set up a new POP3 account
This is why it's so very important not to mess with one's own settings (if they used to work just fine) when the fault is really at TalkTalk's end. I just tried the insecure port 110 trick here but it made no difference - nor on switching back to the normal 995 POP3 with SSL. The TalkTalk servers are still lying to my mail program and pretending there are no new email messages to download while secretly hoarding them online (ie only viewable via webmail).
... computer programmer since the 70s.

Message 27 of 56
Thanks all, I ended up deleting and reinstalling the email profile on my Iphone. I noticed my Mac has the same problem, so will follow the guides above.

Thanks all, much apprecaited
Mark C
0 Likes

zipppydj
Conversation Starter
Message 28 of 56

@neila1 wrote:

I’m using pop on iPhone and resolved the issue using the above solution: port was set to 995 , SSL on etc: I just changed port to 110 - box came up with ‘continue’ option, I clicked that, then ‘done’ and all emails came through. Then changed back to port 995, and all seems to be working still !! Thanks for the post - resolved the issue where Talktalk couldn’t - despite being ‘helped’ by support all yesterday evening 


Many thanks, this appears to have worked for me. It was driving me mad. Luckily I only deleted one of my POP3 email accounts & now my iPhone doesn't appear to give me the option to set up a new POP3 account only IMAP accounts. So frustrating. 

0 Likes

Message 29 of 56
Hi Gondola and all
Thanks for your help I am loath to delete acc and start again as the weird thing is I am receiving talk talk emails including yours on my iPad but not IPhone with exactly same settings
I have tried changing port no luck
My other email address works so the fault must be with TTalk are they looking in to it? Started Friday the same as everyone else Thanks
0 Likes

Message 30 of 56

Hi @neila1

 

It's magic... but if it works then it's a great trick. Thanks for sharing.

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

0 Likes

Message 31 of 56

I’m using pop on iPhone and resolved the issue using the above solution: port was set to 995 , SSL on etc: I just changed port to 110 - box came up with ‘continue’ option, I clicked that, then ‘done’ and all emails came through. Then changed back to port 995, and all seems to be working still !! Thanks for the post - resolved the issue where Talktalk couldn’t - despite being ‘helped’ by support all yesterday evening 

Message 32 of 56

Hi Stoker, well that would be a magical coincidence!

 

No, it's all Gondola magic.   Gondola Community Magician

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

Stoker
Super Duper Contributor
Message 33 of 56
you guessed wrong.

'use SSL' was already set to on and authentication was already set to password.

I've set the port back to 995 and all seems well. Maybe TalkTalk have just sorted the problem at their end by coincidence.

Message 34 of 56

Hi Stoker

 

The Macbook and Macbook Air are now both on the right settings so it's great that they're now both working as expected.

 

The wife's iPhone now using port 110 instead of 995 tells me that it's set up for a POP3 account.  110 is the insecure port so my guess is that the secure 'use SSL' settings were off.

 

What I'd like you to try is set the port to 995 and the 'use SSL' settings On and authentication to password.

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

Stoker
Super Duper Contributor
Message 35 of 56
Here's what worked for me on my wife's iPhone running iOS 11.4.1(15G77):-

I changed the incoming server port to 110 from 995 and emails have started to download.

This is exactly the opposite of what I have done on the Macbook Air and I don't understand it but it seems to be working.
0 Likes

Stoker
Super Duper Contributor
Message 36 of 56

Here's what has worked for me for POP accounts on my wife's Macbook Air:-

 

I noticed that Mail was working fine on my own old Macbook running OS X 10.11.6 (El Capitan) so when I did a comparison of the settings on my wife's Macbook Air running OS X 10.13.6 (High Sierra) there was a difference in the port used for incoming mail. 995 was being used on my Macbook whereas 110 was being used on the Macbook Air. After changing the settings on the Macbook Air and restarting Mail the emails started to download.

 

HTH

0 Likes

Message 37 of 56

Hi @Red_Shoes

 

First just make sure the mail account is working in webmail and the password you enter manually rather than relying on a saved password.

 

For an iPhone that doesn't give the option to accept the certificate and continue just delete the email account and set it up again.  Settings > Accounts & Passwords and tap Add Account. For iOS 10.3.3 or earlier, go to Settings > Mail > Accounts and tap Add Account.

 

The tiscali email settings are included in this article (Click here).

 

During the manual setup process the mail app will check and test the settings and during that process you'll get the option to accept the certificate if it isn't automatically accepted by the mail app.

 

You may have to recheck and update the settings if the mail app does not initially use the recommended settings. Check carefully that the mail server names are fully correct and the port numbers are correct and authentication is by password.

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

0 Likes

Red_Shoes
Popular Poster
Message 38 of 56
Same here error message flashes up all the time so annoying when you press details it states imap.tiscali not trusted in red then details go on for ever with no way to accept
0 Likes

Message 39 of 56

Fair comment my appologise for jumping the the wrong conclusion. 

0 Likes

Message 40 of 56

Hi @Horse_0101

 

Just to clarify that the part of TalkTalk scheduled for an outage up to 8pm today, 5 August, is My Account (Mobile only).  That's the MyTalkTalk app.  It looks like the part of that being worked on is Mobile Billing.

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

0 Likes