email support

Ask us about your TalkTalk email account and Webmail.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

SMTP not working on onetel account since upgrading to El Capitan

Emore
Chatterbox
Message 14 of 14

I have just had a new SSD installed in my Mac and the OS is now El Capitan. The guys who installed it have not been able to get my onetel email account fully operational. I can receive, but not send emails.

 

The connection doctor says "Could not connect to this SMTP server. Check your network connection and that you entered the correct information in the Account preferences. Also verify that the server accepts connections on port 25. If it does not change the port number in the Advanced tab of Account preferences".

 

The network connection is fine (I can receive emails).

 

The Mac guys followed these recommended settings.

 

Description is Onetel Smtp

Server name is smtp.onetel.com

the port is set at 25

Authentication is set at None

Use SSL is unchecked

Allow insecure authentication is unchecked

 

They were stumped. I know nothing so of course am stumped. Any help would be greatly appreciated.

 

 

0 Likes
13 REPLIES 13

margaret22
First Timer
Message 1 of 14

I had a similar problem today with my old Onetel acount, having a Plusnet one at the moment. I could not send from my Onetel account.
These worked for me to ‘send' from the Plusnet address
-
incoming: pop.onetel.com
outgoing: relay.plus. net
select ‘my server requires authentication’ -settings- log on using -account name=enter your plusnet usename and password -ok
The advanced tab then showed: outgoing mail smtp, port 25, [Plusnet?], incoming mail Pop3, port 110. 

Windows Live Mail on W10.

Regards, Margaret

0 Likes

Message 2 of 14

Hi Emore

 

Yes you'll have been sending from a different SMTP server.  Because onetel is an insecure email platform the SMTP server requires login using the email username and password and for spam protection requres authentication from the TalkTalk network. 

 

The situation will change when the new TalkTalk mail platform goes live as all onetel mail client users will change to secure connections so sending off-network but via the onetel SMTP server will become possible.  We just await the public launch of the new TalkTalk Mail. 

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

0 Likes

Message 3 of 14
Gondola - I think changing the SMTP server to my plusnet server has fixed the problem! Many, many thanks for your forensic analysis!
0 Likes

Message 4 of 14
Yes I am confirming that I am not a current TalkTalk customer. I'm sorry I don't understand this fully, but are you saying that, because it worked up until 2 days ago, I must have been sending using a different SMTP server?
0 Likes

Message 5 of 14

...are you confirming that you're not a current TalkTalk customer? 

 

If you're not a current TalkTalk customer and attempting to send using an email client / app calling the onetel SMTP server but off the TalkTalk network then sending will fail.  I did say that in my first post.

 

If you're saying that onetel mail was working using an email client / app then I'd say you weren't previously sending using the onetel SMTP server.

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

0 Likes

Message 6 of 14
Well my Accounts window doesn't look quite like that... No host name, but it says my incoming mail server is pop.onetel.com and my outgoing server is smtp.onetel.com. Bear in mind that up until 2 days ago and the upgrade the onetel accounts were working fine.

My onetel account was set up long ago when I was a onetel customer, which I no longer am.

My plusnet accounts have a different mail server.

0 Likes

Message 7 of 14

Hi R

 

A 'tidy' graphic is always a nice illustration.

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

0 Likes

Message 8 of 14

 

That's a very tidy graphic Gondola, and yet, the passwords don't match .......................... ha!

 

~R.

0 Likes

Message 9 of 14

Hi @Emore

 

I believe your Apple Mail should have an SMTP entry:

 Screen Shot 2018-07-29 at 13.03.42.png

 

With the SMTP server setup. And when you look in Keychain there should be SMTP server entries.

 

You mention Plusnet. Are you a TalkTalk customer? I mentioned earlier that onetel SMTP email requires sender authentication from the network. i.e. You must be sending from the TalkTalk network. 

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

0 Likes

Message 10 of 14
Thanks for all your advice Gondola. There is only one entry for the onetel email address in Keychain Access. It's for the POP incoming server. Do I need to create another entry then for the onetel SMTP?

(Equally, there's only one entry for my plusnet email account that's fully working?)
0 Likes

Message 11 of 14

Hi Emore

 

Apple Mail needs to have saved your email SMTP server login name and password. This is stored in Keychain Access on your Apple computer.

    Applications > Utilities > Keychain Access.

The app will need you to type in your macOS User Account login to authorise viewing the password.  Then click Allow to see the Mail password.

 

The SMTP server must have a password saved in addition to the IMAP or POP incoming server.

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

0 Likes

Message 12 of 14
I'm not sure how this could be. The guys reset my passwords after installing El Capitan. The password is set up for incoming emails, and as these are working fine, I assume the password is fine. As far as I can see, no password authentication is needed for outgoing emails, which are the ones that aren't working.
0 Likes

Gondola
Community Star
Message 13 of 14

Hi @Emore

 

Your settings are correct.

 

Onetel is an insecure legacy email platform and sending is authenticated by the username - the full email address - and the email password AND by sending when connected to the TalkTalk network.

 

If your email address and email password are not recognised and or you're not getting authentication from the TalkTalk network then sending will fail.

 

Don't forget that your passwords are stored in Apple / iCloud Keychain. If that's been cleared on the upgrade to El Capitan then you'll need to restore passwords.

 

For confirmation, the email client settings are here. Scroll down to the onetel section.

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

0 Likes