email support

Ask us about your TalkTalk email account and Webmail.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Security Padlock symbol changes to 'Not Secure'

AndyG8
First Timer
Message 3 of 3

There is occurring a problem while reading emails 

The padlock security symbol is visible when I open the Inbox.

However, as soon as I open an individual mail, the padlock symbol is replaced by a ‘Not Secure’ label, which remains until I log off.

 

AndyG

0 Likes
2 REPLIES 2

Ady-TalkTalk
Support Team
Message 1 of 3

Hi Andy, it seems Gondola has this well in hand for you. Please let us know how you get on. 

 

 

Ady


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


Gondola
Community Star
Message 2 of 3

Hi Andy

 

The TalkTalk Mail site is secure as the https secure connection and the closed padlock assure you.

 

If a mail message contains image content hosted on an insecure server that will flag up in the browser as 'Insecure' when loaded.

 

The browser will remain showing the insecure notification even when navigating away from such a mail message. Simply refresh the browser using the browser page refresh circle arrow icon top left toolbar to regain the secure padlock in the address bar.

 

If content is definitely spam then it's best not to load those images as not only will that tell the spammer of an active mailbox but there's a risk the images can hide embedded links to download malware.

 

TalkTalk Mail includes a Display setting to 'Allow pre-loading of externally linked image content'. So for extra security you may choose to untick that setting.

  • Main settings menu, (triple line icon)      top right header
    (Mobile browser or Mail app1 settings menu is the cog icon)
  • Settings menu item
  • Mail (or Email in the left side pane)
  • In the Display menu
    Untick 'Allow pre-loading of externally linked images'
  • 1 In the Mail app Security settings, switch off 'Allow external images'

 

Allow pre-loading of externally linked images.png

 

If the Display linked images setting is unticked and the mail message contains such images then the Detail view will have a Show images button and a comment "External images have been blocked to protect you against potential spam."

 

External images have been blocked

 

On receiving the mail message if you trust the sender then select the Show images button in the Detail view and the image content will be downloaded.

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution