email support

Ask us about your TalkTalk email account and Webmail.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Since upgrade emails deleted from inbox in client stay on server and in webmail inbox

Ed901
Popular Poster
Message 15 of 15

For my emails I use MacOS Mail on my MacBook, iOS Mail on my iPhone and your webmail service. Until recently my mailboxes all stay synchronised as I use IMAP settings.

 

However, since the new upgrade to the TalkTalk Mail service I have found that emails which I delete in my email clients are not also being deleted from the server. When I login to my webmail they still appear in my inbox (albeit very slightly greyed-out to the other emails). In the other direction everything seems to works fine -- so changes I make in webmail are reflected in my clients.

 

I have looked through all my settings and tried altering a few, but whatever I do I cannot find a way to make the emails which I delete from my inbox in my clients also delete from the server/webmail inbox.

 

Please can anyone help resolve this? Many thanks in anticipation.

0 Likes
14 REPLIES 14

Message 1 of 15

Hi @Gondola 

 

Sorry for the slow reply.

 

In answer to your question -- I get the ghost emails whether the deleted messages are read or unread.

 

Following your advice on how to do a manual setup I deleted, rebooted and reinstalled my Lineone.net account in MacOS Mail for a second time. I had to put in the wrong password several times before it let me get around the automatic setup. After entering all the settings manually I then had an issue with sending emails -- I checked and re-checked my settings but kept getting errors such as the password not being recognised and that the smtp was "offline". Eventually I gave up and went to bed! Fortunately today it seems to have resolved itself and is working okay.

 

However after more test emails, the same issue with the deleted messages persists, with the only bizarre difference being that I have to quit MacOS Mail twice before the deleted (greyed-out) messages disappear from the server's inbox!

 

As I said before, thank you for all your time and help -- any further thoughts are appreciated but not essential.

0 Likes

Message 2 of 15

Hi @Ed901 

 

If you don't see the Manual setup option when first creating a new account there is a workaround to forcing a manual setup.  The auto-setup, by giving you port 143, has selected unencrypted emails.  So, not a secure connection.  Not recommended.

 

The workaround is to put in the wrong password.  Just the once so that the account does not connect to the server and cannot try an auto-setup.  Then proceed with the manual setup but this time with the correct password and the full secure settings.

 

The Inbox mail being moved on deletion from the Inbox to the Trash folder is good.  Are the ghost emails just a ghost of unread email. i.e. Do you delete before reading or do the ghost emails persist even when read?

 

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

Message 3 of 15

Hi @Gondola 

 

I followed your instructions as closely as possible to delete, reboot and reinstate  -- however I couldn't work out how to get around Apple's automatic setup procedure. Having clicked on "add account" a window opened asking for my name, email address and password. Once entered it automatically set everything up and downloaded my messages from the server -- this all seems to have happened correctly, except on checking the email settings it detected the Incoming Port as 143 (rather than the 993 stated in your table - although both seem to work), all the other settings matched your table.

 

Unfortunately following some test emails the situation appears to remain as it was before -- so emails deleted / moved to trash in MacOS Mail are also moved to the trash folder in TalkTalk Mail, BUT they also remain in the TalkTalk Mail inbox (albeit greyed-out) until I Quit Mail when they then disappear from the inbox.

 

Thanks again for all your help and assistance. Any further thoughts appreciated but not essential.

0 Likes

Message 4 of 15

...table updated, just for completeness and to avoid confusion.

 

From what I see and because the account is working I think you do already have the correct settings. The deletion, reboot and then reinstatement of the lineone email account is just to clear any software error. Fingers crossed.

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

0 Likes

Message 5 of 15

Hi @Gondola 

 

Thanks again for your quick response.

 

In answer to your query, yes it is a lineone.net account.

 

Thanks for the help and advice. I will try deleting and adding the account once you update the settings table (although I think I know most of the settings).

0 Likes

Message 6 of 15

Hi @Ed901 

 

Query from here - you've got a lineone account selected on the Advanced tab? If it is a lineone.net account we're talking about rather than the talktalk.net account I'd assumed then let me know and I'll edit the table of settings I've given below. TalkTalk's recommended settings are: Email settings - IMAP or POP3 

 

I do think it's likely to be a strange software thing with MacOS Mail and without knowing all the configuration settings the easiest way to check is to set up afresh.

 

I'd delete the TalkTalk account, reboot the MAC, add the TalkTalk account and test to see if there's any difference.  Apologies in advance if no change.

 

Don't setup automatically.

 

The lineone.net email settings you need are:

 

Account Type  IMAP
User Name username@lineone.net
Password Yes
Incoming Mail Server imap.tiscali.co.uk
Incoming Port 993
Use SSL Yes / on
Use Authentication Yes
Outgoing mail server smtp.tiscali.co.uk
Outgoing Port 587
Use SSL Yes / on
Outgoing Authentication Password

 

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

Message 7 of 15

Hi @Gondola 

 

Thank you for your quick feedback -- it's really appreciated.

 

I'm not sure why I store junk on the server either!? ...didn't really think!

 

Sorry I didn't show the whole window in the earlier screenshot but it possibly included identifying information, but yes, IMAP. Please see screenshot of Advanced tab below (where I've covered the identifying info so you can see the whole window) -- the inactive POP accounts are all old Virgin accounts (not used for years). I'm not sure what you mean about "enabled POP3 account for TalkTalk on the Advanced tab", hence the screenshot...

 

Mail Settings2.jpg

 

As you suggest I had considered deleting the TalkTalk account from MacOS Mail and reinstalling it, but I was a bit worried I might lose all my emails and I wasn't sure whether it would make any difference to the problem -- but if you recommend it I will try it? By the way, I have used IMAP settings on this account for a long time -- I can't remember exactly when I switched from POP3, but at the very least it would've been over 3 years ago.

 

Thanks again for your time and effort.

0 Likes

Message 8 of 15

Hi @Ed901 

 

The Mailbox Behaviours looks ok for your version of MacOS Mail. I wouldn't bother with the ticking of Store Junk on the server but otherwise it's fine and just as I would set it up.

 

For clarity, and only because I cannot tell from the screenshot, the TalkTalk account is set up as IMAP?  And there's no enabled POP3 account for TalkTalk on the Advanced Tab?

 

If it's a glitch / an inherited (POP3?) setting that's still there, then as all the emails are on the server what you could do is delete the TalkTalk account from MacOS Mail and set it up afresh. 

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

Message 9 of 15

Hi @Ady-TalkTalk - Thanks for the prompt reply. The issue didn't occur until the upgrade to TalkTalk Mail a few weeks ago, so this lead me to the conclusion that the issue was with TalkTalk rather than Apple -- now I'm not so sure (as you will see in my reply to @Gondola )? I will try asking Apple, but I'm not sure they'll be that helpful in supporting an older version of Mail -- I'll probably be told I need a new Mac so I can run the latest software! Thanks again for your assistance.

0 Likes

Message 10 of 15

Hi @Gondola - Thanks for taking the time to reply to my post. Unfortunately (for me) my MacBook reached an age last year where it is now too old to update to the newest Apple OS releases (I'm running OS X El Capitan ver. 10.11.6) and hence I can't upgrade to the latest MacOS Mail. I had already come across the Mail Guide to Mojave 10.14 that you linked to, but I do not seem to have the same stated options available in my (older) version of Mail, see below -

 

Mail settings.jpg

 

As I said in my earlier post -- now I know that I just need to quit Mail, it's more of a niggle than a real problem -- but it didn't happen before TalkTalk Mail was upgraded a few weeks ago. This is what originally made me think it was an issue with TalkTalk Mail rather than MacOS Mail? Now I'm not quite so sure -- maybe there is some incompatibility with my older version of MacOS Mail as the new iOS Mail is fine? I guess my solutions are to try a different email client on my MacBook or buy a new computer! Thanks again for your help.

0 Likes

Message 11 of 15

 You can try asking Apple as it's their product that seems to be the root of the issue. I'm sure they'll have tips and tricks to offer you. I suspect they'll have a workaround for you. 


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


Gondola
Community Star
Message 12 of 15

Hi @Ed901 

 

Depends which version of MacOS Mail you're using but here's an extract from the Mail Guide to Mojave 10.14. Scroll down to the section on Viewing Deleted Emails. You'll see that if the TalkTalk Mailbox is specified (and folders are synchronised by IMAP) in Mailbox Behaviours then when you Delete in MacOS Mail the deleted email will be moved to the Trash folder.

 

And it's exactly the same with Thunderbird. In Server Settings the default is When I delete a message it is moved to the Deleted folder for the IMAP Mailbox.

 

Thunderbird Server Settings.png

 

There is the option of just marking as deleted or removing immediately. But they're user options, not the standard IMAP default.

 

My take is that MacOS Mail and Thunderbird do work as expected with TalkTalk Mail.

 

In MacOS Mail just have a look at the TalkTalk account and Mailbox Behaviours to make sure the Mailbox is selected.

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

Message 13 of 15

Hi @Ady-TalkTalk, Thank you for your reply and yes, I'm fairly sure my "delete from server" settings are correct. Since my original post I've been searching other forums for suggestions and I've further isolated the issue. Contrary to my original post everything sync's correctly between the mail client (Mail) on my iPhone and the TalkTalk server (i.e. messages I move to trash on my iPhone move to trash on the server and hence my MacBook). The issue is between the mail client on my MacBook (Mail version 9.3) and the TalkTalk server. When I delete / move messages to trash in Mail on my MacBook they move to trash on my iPhone but on the server they stay in the inbox but are greyed-out more than a normal read message. To get the greyed-out messages in the inbox on the server to move to trash on the server I have to fully "quit" Mail on my Mac and then they move! I found the following on a Microsoft forum which might help explain the issue further...

 

"By default, Mac Mail does not send a complete delete command to servers like Outlook.com until the message is one month old. There should be an option to "Permanently erase deleted messages when: (Never / one day / one week / one month old / quitting email)." If you choose to permanently erase deleted messages when quitting mail, for example, Mac Mail will send up complete delete commands when you exit the app. Please try this option out and come back to the thread if you have any issues here.

For the record, Thunderbird also doesn't delete messages by default. The option in Thunderbird is under "Server Settings", called "Clean up ('Expunge') Inbox on Exit."

IMAP clients like Mac Mail and Thunderbird aren't doing what users expect. As such, I'm thinking about ways to make the user experience better by tweaking some things on the Outlook.com server side.

Thanks for reporting this and sorry for the frustration. I hope my answer helps.

Ben Poon
Outlook.com Program Manager"

 

Then in reply...

 

"Hi Ben,

It seems you are right. When quitting Mac Mail the deleted messages in Mail are moved to the deleted map on the server. But be carefull. Don't use the option 'Delete mails after...' in Mac Mail. That did delete all my messages in the deleted folder. Not really a problem for me, but be aware of that.

Thanks for your advice."

 

I don't know whether the delete when one month old thing works as a month hasn't passed yet, but I'm trying to test that (although it's difficult as it means I mustn't quit Mail or reboot my computer for a month). It's interesting that Mail on the iPhone works as expected and it's only Mail on the MacBook that has the problem. I don't know if anything can be done to resolve the issue, but now I've found out that I can sync everything properly by simply quitting Mail it's not so much of a problem -- just a niggle.

0 Likes

Ady-TalkTalk
Support Team
Message 14 of 15

        Hi Ed901, I'm sorry to do this, but you have made sure they're all set to delete from the server when deleted haven't you?

 

 


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


0 Likes