email support

Ask us about your TalkTalk email account and Webmail.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

TalkTalk Email on a Samsung phone

jbuchanangb
Philosopher
Message 6 of 6

Solved my own problem eventually. I have 2 TalkTalk email accounts on my Samsung phone, both working fine until recently. Then they ceased to work over 4G while continuing to work over wi-fi.

A month ago I referred the problem to Vodafone, and they reset Secure Net, and the accounts work OK again until yesterday.

There is a related thread here

After discussions with Vodafone and Samsung, I discovered that my IMAP settings were for security "None" on port 143. Why had it ever worked?

So I set the port to 993 and have to choose between "None", "SSL", "SSL (Accept all certificates)", "TLS", and "TLS (Accept all certificates)". 

According to the relevant help page the choice should be "TLS". On this Samsung Galaxy phone running Email client Version 6.1.50.25 the security option which works is "SSL".

Who would have thought it?

Retired the 11 years old Dell, new one is an Inspiron 3881 running Windows 10 and a Qualcomm QCA9377 Wireless Network Adapter with Sagemcom FAST 5364 router.
5 REPLIES 5

Message 1 of 6

Thanks for taking the time to post how you fixed your problem.

 

Ady


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


0 Likes

jbuchanangb
Philosopher
Message 2 of 6

That’s right. So it is a bit confusing when the TalkTalk instructions clearly state to use TLS, when actually SSL is what works. Anyway all sorted now, I just posted this so others might learn from my discovery.

Retired the 11 years old Dell, new one is an Inspiron 3881 running Windows 10 and a Qualcomm QCA9377 Wireless Network Adapter with Sagemcom FAST 5364 router.
0 Likes

Message 3 of 6

There are different variants of the J5. I guess your incoming server settings look like those depicted here?

 

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

jbuchanangb
Philosopher
Message 4 of 6

Mine is a Samsung Galaxy J5 (2017) aka J530. Not sure if that counts as an "older" Samsung device. It confused Samsung Technical support, and it doesn't exactly match the characteristics of the J5 (2017) depicted on Samsung's web site.

Retired the 11 years old Dell, new one is an Inspiron 3881 running Windows 10 and a Qualcomm QCA9377 Wireless Network Adapter with Sagemcom FAST 5364 router.
0 Likes

Gondola
Community Star
Message 5 of 6

@jbuchanangb wrote:...Samsung Galaxy phone running Email client Version 6.1.50.25 the security option which works is "SSL". Who would have thought it?

That'll be me then! The older Samsung devices, for example a Samsung Galaxy Note 4, has the security types that you mention e.g. SSL or TLS.  Newer Samsung devices specify SSL/TLS for incoming mail security.

 

IMAP Port 993 and Security Type SSL is the correct setting to use for your device.

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution