email support

Ask us about your TalkTalk email account and Webmail.

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Talktalk IP address blocked

First Timer
Message 14 of 14

I am getting this error message when I try to send emails from my laptop to my "published" email address (which is redirected behind the scenes at to an outlook exchange account). It implies that the talktalk IP address is on a blacklist.

I can't work out how to report this to Talktalk. Does anyone know?

When I do the same thing using my phone (not connected to the wireless network and so not using this IP address) it works fine.


Many thanks


Reporting-MTA: dns;

Action: failed
Final-Recipient: rfc822;[public email address]
Status: 5.0.0
Remote-MTA: dns;
Diagnostic-Code: smtp; 550 5.7.1 Unfortunately, messages from [] weren't sent. Please contact your Internet service provider since part of their network is on our block list (S3150). You can also refer your provider to []


Message 1 of 14

Hi SPJ62 


I thought the connected accounts feature was just dropped from i.e. Microsoft's webmail service?

GondolaVolunteer 2017-2022

  Like below to appreciate my help . . . Mark as solved  Accept as Solution

First Timer
Message 2 of 14

And Microsoft withdrew the facility I want in May 2021.  Grrr. It would suck in emails from any IMAP or POP mailbox, and add them to the inbox.  The alternatives offered are rather second best 


Message 3 of 14

Hi SPJ62 


The monetising approach of the UCEPROTECT organisation is disliked, by many, along with their listing of IP address ranges and not just individual servers. But if spam is sent and finds a UCEPROTECT honey-pot trap then it's inevitable that a blacklisting will follow.


I'd be pretty confident that Microsoft wouldn't solely rely on a UCEPROTECT blacklisting.  I'd also be confident that Namesco would be fighting spam as much as anyone including TalkTalk.


Thanks for alerting us to the issue.

GondolaVolunteer 2017-2022

  Like below to appreciate my help . . . Mark as solved  Accept as Solution

Message 4 of 14

Thank you - I think my comment above crossed in the ether. Namesco will not be paying the ransom.


This is definitely nothing to do with Talktalk, but thank you all for your assistance!

Message 5 of 14

Hi SPJ62 


SRS, the rewriting of the mail header by the forwarding mail server isn't a cast iron guarantee that mail will not be rejected by the receiving mail system. It does help to improve deliverability but it rather depends on the checks carried out by the final recipient's mail service.


The mail host IP address is currently listed on the UCEPROTECTL2 blocklist that is effectively a low reputation spam host blocking list. I'm sure their email admins will know and will be trying to improve the sender reputation / eliminate spammers / use a different sending IP address.


But if you can pull the mail in / collect it rather than forward it that will get around the current problem.

GondolaVolunteer 2017-2022

  Like below to appreciate my help . . . Mark as solved  Accept as Solution

First Timer
Message 6 of 14

So Namesco (who own the IP address have just contacted me to say the following. So it looks as though (at least temporarily) Microsoft were using a bad blacklist, which is my some of my incoming emails were bounced.  Anyway it all seems to be working OK now. So we now need an authoritative way of checking if a blacklist is good or bad! 


"We have checked the system and we can see that the email server IP that you are sending from has been added to the following blacklist:



Upon further investigation we have determined that UCEPROTECTL2 is a known fraudulent blacklist service that blacklists entire IP ranges and then attempts to hold them for ransom. The ransom fee for the blacklist will not be paid and the IP will be removed from their blacklist within 7 days."


Message 7 of 14

Please let us know how you get on.




Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.

First Timer
Message 8 of 14

Thanks (sorry I have been focussed for a while on fixing a printer problem, now sorted).   

I'll have a think about that.  The whole reason I bought the domain (nearly 20 years ago now!) is so that I could use the same "public" email address while changing the underlying mail provider, ISP, etc.    [I thought Exchange had a facility where it could go and suck in emails from other mailboxes, but I can't now find it]. 


Message 9 of 14

Hi SPJ62 


The issue is that forwarding mail via your personal domain isn't reliable when the final recipient mail service checks for potential spam senders.


The final recipient mail service will check the SPF file for the originator of the mail message. If that SPF file designates that only specified mail servers are permitted to send mail then your personal domain mail service will not be one of the permitted senders and as a result the mail might not be accepted because it will be deemed potentially spam.


However, if the SPF file designates that any mail sender may be used then that mail will be accepted when sent on by your personal domain mail sender.


The net result is that some mail can be received, some mail can be dropped.


It's therefore best to collect mail from your personal domain mailbox rather than forward on.

GondolaVolunteer 2017-2022

  Like below to appreciate my help . . . Mark as solved  Accept as Solution

First Timer
Message 10 of 14

Thank you again.  I have a personal email domain (which is hosted by what appears to be the owner of the IP address, and my account there simply redirects all incoming email to my outlook account (with SRS enabled).  I have raised a query with them, as it does rather look as though their IP address is being blacklisted by  Outlook.  So I agree doesn't look like a talktalk problem.


The weird thing (which is what made me suspect my ISP!) is that 

* I sometimes get an error message if I send an email from myself to myself using the outlook client 

* but it works OK if I use the outlook webmail, to do exactly the same thing.

* and it works OK if I use my phone (on 4G)

And (I really am not making this up) things that were failing 30 mins ago now seem to be working OK (eg sending an email from my work account). So maybe Ukservers have sorted the issue at their end. 



Message 11 of 14

Hi SPJ62 


I just checked the sending IP address that's being blocked and it's not a TalkTalk public IP address it's the IP address of a personal domain server.


Your TalkTalk IP address can be discovered by simply keying in


So, what is it that you're doing with email?  Sending a personal domain mail message via the mail host sender at or forwarding via that sender?


I don't see this as a TalkTalk issue. What's your take?

GondolaVolunteer 2017-2022

  Like below to appreciate my help . . . Mark as solved  Accept as Solution


First Timer
Message 12 of 14

Thanks, that is very helpful, I will see if I can get another IP address!   I am pretty confident that is the problem


Emails works fine if I send using Microsoft exchange webmail, or the phone apps (via 4G).   (I am not using the talktalk mail system at all.)  


Community Star
Message 13 of 14

Hi SPJ62


Many IP addresses can get onto block lists. You can try to acquire a new IP address by powering off your router for 30 minutes and hope that the Edge router offers a new IP address.


Important that you use the recommended settings in an email client or you can use webmail of course.


Select here: Sign in to TalkTalk Mail

Enter your email address and password, select Sign in.


Test the sending via webmail.


The email client software / app may require updating to replace out of date settings.


On updating the email software incoming, outgoing and some advanced server settings, you'll possibly be asked to accept a new certificate (yes, accept) and to enter the email password so have the current password ready. Tick to save the password before entering it.


Supported* email client and app settings are:

Account Type  IMAP (recommended) or POP3
Username Full email address
Password Email password
Incoming mail server
Incoming Port (IMAP / POP3) 993 / 995
Incoming Connection Security SSL/TLS (Use SSL on for mobile)
Outgoing mail server
Outgoing Port 587
Outgoing Connection Security STARTTLS (Use SSL on for mobile)
Outgoing Authentication Required Yes
Authentication Method Normal Password

Apple/Mac Mail Connection Security is use TLS/SSL


* Email clients, apps and devices that do not support secure mail using a minimum of TLS1.2 connection security are not supported.

GondolaVolunteer 2017-2022

  Like below to appreciate my help . . . Mark as solved  Accept as Solution