email support

Ask us about your TalkTalk email account and Webmail.

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Trouble with draft and sent saving of email with attachment in email client (IMAP)

Conversation Starter
Message 7 of 7

So, I don't write many emails given disability, no work, no social life, and being too brain fogged by prescription meds to think coherently most of the time. But I just needed to send an email to some company with proof of my eligibility for a rebate due to my benefits status. Fairly short email with an attached 7.2 Mb pdf (actually scans of the three pages of a letter from the benefits people). I use Thunderbird (latest 78.0) as my email client and was sending via my address, with my address and the two ones and the one all configured and connecting and fetching incoming mail fine via IMAP.


After adding the attachment, but while still typing (slowly) I started to get an error message from Thunderbird (hereafter TB) That it couldn't save a draft in the IMAP linked Sent folder for the account, asking me if I wanted to save it just in a local folder instead. This repeated at the autosave draft interval. After finishing and posting, I then got a similar TB error that it couldn't save in the Sent folder. Retrying several times, a progress indicator showed it progressing part way then stalling, then finally giving the error message again. Finally I gave up and had it save locally, which caused TB to create a new local TakTalk Sent folder, separate from the IMAP one. I then tried to both move and copy the sent email from the local folder to the IMAP Sent folder, but it always failed. I checked my TalkTalk account via webmail and there was no sign of the sent message there in the Sent folder (as expected as it wasn't in the Sent IMAP folder here).


Further, I put TB offline, and moved the sent email from the local folder to the proper IMAP sent folder - which it did right away. But when I then put TB online again, it struggled to sync the Sent folder, and the end result was simply that the email disappeared from the Sent IMAP folder here again (and of course did not appear in the Webmail interface). Indeed I almost lost the email (should have copied, not moved), but luckily running Repair on the local Sent folder got it back again (in the new, unwanted local Sent folder, not the account's subscribed and synced one).


But then in TB I created a copy of the sent email from which I removed the attachment. THAT version, identical apart from the removed attachment, immediately successfully moved into the IMAP Sent folder here AND appeared in Webmail, showing it was copied to the TalkTalk server.


So ... what gives, TalkTalk? Emails with attachments (below some size limit? 25MB?) can be sent via SMTP from a client, but won't be accepted as uploads to the account's draft and sent folders on the server and therefore also can't be saved locally to the synced draft and saved folders? Is it attachments of any size, or just up to some limit (well below the max size for sending emails)? Is this a deliberate policy and configuration, or a bug? How exactly are you expecting users who use clients via IMAP (which you recommend over POP3) to deal with keeping drafts and Sent copies of emails that have attachments? A casual email to a friend, it might not matter, but THIS one it's important for me to have a copy, and it shouldn't need me to jump through hoops saving locally, copying, deleting the attachment, then moving that to the Saved folder (none of which is possible for the auto save of draft copies in case of power loss or whatever).


While I didn't get an error on the actual send, I'm now worried that it may not have actually gone to the recipient - which could cost me £140 towards my heating costs next year - which is a lot given my only income is the ESA benefit.




Message 1 of 7

Hi DavidB-E,


Thanks for the further information, we'll let you know when we have an update about this.


Glad to hear the ukgateway issue is now resolved


Conversation Starter
Message 2 of 7

OH, BTW and utterly unrelated, Ady, my OTHER problem that I've been complaining about all year has been fixed - yay! A little while ago there was an email from TalkTalk about how email mailboxes not tied to accounts would have to be paid for or be shut down. This, I thought, is what I was afraid of with the address (and alias) that I still use from my original dial-up ukgateway, then Tiscali account. I had attempted many times before to add the ukgateway mailbox to my Tiscali account (which has 3 other mailboxes, and which provides my broadband and phone), but it always just produced an error message saying that mailbox was already connected to another account - the original UKGateway one - which I haven't been able to login to (the account, not the mailbox) all year, apparently indicating that account was gone even though the mailbox was still there. Dejected, I nevertheless made what I expected to be a futile last attempt to connect the mailbox to my Tiscali/TalkTalk account ... and the whole account interface had changed ... and this time, with whatever had changed besides the look of the interface, it let me connect the address (with alias) to my Tiscali account just like that! I'd tried so many times earlier this year, always with the same failure message, I just sat stunned looking at the success unbelievingly for at least a minute in shock.


So bye-bye to the old ukgateway account, but with the mailbox now safely moved to my active Tiscali/TalkTalk one. Finally I can stop worrying about losing that mailbox and address. 😁


Message 3 of 7

I have some further information to narrow down the parameters of the problem. As this was a very important email for me, enabling me to get a small addition to my ESA benefit, I became worried that maybe it hadn't been delivered - even though I didn't get an error message about the send operation, only the failure to save the drafts and the Sent copy. So I decided to send a second email with an added intro (in case they did get the first one) above the original email's content, with the document I was trying to attach in the form of 3 jpegs instead of the one pdf (which had just contained the 3 jpegs, each a scan of a page of a letter from the benefits people).


Starting off, I used 'Edit as a new message' on the copy of the original saved in a local folder (size 9.8 MB), then deleted the pdf and instead attached the 3 jpegs. Thunderbird reported the 3 jpegs as attachments were 6.8 MB total (1 MB less than the 7.8 MB it showed as the size of the pdf attachment as an attachment rather than the size of the pdf on disk). Thunderbird then successfully auto saved the draft to the IMAP drafts folder, also showing up checking via webmail. After turning my original text into a quote, I then started typing a new section above that, and a second draft auto save happened successfully. But before i had finished a 3rd draft autosave failed repeatedly, as with all attempted draft and sent auto saves of the original. The eventual error message was a timeout due to the TalkTalk mail server stopping responding before the save of the draft was complete. So the failure started as I was still typing more added text, at some point when the total email size had reached some value above 7.8 MB (the size of the last successfully saved draft) but below the 9.8 MB of the original


I then reduced the quality of the jpegs (greyscale scans) from 100% to 90%, which reduced the combined total attachment size as shown in TB to 2.2 MB, quit the email composition, started again doing exactly the same except for attaching the lower quality jpegs instead of the higher quality ones after removing the original pdf (before first auot save of a draft), and this time the drafts all auto saved to the IMAP draft folder, and after I sent it a copy was successfully created in the Sent IMAP folder - email size 3.0 MB as compared with the original 9.8.


It therefore appears that:


1) It's not a problem with all attachmentss.

2) It's not a problem just with pdfs.

3) It IS a problem when the email size passes some value above 7.8 MB but below 9.8 MB.


Again, note that this is NOT a problem with the SMTP server, which I know has a size limit but it's higher than this, and the original email did appear to be sent, it's just the drafts and Save copy that failed to upload to my mailbox (and therefore wouldn't appear in the subscribed IMAP folders in TB either). This is a problem with the IMAP connection uploading draft and sent copies to the mail server where the mailbox is. It might perhaps be relevant that I have TalkTalk ADSL broadband over a phone line, not fibre broadband. And of course upload speeds on ADSL broadband are much slower than download speeds (I've never had fibre so not had reason to see if fibre broadband has the same kind of slower upload than download). The issue appears to be that when uploading via IMAP to the IMAP folders, the server stops responding before the upload is complete, which might actually be a TIME limit problem rather than a size one - i.e the apparent size limit actually being that above a certain size the upload takes too long passing some time limit. And if it IS a time limit, then if you and the engineers have fibre connections rather than ADSL phone line broadband, you - and all the customers with fibre - will NOT see this problem, only ADSL phone line users trying to move/copy emails into IMAP folders that are big enough to hit the upload time limit problem.


Message 4 of 7

I'll ask the question for you, but you're the only person to have asked this question since we migrated everyone to the new platform. I'll post back as soon as I hear anything. 

Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.

Message 5 of 7

According to the size column the toal email size is is 9.9 MB, where total email size without the attachment is 3 kB, and the attachment alone is 7.6 MB. So the whole email with attachment is, I believe, well within the size limit to send, and indeed it appeared to send - at least I got no error indication for the send. The problem is that I got error messages every time it tried to auto save it as a draft after I added the attachment but before I'd finished composing the text, and on every attempt to save a copy in the IMAP sent folder after sending (but it saved fine in a local non-IMAP folder); and every attempt to copy or move it from a local folder into the IMAP Sent folder.


Which still leaves my actual question: is there a size limit, different from the actual send  size limit, for saving drafts and Sent copies with IMAP? Or will it simply not save a draft or sent IMAP copy with an attachment of any size? And is this  known and configured, or is it a bug?


Support Team
Message 6 of 7

Hi DavidB-E, have you checked the actual size of the total draft? Emails are often much bigger than you'd think. 

Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.