email support

Ask us about your TalkTalk email account and Webmail.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Trouble with new emails

Julian18
Participant
Message 26 of 26

Since my emails have updated to the new talktalk emails, most of my emails which are not spam have started automatically going into my spam folder.

0 Likes
25 REPLIES 25

Message 21 of 26

Hi Julian18 

 

Those links have been disabled. Are you using the Google Chrome browser?

 

Settings > Advanced > Privacy & Security > Content Settings > Popups & Redirects - Allow

 

What else is running? An email client like Outlook that's tagging the emails as Spam? Internet Security like Norton AntiSpam or similar? Other Add-ons / Extensions?

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

0 Likes

Message 22 of 26

Have checked, there is no filter rule running and cannot right click on any links as they all have a line through them greying them out.

0 Likes

Message 23 of 26

Hi @Julian18 

 

There has to be a filter rule running that's pushing those emails back to the Spam folder. 

 

Right click on links.

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

0 Likes

Message 24 of 26

The emails still go back to spam as soon as I mark them not spam, can't click on any links in emails either. Not impressed so far!!!!

0 Likes

Gondola
Community Star
Message 25 of 26

Hi @Julian18 

 

I'd say mark the email as Not Spam. The email will be moved into the Inbox. 

 

Check the Filter rules for anything that could be identified with the move of those emails to the Spam folder. 

 

Menu > Settings > Email (or Mail) > Filter rules.  To troubleshoot, disable rules that file to the Spam folder to see if normal mailbox operation is restored.

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

0 Likes