cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

Upgrade your legacy mail settings

Reply
Gondola
Community Star

We're seeing a number of users of mail domains in the tiscali.co.uk family, for example lineone.net and tinyworld.co.uk not receiving mail messages because their email client software is still using out of date (not recognised) legacy server host name and maybe insecure port settings. The email client software / app requires updating to replace the out of date settings. The tiscali.co.uk server name is supported so doesn't need an update but worth checking that secure ports and connection security are set. 

 

The TalkTalk email settings for all mailboxes managed by TalkTalk Consumer are those given in the TalkTalk Mail Support Hub help page Email settings - IMAP & POP3.

 

On updating the email software incoming, outgoing and some advanced server settings, you'll possibly be asked to accept a new certificate (yes, accept) and to enter the email password so have the current password ready. Tick to save the password before entering it.

 

Supported* email client and app settings are:

 

Account Type  IMAP (recommended) or POP3
Username Full email address
Password Email password
Incoming mail server mail.talktalk.net
Incoming Port (IMAP / POP3) 993 / 995
Incoming Connection Security SSL/TLS (Use SSL on for mobile)
Outgoing mail server smtp.talktalk.net
Outgoing Port 587
Outgoing Connection Security STARTTLS (Use SSL on for mobile)
Outgoing Authentication Required Yes
Authentication Method Normal Password

 

Apple/Mac Mail Connection Security is use TLS/SSL

 

It's also important to make sure the email address is added to a TalkTalk Consumer customer MyAccount to avoid restriction to webmail only access and possible deletion.

Email not showing in MyAccount

 

* Email clients, apps and devices that do not support secure mail using a minimum of TLS1.2 connection security are not supported.

GondolaVolunteer 2017-2021

 Add Likes below to appreciate my help . . . and if I offered a solution Best Answer