email support

Ask us about your TalkTalk email account and Webmail.

Showing results for 
Show  only  | Search instead for 
Did you mean: 


First Timer
Message 5 of 5

I use Pegasus to access emails sent to Pipex and Talktalk. Talktalk is working well on send and receive. Pipex stopped a week or so ago. So far Talktalk have not been able to help.

When trying to use Pegasus I get the message "host claims either username or password invalid." followed by a time out. Can anyone help?


Message 1 of 5

Hi Chris,

How are you getting on, has Gondola's advice helped?



Message 2 of 5

Hi Chris


The password is the same as the one you use with Pegasus. I've never used the product so cannot advise on whether the password is available to the user.


The first thing is to check that pipex mail is working via the webmail login.


If you cannot find the password then the TalkTalk Community Team will need to authorise a password change for you currently.


Please do a quick check that your Community Profile includes in Personal Information (Click here) your name, current landline 'phone number and an alternate number (mobile recommended) and address with postcode (location). Then scroll down to Private notes to add the Pipex email address with any relevant other notes and finally save changes.


TalkTalk will need to verify you are the registered mail user. You'll get an initial response from a TalkTalk (TT Staff) team member here.


You'll then receive via Community Personal Messaging (the envelope icon by your avatar top right of this page when signed in to Community), a data verification request prior to authorising the password change.


You'll then get a call on your mobile and a team member will run a security check and give you the new password.


When the Pipex mailbox is migrated to the TalkTalk Mail platform and you have a MyAccount as a MailPlus or Broadband customer then you'll be able to manage the password change there or set up Reset Details for when you forget the password and need to reset it.

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Mark as solved + Accept as Solution

Message 3 of 5

I visited the link. It does say business. However the dsl account was set up many years ago and I haven't accessed it direct for years. Been using pegasus to do that so no idea what my password is.


Community Star
Message 4 of 5

Hi Chris


Please sign in to pipex webmail and check the mailbox is working.


Have you recently received an upgrade message from TalkTalk about the upgrade to the TalkTalk Mail platform?

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Mark as solved + Accept as Solution