email support

Ask us about your TalkTalk email account and Webmail.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

e-mails not secure

Casper2
First Timer
Message 5 of 5

When I go to my mail, the padlock shows, but then on some e-mails it will change to not secure, this has me worried, I am not computer savvy. Thank you.

0 Likes
4 REPLIES 4

Message 1 of 5

Hi Casper2, thanks for posting back to let us know it's sorted. 

 

I've marked Gondola's post as best answer to help others find the answer more speedily and to recognise the assistance provided. 

 

 

Ady


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


Message 2 of 5

Hi Casper2 

 

Nice move.

 

That keeps control in your hands.  You can choose to view content that you're sure you can trust and not have potentially untrustworthy content being shown to you.

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution

Message 3 of 5
Thank you Gondola for your reply, I have unticked the box and that has worked, the padlock stays on.

Gondola
Community Star
Message 4 of 5

Hi @Casper2 

 

The TalkTalk Mail site is secure as the https secure connection and the closed padlock assure you.

 

Some images used in the advertising are causing the yellow triangle advisory message just so you're aware that some image content for advertising is displayed is from an http website.  If you use an ad-blocker browser add-on or extension you'll not come across this issue.

 

Secure connection but insecure images.png

 

 

The TalkTalk Mail content is fully secure so you should have no concerns. As for whether clicking on advertising maintains your privacy that may depend on what you've agreed to share in the Manage Cookies section of the Main Settings Menu - triple line icon on the right of the header.

 

If an email has insecure content such as images hosted on a http server then when you select the mail message the browser will also flag up that the connection is insecure and any information might be seen by others.

 

Browsers are simply flagging up to you that some mail messages may have 'mixed content' with some content hosted on http servers.  If in any doubt don't open the mail message.

 

TalkTalk Mail includes a setting to Allow pre-loading of externally linked image content. So for extra security you may choose to untick that setting. If the setting is unticked and the mail contains such images then the message detail view will have a Show images button and a comment "External images have been blocked to protect you against potential spam."

 

Main settings icon top right (triple lines) > Settings > Mail (in the side panel) > Untick Allow pre-loading of externally linked images.

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution