email support

Ask us about your TalkTalk email account and Webmail.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

error 10060

Tedbel84
First Timer
Message 3 of 3

I have 2 laptops, running latest Thunderbird on same router

Win10 laptop will send mail from port 25, no problems

Win 7 laptop, with same settings as far as I can see, stopped sending mail 2 weeks ago.

I get this message. 

" the mail server sent an incorrect greeting. cannot connect to SMPT server

92.142.132.16 ; 25.    connect error 10060  "

 

Looking on line, this seems to be an old problem, but non of the cures seem to work here.

Have tried changing port 25 for 587 & back again with no improvement.

Cannot decide if the problem is with Thunderbird or Talk Talk settings.    Advice please

0 Likes
2 REPLIES 2

Ady-TalkTalk
Support Team
Message 1 of 3

Hi Tedbel84, Gondola will be able to help you sort this. 

 

Ady


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


Gondola
Community Star
Message 2 of 3

Hi @Tedbel84 

 

Is this for TalkTalk.net emails or another TalkTalk managed domain? Some legacy domains do still use port 25 and insecure email and require a connection to the TalkTalk network to obtain network authentication for sending.

 

The Mail Support Hub has the Email Settings for the TalkTalk managed domains.

 

Unless you are using a legacy domain like onetel.com, or other domains in the onetel family, toucansurf.com or homecall.co.uk then you should be using secure ports IMAP 993, or POP3 995 and SMTP 587 with the appropriate connection security and normal password as authentication. 

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution