email support

Ask us about your TalkTalk email account and Webmail.

Showing results for 
Show  only  | Search instead for 
Did you mean: 

legacy Tiscali email doesnt work with new mail settings??

First Timer
Message 6 of 6



I'm aware that the mail settings get changed every now and then and i Comply. i have a lineone and tiscali account. 


ive also signed up and paid for the talktalk mail plus scheme to retain my email address and a couple of others (if theyre attached to my account), which is the case.


a week or so ago both my accounts lost mail server connection. ive just got my lioneone account back on with the new mail setting using IMAP (always a IMAP user).


the problem is my other Tiscali account, it errored in "my account" wouldnt let me reconfigure its settings (disabled due to incorrect settings - please reconfigure account). so i deleted it and tried to add it again.....


i must say i think ive tried the recommended settings around 10 times and permutations of the settings around 20 times?? 


nothing works 😞 the main issue seems to connecting to the incoming mail server. the same account using the same credentials worked signing into the webmail at talk talk..


so if anyone can suggest anything new to add a second email to "my account" im happy to try.


this tiscali account has been active around 10 years..


Message 1 of 6

Ah, I see you found the MyAccount and sorted the issue whilst I was away keying in the solution.

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution


Message 2 of 6

Hi Morromj 


We're not quite on the same page regarding MyAccount. The MailPlus MyAccount should list all your mailboxes.


If not added to a MyAccount then the credentials will not be recognised when adding to an existing webmail email account as a secondary added email account.


Managing your email in My Account is the help advice and email not showing in your my Account is the section to expand.

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution


First Timer
Message 3 of 6

Hello All

Problem solved. the issue was the second tiscali account was not registered in mailplus with my account. i thought by just adding it as another account on my main account it would be recognised. i didnt know there was another area within my account to register multiple email accounts as part of mail plus.


I've know done this and all email settings recommended now work. 




First Timer
Message 4 of 6

Hello, thanks for thjis and answers in oerder below


i can sign in via web portal with old (and newly created password) i can see and send / receive mails via this route


edited the reset information, which was good anyway.


i still cannot add the same account as a secondary account to "my account" it says it was disabled due to invalid credentials?


i changed password as per your advice, if im honest we was already compliant, but changed any way. we can log into webmail with these credentials, but cannot add as a secondary account in my account or via iPhone using recommended settings IMAP


seems the "my account" and add account are unhappy with the Tiscali account? it is accessible via web portal and has been live for 10 years on android and iPhone. 


Community Star
Message 5 of 6

Hi Morromj 


First make sure that the tiscali email address is added to your MailPlus customer MyAccount and check that you can sign in to TalkTalk Mail webmail. 


Select here: Sign in to TalkTalk Mail

Enter your tiscali email address and password, select Sign in.


Then staying signed in follow the guide to make sure you do have password recovery options (Update your reset details via the main menu) and that these are set up so that you can upgrade the password.


Upgrade your legacy mail password


Then follow the guide to update the password and server host names, port and security settings for your tiscali email client.


Upgrade your legacy mail setting


Let us know if that's working now.

GondolaVolunteer 2017-2021

 Like below to appreciate my help . . . Best answer is + Accept as Solution