cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

2 router setup sagecom fast 5364(main) Bt homehub 6(slave)

Reply
11 REPLIES 11
Joe Muzzi
Chatterbox

Hi, I have been trying for days to setup up a second router (Bt HH6A) in my shed. My main router is sagecom fast 5364.

 

So I have run a cat 6 cable from lan port 1 on main router to lan port 4 on Bt router.

 

Before plugging cat 6 cable into Bt router, I have set the Bt router address to 192.168.1.2 with dhcp turned off as well as it’s firewall, the sagecom(main router) is 192.168.1.1 with a dhcp pool range 192.168.1.10 - 192.168.1.253

 

when connecting cat6 cable to the 2 routers, I have invalid IP address, could some please advise what I am doing wrong?

 

also I cannot change dhcp on main sagecom router as although it says it has saved when I go back to dhcp setting they are the factory default setting?

KeithFrench
Community Star

There is a bug in the current version of firmware in the hub that prevents changing the DHCP pool, this should be fixed in the next version of firmware, currently under test. For the time being, although wrong, why don't you set a static address on the BT router of 192.168.1.254, unless you have an excessive amount of devices, I can't see the DHCP server ever trying to allocate .254 to another device.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Joe Muzzi
Chatterbox

Hi Keith, thank you for your reply, I have changed the Bthh6 address to 192.168.1.254, I have also turned the dhcp and firewall off on bthh6, turned off bthh6 router, connected cat6 cable to port 4 turned back on HH6 and still not getting any connection to the hh6, TalkTalk router is working fine

KeithFrench
Community Star

When you say that you have turned off the BT router, do you mean that you have put it into bridge mode?

 

More basically, is the link status shown as UP over the Cat6 cable at both ends? If so, do devices connected to the BT router get allocated the correct IP address, mask, default gateway & DNS server? If so, can they ping 192.168.1.1?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Joe Muzzi
Chatterbox

As far as I am aware there is no bridge mode for Bt hh6, I have been following this guide for using hh6 as secondary wireless ap/switch 

 

https://community.bt.com/t5/Home-setup-Wi-Fi-network/UPDATED-How-to-setup-HH6-as-Wireless-AP-or-Swit...

 

 

Joe Muzzi
Chatterbox
I have no connection on wireless or lan
KeithFrench
Community Star

But what about the link over the Cat6 cable between the two routers, is that UP. In the hub go to:-

 

Dashboard > See Wi-Fi Settings > Manage Advanced Settings > Ethernet gear icon

 

 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Joe Muzzi
Chatterbox

Ok so I have checked that setting on sagecom and port 1 states DOWN, I also tried port 4 and when connected with cat6 that goes to down as well, but both ports working with different cable to other devices. And just to confirm my cat6 cable running to the shed is working fine in my Ethernet port on computer

KeithFrench
Community Star

Then there are two possibilities:-

 

1. Port 4 on the BT router is the wrong port

2. The BT router does not support auto-negotiation of cable type, but this may need further explanation.

 

I have no idea if either is correct, as I do not know the BT router at all.

 

Most TT equipment does support auto-negotiation of cable type, this means that you can use a straight cable or a reversal Cat5e/6 cable & it will work out the pinouts to use.

 

If the BT router does not support this, then you will have no choice but to make up a reversal cable yourself. This will involve cutting the RJ45 connector off one end of the cable & crimping a new one on, so as the pinouts are then correct for a reversal cable. I would suggest you try this on a short cable that you are not worried about first, with the two routers close together.

 

See this guide on crossover cables:-

 

https://www.computercablestore.com/straight-through-crossover-and-rollover-wiring

 

 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

KeithFrench
Community Star

There is one other possibility - your Cat6 cable is too long, it can only be 100M in length maximum.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Joe Muzzi
Chatterbox

Hello again, I think I may have found the problem. As you suggested I ran a normal cat5 from main router to slave router, it was then picked up by both routers. So I then tested my cat6 in a Netgear gigabyte switch, the light never came on tested the cat5 and that worked, so thought it must be the cat6 cable (which is only 25m long btw).

 

only I have the cat6 connected to a coupler upstairs, so I disconnected the cat6 cable from the coupler and connected the cat5 cable to the coupler and connected to my Netgear switch the cat5 was also not detected by the switch, but if I test the cable on the other end of the coupler (from main router), this is detected in the switch

 

so my conclusion is that the coupler is causing an issue with the cable being recognised in my router/switch. Which is odd as the exact same setup cable coupler cat6 is providing 76mbps straight into my Ethernet connected pc

KeithFrench
Community Star

Glad you have found the problem.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they?