cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Can't remote desktop from work computer into home computer

ANSWERED
Reply
11 REPLIES 11
rmd_2000
First Timer

Hi,

I have faster fiber and Huawei HG633 router. Also I am using a desktop computer with windows 8.1 pro and wifi connection to the router.
I can login from home to my working computer through VPN and after by remote desktop.
I can't do it the other way around, from work to my home computer. My work computer has Windows 7.1

I have followed your instruction for Huawei HG633 router as I found in the talktalk blog:
1. Rezerved DHCP (it gave me 192.168.1.2) - actually I didn't know where to use it after it was setup...
2. Open a new port forwarding for TCP or TCP&UDP 3389 to 3389 (internal & external)
I could not specify/associate an IP address for this port forward opening as I've seen in other than HG633 router video guides.

On the computer:
1. Allowed Remote conection (in My computer, properties, remote tab)
2. I have assign IP address 192.168.1.13 , default gateway 192.168.1.1, preffered DNS 192.168.1.1 on my wireless IPv4 device (internet access)
3. Make sure the fireall allows Remote desktop (domain & public); also made inbound rules to allow port 3389 TCP and 3389 UDP in.
4. Have checked my external/public IP (that I try to use from the work computer for remote desktop at home)
5. Made sure that my home computer windows login account has a password.

Can you help, please?

Thank you

rmd_2000
First Timer
Sorry I've post it twice, could find my first post and I thought it failed to post.
KeithFrench
Community Star

If you want to include screenshots of the port forwarding config you have used on the router, I will check this for you. You may need to request the OCEs disable scam protection on your account as well.

 

Have you tested to see if the TCP port is open from a device connected locally to your router by going to:-

 

https://portchecker.co/

 

 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

KeithFrench
Community Star

I have just tested TCP port 3389 & it opens OK on my PC via the TalkTalk Wi-Fi hub. So you may not need scam protection disabled. It could be the router config on your HG633?

 

However, I am opening the port on my PC, rather than using RDP, as my OS does not support RDP.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

KeithFrench
Community Star

On re-reading your initial post, another possibility is are you trying to test RDP from another device locally connected to your router, by going out to the internet & back into the router's public IP address. If so, this is classed as loopback traffic & is blocked by all TalkTalk routers, as they consider this a security risk. If the TCP port reports open via the port checker, you need to test it from another broadband, or other internet access, not your own

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

rmd_2000
First Timer

Yes, I've checked now and port 3389 is opened. The following attaching's shows the port forward settings.

Capture 2.PNGCapture.PNG

 

 

rmd_2000
First Timer

Yes, you are right. I was connected to the work computer when I tried to log back in my home computer. I will try it from work the computer tomorrow. I guess it is a loop connection.

KeithFrench
Community Star

If that is open, then unless you are falling foul of the loopback traffic block, or some internet restrictions from work, it should work. The HG633 unusually forwards to the MAC address not the IP address, so whatever you looked at is wrong.

 

One other point with the HG633, does the  PC connect directly to the router (WiFi or Ethernet), or does it go via some sort of extender or switch?

 

You said that you had statically assigned an IP address to the PC, did you do that on the PC itself, or did you just use one of the router's DHCP Reservations? If done on the PC, did you set the default gateway & subnet mask correctly and exclude your chosen address from the DHCP IP address range on the router?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

rmd_2000
First Timer

I've checked the MAC address from the router port forwarding and it is the computer's one (actually the wireless stick I use to connect to the wifi router).. HG633 does not use an IP address, yes.

It's my computer, the USB TP-LINK wireless stick and connected straight to the router (wifi).

The static IP address gateway and DNS are set on my computer, as in the picture.

I've made a rezervation on the router but I didn't use it anywhere, didn't know where.Capture 3.PNG

rmd_2000
First Timer
The IP static is on the computer and I didn't exclude anything from the DHCP IP addresses from router.
rmd_2000
First Timer
I've done it now. Skipped the my static IP from the computer on the router.
KeithFrench
Community Star
Solution

Remove the DHCP address reservation for the PC from the router, you must use one or the other, but not both.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they?